Linux-Noob Forums

Full Version: Running .BIN files
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hello there, I've been having problems running a .bin file, specifically trying to load the Java sdk onto Ubuntu. When I try to run it, I get the error "error while loading shared libraries: cannot open shared object file: No such file or directory".


I don't know much about Linux, but I know that libstdc++6 is up to date. I have no idea if it'll help anything though.


Any help would be greatly appreciated



Try doing this from a terminal:


sudo apt-get install libstdc++6
sudo ln -s /usr/lib/ /usr/lib/

(found here)


And then run the install again. I imagine this problem is probably due to old versions of libstdc++ being used by the Java SDK installer.


Let us know if this solves the problem. :)

Thanks for the response :)


Unfortunately, it did not solve the problem. Do you think that it would work if I tried an older java sdk?


Edit: I tried another one and it worked just fine. I'm guessing Sun messed up that file ;)