Linux-Noob Forums

Full Version: 30 days with Ubuntu 7.04 (feisty fawn)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Day 6


Hi again folks, well here I am on Day 6 with Ubuntu, and it must be said after reading the news and checking my mail I can safely say that things feel just fine with the distro, I mean, it could have been Fedora, or SLED10 or some other distro, and rather than notice what distro it was I was just doing my usual thing, and that's a good sign. True, every distro has it's advantages and some have disadvantages but I cannot say that Ubuntu is a bad distro at all. What I do feel is that the marketing hype that has propelled it to the masses in a very short period of time is a bit overstated and that many users that move to Ubuntu from Windows may be in for a surprise that they were not suspecting. However, those same users would probably also run into similar issues with other popular linux distros.


Anyways, on with the show.



I've setup printing using the System/administration/printing tool. It wasn't difficult, however no linux driver was listed for my printer (Dell Color Laser 3100cn) so I chose Generic postscript, and that worked fine, but to get it to print over the network I had to configure it as Unix Printer (LPD).


[Image: post-1-1178565924.png]


The printing itself, works fine and is fast so no complaints even with the generic driver.




I clicked on Places/Network and I could see a Windows network icon, clicking on that showed me two workgroups, and clicking on one of them showed what computers were in that workgroup. I then logged on to one of them using my Windows XP username/password and that was it, I was able to browse the files easily, so much so that I decided to watch a music video (to test the network speed over wireless connection 11mb/s). Unfortunately Totem came back to haunt me except this time with the following error:-


"Totem could not play 'smb://home-0ca963252f/C$/music/lalala.avi'. There is no input plugin to handle the location of the movie.


So, google seems to be aware of that error and while I look around, I decide to copy the file locally from the networked windows box, to my desktop. That worked nicely and fast, well not lightning speed but good enough.


Once the file was on my desktop, i noticed that gnome showed what the video was (thumbnail) so i double clicked on it and guess what ? Totem played the file with no problem. I dunno sometimes.


[Image: post-1-1178567456.png]


To double check, I tried another file (this time mpg) and it too failed with the odd error.


[Image: post-1-1178567764.png]

Day 5 - Desktop effects, hrmm I have no interest in this but its good to see that it was easy to add it :)Help files and information are basically the core of assistance for new users. The lowering of the hurdle is an important thing, hopefully people will experience the same feel you had, that the help was within a short reach.


Day 6 - Sometimes hype is needed to draw attention and whilst I agree that maybe the hype of ubuntu is greater than others, the fact is it has brought Linux to the attention of an audience that maybe the others weren't reaching. Printing has grown to become a simple enough setup on all the dirstros now, CUPS has grown to be an amazing replacement for the old lpd system. But as it is, lpd still works and still provides good access to printers ;) Networking is generally a breeze, Linux is after all a system that almost expects a network. It is odd what happened to totem, I think that its actually a fault within gnomevfs (after browsing google), so it would affect any application that attempted to open a file across the network. The only way around this is either to directly mount the share as a network drive or do as you did, copy the file across. That is very much a pain, whats the point in browsing with smb:// only to result in something you can't open. Oh well.


Another good couple of days in your 30 day challenge.

Day 7


Firefox crashed.


Well I had two Firefox's open, one with 6 tabs, the other with 3. In addition I had nautilus open still browsing the network shares from yesterday (it did copy the files over nicely) and had started to play one of the music videos in Totem when I remembered that I wasn't pleased with the video quality of Totem's rendering of the videos. Basically there was little black spots every on the video (worked fine in fedora with mplayer) so I 'll try to see if I can get mplayer working later.


Anyway, while I started a new video and multitasked back to Firefox I noticed the desktop going black (except for my terminal).


[Image: post-1-1178651517.png]


I also noticed the system was going slow (lots of hdd activity) so I guessed I was low on ram and that it was reading from the swap file. While attempting to type free in the terminal firefox disappeared. I've seen this behaviour before with Firefox in linux on this laptop so it was no surprise, usually happens after a few days of use but all the same it's annoying.


I blame the Firefox crash on Shockwave flash player, typing about:plugins in Firefox shows me this.


Quote:Shockwave Flash 

File name:

Shockwave Flash 9.0 r31


MIME Type Description Suffixes Enabled

application/x-shockwave-flash Shockwave Flash swf Yes

application/futuresplash FutureSplash Player spl Yes

and to get Firefox to act weird, all I have to do is view a video on youtube then right click within the video window, scroll up and down through the available options and then move my mouse outside the video window (but still within the Firefox window) and click. Once I do that, the hdd's goes into meltdown and I lose control of my box. NOTE: I had this exact same issue in Fedora on this machine.


Getting mplayer to work


I had mplayer installed previously but when I clicked on a video with it, I got an error.


'Fatal Error! Error opening/initializing the selected video_out (-vo) device).'


Google gives me results that apply to Suse, Linspire, Xandros, but not Ubuntu (doesn't anyone using Ubuntu also use mplayer ?).


While reading google's results I start mplayer in cli mode and point it to the file in question, this time it starts up and plays the video !. Strange. Even more strange is the same black dots every 20 millimetres or so in horizontal/vertical alignment, so it's not just a Totem issue, something is borked with the video codecs.


I'd show you a screenshot of the dots in question but when I take a screenshot of any video all I get is a green background within the video player, probably something to do with rendering of the video itself.


So, after trying out lots of options withing mplayer (preferences)


[Image: post-1-1178653220.png]


nothing made a difference to the dots.


[Image: post-1-1178653204.png]


Finally I thought that maybe Beryl was causing the issue, so I turned it off by re-enabling Gnome (metacity) and low and behold, the video that was still playing with dots, now had no dots ! (to re-enable Gnome metacity, right click on beryl manager, choose 'select window manager' and then choose 'Gnome (metacity)'.


I still however get the fatal error when opening a video with mplayer via it's internal browser or right clicking in nautilus and selecting open with 'Mplayer Movie Player'. So I can only play video's with mplayer via cli.

Sounds like some weird problems you have.. actually.. I've done most of this the easiest way with installing my needed apps for multimedia/chat/office via automatix!


Check out and try it! :)it's good and easy ;) hehe

Day 8


Mplayer continued


It seems that the mplayer issue above (error when trying to open a video via a right click and choose 'Open with Mplayer movie player' is weirder than I thought. If i double click on the same video it opens in Totem and plays fine. Changing the video prefs in Mplayer didn't help so I decided to try chaning how it opens. I right clicked a video, and chose 'open with other application', I then clicked on the 'use a custom command' triangle and typed 'mplayer' with no quotes.


Guess what, now when i right click on a video, I get the option to open with the following choices (text in parenthesis added by me)


Quote:Open with Movie Player (totem)Open with mplayer (the one i just added)

Open with Mplayer Movie Player (the one that doesnt work)

Open with other application

If i select mplayer from the list above, the video opens with no problems.



Configuring Evolution with gmail


Ok, that's enough video stuff for now, time to access my gmail via Evolution. But first I sign in to the gmail account and click on 'settings' and then 'Forwarding and pop'. I set it to Enabled (Enable POP for all mail (even mail that's already been downloaded)).


[Image: post-1-1178737585.png]


Once done, I fire up Evolution. And configure pop and smtp with the settings in the screenshots below (most choices are optional, so look at them carefully.)


[Image: post-1-1178737594.png]


[Image: post-1-1178737614.png]


[Image: post-1-1178737987.png]


[Image: post-1-1178777170.png]


Cool stuff really !

Day 9.


Today I decided to take it easy and not configure/fix/install anything, so I tested bittorent in Ubuntu, and guess what, it worked, first time, with no questions.


But, that did lead me to check the firewall status which apparently is non-existant.


Quote:root@anyweb-laptop:~# iptables -LChain INPUT (policy ACCEPT)

target prot opt source destination


Chain FORWARD (policy ACCEPT)

target prot opt source destination


Chain OUTPUT (policy ACCEPT)

target prot opt source destination

why is there no iptables rules defined at all, seem strange, i'll look into that later.


here's my current ubuntu desktop for those that care :)


[Image: post-1-1178833920.png]




Day 10


Can I watch TV ?


I tested an Avermedia USB 2.0 TV box today with ubuntu. It wasnt recognised by the OS as far as I could tell via lsusb, and I

tried some guides on [/url][url=] but it seems that my particular model of USB tv tuner is not supported (not listed on their Hardware compatibility list)


I may look into this later, but either way I'm not too fussed as I also had the same issue with it via FCR6, I plugged it into the Ubuntu laptop to see if anything had changed, and well, nope, nothing has changed. And yes I did try the System/Administration/Restricted Drivers Manager but it just told me nothing was found (more or less).


[Image: post-1-1178921694.png]




I do have a supported USB tv tuner box though, so I may get to try that one yet :)

Docking the laptop


I will now attempt to dock the laptop and I presume the correct way of doing that would be to boot the laptop while docked, but for the laugh I'm going to dock it while still powered on and with some uptime since my last reboot


Quote:anyweb@anyweb-laptop:~$ uptime 00:01:01 up 7 days, 9:20, 2 users, load average: 0.16, 0.29, 0.16

ok the docking didn't go to well, when i connected it (powered on) to the docking station, there was no video on the external lcd so I cycled through the FN F8 keystrokes and still nada. finally I restarted X with ctrl_alt_backspace and now, when I pressed FN F8 the laptops lcd went black and that was it, no video externally either. So I tried those keystrokes some more times and nothing was happening. Finally I pressed the power button on the laptop with the hope that it would gracefully shutdown (seeing as I could not SEE anything). But that didn't work, so I had to do a dirty shutdown by holding in the power button.


However, once I powered it back on, I have video on the external LCD while docked, so that is cool and i'm writing this now while docked. However, no audio, so I check all settings in Volume Control 2.18.0 and nothing makes a difference until I connect my speaker cable direct to the laptop.



New updates available


I have new updates available so I choose to install them.


[Image: post-1-1178921873.png]


The updates look interesting and are related to HAL (hardware abstraction layer) so this could be exciting. While I'm waiting for the updates to install I move a window around (as xgl is now re-enabled after the reboot) and really enjoy the wobbly effects that it offers especially seeing it on a 19 inch LCD. The spinning cube desktop effect is also very nicely done even on this lowly laptop.


[Image: post-1-1178922471.png]


More on the mplayer issues


I've now figured out that the mplayer issue isn't mplayer but gmplayer. If i start a vid via mplayer in CLI it works fine, if i try the same one in CLI I get an error.


[Image: post-1-1178925274.png]


see this


Quote:anyweb@anyweb-laptop:~/backup/music videos$ mplayer some_music.m2vMPlayer 2:1.0~rc1-0ubuntu9