Linux-Noob Forums

Full Version: HowTo Install VMware on FC6 & Cent0s
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Well , if you have tried like me to install the VMware Server or WorkStation on a new kernel [ kernel 2.6.20-1.2948.fc6] like me & had no luck !!!

Here is the Solution.


I have tried this tutorial which is at [/url] which did not work for me cause whoever wrote that article is outdated now & will not work for you either (with all my respect to whoever wrote it) .


If you have a new kernel like me kernel 2.6.20-1.2948.fc6 (where they are talking about 2.6.19-1.2911.fc6), this is how i got it working.


1)Register to get your free serial number(s) to start using VMware Server & then download

2)Make sure you have the following or updated

* gcc

* gcc-c++

* kernel-devel

* xinetd

& if i was in your shoes i will also install



which will not harm your box (FC6 includes GCC 4.1 compiler. Some applications will NOT compile in GCC 4.1)

install GCC 3.4 to allow compiling applications which do not yet support GCC 4.1


yum install

3)uname -r & it should spit 2.6.20-1.2948.fc6

4)rpm -q kernel-devel & should spit [kernel-devel-2.6.20-1.2948.fc6]

5) rpm -i /home/user_name/VMware-server-1.0.3-44356.i386.rpm

6)VMWare server is installed & for your box to use it you will have to configure it

7)$ su -


this is what you get:


In which directory do you want to install the mime type icons ?


What directory contains your desktop menu entry files? These files have a .desktop file extension. [/usr/share/applications]


In theory , you can valid & confirm each section.


8)End of installation if you have no errors !!! your configuration should look like this

The configuration of VMware Server for Linux for this

running kernel completed successfully.


You can now run VMware Workstation by invoking the following command:





--the VMware team


as root


/etc/init.d/xinetd start


9)Now if everything went wrong & the aborted to configure with something like this


Using 2.6.x kernel build system.

make: Entering directory `/tmp/vmware-config0/vmnet-only'

make -C /lib/modules/2.6.19-1.2911.fc6/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

make[1]: Entering directory `/usr/src/kernels/2.6.19-1.2911.fc6-i686'

CC [M] /tmp/vmware-config0/vmnet-only/driver.o

CC [M] /tmp/vmware-config0/vmnet-only/hub.o

CC [M] /tmp/vmware-config0/vmnet-only/userif.o

/tmp/vmware-config0/vmnet-only/userif.c: In function 'VNetCopyDatagramToUser':

/tmp/vmware-config0/vmnet-only/userif.c:629: error: 'CHECKSUM_HW' undeclared (first use in this function)

/tmp/vmware-config0/vmnet-only/userif.c:629: error: (Each undeclared identifier is reported only once

/tmp/vmware-config0/vmnet-only/userif.c:629: error: for each function it appears in.)

make[2]: *** [/tmp/vmware-config0/vmnet-only/userif.o] Error 1

make[1]: *** [_module_/tmp/vmware-config0/vmnet-only] Error 2

make[1]: Leaving directory `/usr/src/kernels/2.6.19-1.2911.fc6-i686'

make: *** [vmnet.ko] Error 2

make: Leaving directory `/tmp/vmware-config0/vmnet-only'

Unable to build the vmnet module.


For more information on how to troubleshoot module-related problems, please

visit our Web site at "" and



Execution aborted.


10) Rendez vous at this page & download [url=] which is a patch to fix this problem where it will save you a great big headache.

11)put this file in your /home/user_name & -> tar -xzf vmware-any-any-update109.tar.gz

12)After the file has been extracted, change to the /vmware-any-any-update??? directory and run:

13) ./

14)During the configuration, which automatically follows right after the patch has been applied, I accepted all of the defaults to the questions that are asked, meaning the paths to directories that were listed,

Thanks a ton, Johnny06.


Followed your instructions and it worked like a charm.


Note: i did receive a different error when running


here's what I received:


Building the vmmon module.


Using 2.6.x kernel build system.

make: Entering directory `/tmp/vmware-config4/vmmon-only'

make -C /lib/modules/2.6.20-1.2948.fc6/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

make[1]: Entering directory `/usr/src/kernels/2.6.20-1.2948.fc6-i586'

CC [M] /tmp/vmware-config4/vmmon-only/linux/driver.o

In file included from /tmp/vmware-config4/vmmon-only/linux/driver.c:80:

/tmp/vmware-config4/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or