Linux-Noob Forums

Full Version: No Ethernet or Mouse
You're currently viewing a stripped down version of our content. View the full version with proper formatting.



I am very much a n00b, so please bear with me. I installed Slackware 10.2 onto an ancient system (P1/75, 32MB RAM, 3GB HD), hoping to do some simple webserver work on it. I was able to install Slack. However, neither my Ethernet or mouse will work.


I am currently using a Logitech PS/2 mouse. I tried using an Intelimouse, and the driver and the mouse stopped the keyboard from working (not even the Caps LED would respond). This occured as soon as the driver for the Intelimouse were loaded. When I start X-Windows, the mouse will not respond, and a similar situation occurs, and my keyboard goes dead, not even the LEDs responding. I have to power cycle the system. When it boots up, it says the file system is forced, procedes to fix it, and reboots again. After this, it will return to a promt, and matter procede as normal. This is not the biggest isue. However, I would like to know how to fix it.


The Larger problem is the fact that I cannot get my Ethernet to work. It is an ISA Ethernet card. This is likely the problem, as I have found postings dealing with PCI Ethernet cards, but none dealing with their ISA cousins. I have tried:


ifconfig eth0 up


The response is:


eth0: unknown interface: No such device


So obviously, the issue is that the drivers, etc. for my Ethernet card are not installled. However, I am uncertain as to how to fix this.


Your assistance is greatly appreciated.

Are you sure a Pentium 75 can handle X Window System?


Do you know what make or model your ethernet card is? I don't think I can help, but one of these experienced people I'm sure could use that information. ;)



I would suggest not running X Windows on the machine as it will lag your machine due to the 75 processor

if however you need a X Windows I would suggest running something like FluxBox, Blackbox


What you will need to do about the network card is find out the make search for driver and

possibly recompile your kernel.