Linux-Noob Forums

Full Version: Muddled in Installation of tar.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi am a newbie, this is my second day on linus so please forgive me if I am asking a stupid question.


I wanted to install xorg-x11-devel-6.7.0-9.i386.rpm so i downloaded and did the following


1) $ rpm -i xorg-x11-devel-6.7.0-9.i386.rpm

error: Failed dependencies:

fontconfig-devel >= 2.1 is needed by xorg-x11-devel-6.7.0-9

2) so dowmloaded and ran $ rpm -i fontconfig-devel-2.2.3-5.i386.rpm

error: Failed dependencies:

fontconfig = 2.2.3 is needed by fontconfig-devel-2.2.3-5

3) so downloaded fontconfig-2.2.3.tar.gz and did the following:

$ gunzip -c fontconfig-2.2.3.tar.gz | tar xvf -

$ cd fontconfig-2.2.3

$ ./configure

$ make

$ make install


All this seemed to run fine

so tried step 2) again, $ rpm -i fontconfig-devel-2.2.3-5.i386.rpm and got the same error message, so why can't it find fontconfig?





first off welcome to the forums


secondly, what distro are you using, and what version


and lastly, exactly what are you trying to accomplish here ? there are easier ways i'm sure,


more info please