Linux-Noob Forums

Full Version: Toshiba Satellite Pro TE2000 Modem Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hello averyone as I typed in the subject line I have Toshiba TE2000 laptop and it has

internal modem installed already. I have checked the modem chipset

trough the WinXP and it says ;

PCI/VEN-10B9& DEV-5450&SUBSYS-00011179

I found that this is a Agere kind of modem from the following internet





It has this description on that page:



Chip Description:

Agere Systems AC97 Modem



Could you please help me to find out what kind of driver I can install in this

Fedora2 (linux). I searched nearly a month still unsuccessful.

I really need to have this modem working in my computer.

I am going to paste the ModemData.txt output here and also I tried to install slmodem driver here how I tried and the results. Please have a look at it.


Hello Jacques,

As you told me I have run the scanModem and this is the output of the







The most recent update of scanModem accessed at

should ALWAYS be used!! Current UPDATE=2004_Sept_27

URLs to cogent advice are regularly entered and updated, and your

problem may be solved therein.

If further help is needed, send a description of your problem to:

with this ModemData.txt Attached, using the following in the email

Subject Line:

scanModem, redhat kernel 2.6.5-1.358

Always send this ENTIRE Modem/ModemData.txt. It includes subtle

diagnostic ouputs needed to best guide you.

If your PC is a laptop, please provide Make and Modem information.


For instructions to UNSUBSCRIBE from,

send an email to:


-------------- System information ------------------------

redhat Fedora Core release 2 (Tettnang)

on System with processor: i686

supported by kernel: 2.6.5-1.358


The kernel-2.6.5-1.358 was compiled with CONFIG_REGPARM, providing more

compact and faster code.


assembled with compiler: 3.3.3

with current System compiler GCC=3.3.3

Modem symbolic link is: /dev/modem -> /dev/ttySL0

----active COMM services are ------------

eth0 Link encap:Ethernet HWaddr 00:A0:D1:D0:AA:BF

inet6 addr: fe80::2a0:d1ff:fed0:aabf/64 Scope:Link

This COMM mode should be closed before using the modem, or DNS services

may fail.


Under 2.6.n kernels, there is currently modem support by:

the more expensive Controller chipset modems using the open source

serial code

Conexant software downloaded through

SmartLink slmodem drivers, including USB hardware

USB modems using the Open Source acm.ko driver

Lucent DSP (digital signal processing) chipsets but NOT:

soft modems ( though some are supported by slmodem drivers)

Intel 536EP and 537 modems

For all other modems, support projections are not available as of this



PPP support module bsd_comp.ko not found!

Resident PPP support modules are properly uncompressed .

======= Fedora code changes =======

SmartLink slmodem-2.9.n, Lucent/Agere DSP, Intel 536ep and 537 drivers

are already Fedora competent. For usage of winmodems with the

kernel-2.4.nn Fedora releases a change in the serial-like driver code

of WinModems is necessary.

See for guidance:

Basically , the line:

if ((tty->count == 1) && (state->count != 1)) {

should be changed into:

if (atomic_read(&tty->count) == 1 && state->count != 1) {

This works in the ltmodem code too. See

An error about "rs_close" during compiling is a signature that the

fedora fix is needed


Beginning with Fedora 2 kernel-2.6.6-1.427, kernel-headers needed for

compiling drivers are provide at: /lib/modules/kernel-version/build/

Thus upgrading above kernel 2.6.5-1.358 to 2.6.6-* is Stongly


redhat is not yet providing pre-compiled drivers for WinModems


An AC97 modem codec was not detected


------ dmesg slamr filtered -------

slamr: module license 'Smart Link Ltd.' taints kernel.

Evidently a slamr compatible soft modem is not installed

---------- End SIL_id section ---------------


Path to lspci is: /sbin/lspci

--------- lspci scan ----------------


00:00.0 Host bridge: ALi Corporation M1644/M1644T Northbridge+Trident

(rev 01)

00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller

00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)

00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c3)

00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link

Controller Audio Device (rev 01)

00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]

00:08.0 Bridge: ALi Corporation M7101 PMU

00:0a.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]

(rev 0d)

00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to

Cardbus Bridge with ZV Support (rev 32)

00:11.1 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to

Cardbus Bridge with ZV Support (rev 32)

01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1

(rev 82)



Though not displayed, an embedded soft modem may reside in this Audio


Multimedia audio controller: ALi Corporation M5451 PCI AC-Link

Controller Audio Device (rev 01)

which sadly is not supported under Linux.



A modem was not detected among the above PCI devices.

This indicates that the modem, if present has a non-standard or ISA


Please follow the directions in Modem/General.txt for identifying the

modem properties

when booting under Microsoft Windows. Also access any documentation


on yourchipset. Guidance can only be provided AFTER

the chipset and/or its drivers have been identified.


======= PCI_ID checking completed ======



Analyzing information for PCMCIA device at PCI Bus 00:11.0

GREPping for an inserted PCMCIA modem with filter: ommunication


Analyzing information for PCMCIA device at PCI Bus 00:11.1

GREPping for an inserted PCMCIA modem with filter: ommunication

If a PCMCIA modem is currently inserted and the sockets activated by

/etc/init.d/pcmcia start

then the PCMCIA bridge is NOT transparent.


If the modem is known to have a Lucent digital signal processing


then PCMCIA.tar.gz variant assembled by Joern Wustenfeld is necessary,

rather than the standard ltmodem-8.26a9.tar.gz at

The following information blocks just query some ppp support items.


grep ppp /etc/modprobe.conf




Be sure to read the section about ppp related modules and aliases in


Be sure to read the Ethernet section of Modem/General.txt

DEVPPP=crw------- 1 root root 108, 0 Feb 24 2004 /dev/ppp


The current modem symbolic link is: /dev/modem -> /dev/ttySL0

The ports /dev/ttyS0 or 1,2,3 are for standard Controller chip modems



No devfsd.conf file found, indicated absense of the devfsd daemon


for device file system (devfs) symbolic link support.



---- dmesg queries -------

PCI: if you experience problems, try using option 'pci=noacpi' or even


apm: BIOS version 1.2 Flags 0x02 (Driver version 1.16ac)

apm: overridden by ACPI.

audit: initializing netlink socket (disabled)

toshiba_acpi: Toshiba Laptop ACPI Extras version 0.18

toshiba_acpi: HCI method: \_SB_.VALD.GHCI


The Modem/DriverCompiling.txt is a MUST READ,

if you are not experienced in configuring kernel-source/

or get "unresolved symbols" upon driver insertion.


Most recent WinModem fixes are in:




I tried slmodem-2.9.9 here is the steps I followed;


1)I change the Kernel dir to the following from the Makefile







and than

3) make install

[root@mail coskun]# cd slmodem-2.9.9/

[root@mail slmodem-2.9.9]# make install

make -C modem all

make[1]: Entering directory `/home/coskun/slmodem-2.9.9/modem'

make[1]: Leaving directory `/home/coskun/slmodem-2.9.9/modem'

make -C drivers KERNEL_DIR=/lib/modules/2.6.5-1.358/build

make[1]: Entering directory `/home/coskun/slmodem-2.9.9/drivers'

cc -I/lib/modules/2.6.5-1.358/build/include -o kernel-ver kernel-ver.c

make all KERNEL_VER=2.6.5-1.358

make[2]: Entering directory `/home/coskun/slmodem-2.9.9/drivers'

make modules -C /lib/modules/2.6.5-1.358/build


make[3]: Entering directory `/lib/modules/2.6.5-1.358/build'

Building modules, stage 2.


make[3]: Leaving directory `/lib/modules/2.6.5-1.358/build'

make[2]: Leaving directory `/home/coskun/slmodem-2.9.9/drivers'

make[1]: Leaving directory `/home/coskun/slmodem-2.9.9/drivers'

make install -C drivers KERNEL_DIR=/lib/modules/2.6.5-1.358/build

make[1]: Entering directory `/home/coskun/slmodem-2.9.9/drivers'

cc -I/lib/modules/2.6.5-1.358/build/include -o kernel-ver kernel-ver.c

mkdir -p /dev

mknod -m 600 /dev/slamr0 c 212 0 ; mknod -m 600 /dev/slamr1 c 212 1

; mknod -m 600 /dev/slamr2 c 212 2 ; mknod -m 600 /dev/slamr3 c 212

3 ; echo -n

mknod -m 600 /dev/slusb0 c 213 0 ; mknod -m 600 /dev/slusb1 c 213 1

; mknod -m 600 /dev/slusb2 c 213 2 ; mknod -m 600 /dev/slusb3 c 213

3 ; echo -n

make install KERNEL_VER=2.6.5-1.358

make[2]: Entering directory `/home/coskun/slmodem-2.9.9/drivers'

install -D -m 644 slamr.ko /lib/modules/2.6.5-1.358/extra/slamr.ko

install -D -m 644 slusb.ko /lib/modules/2.6.5-1.358/extra/slusb.ko

/sbin/depmod -a

make[2]: Leaving directory `/home/coskun/slmodem-2.9.9/drivers'

make[1]: Leaving directory `/home/coskun/slmodem-2.9.9/drivers'

install -D -m 755 modem/slmodemd /usr/sbin/slmodemd

rm -f -rf /var/lib/slmodem

install -d -D -m 755 /var/lib/slmodem



[root@mail slmodem-2.9.9]# /usr/sbin/slmodemd --country=AUSTRALIA

error: mdm setup: cannot open dev `/dev/slamr0': No such device or


error: cannot setup device `/dev/slamr0'


Here I am having trouble, I don't really know the reason.

Help me please..


I also created that symbolic link by the folloving code


[root@mail sbin]# ln -s /dev/ttySL0 /dev/modem


So that is the story, have a look and please tell me what am I

doing wrong and what should I do to fix it up.

Thank you for your time.




I will appreciate your help.