Linux-Noob Forums

Full Version: can i change my $TERM?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hey guys.


when i was using rh9 i'd lauch my terminal then i'd right click to get to the settings then i'd change my session to a linux console session. I liked using linux console because of the vim color coding. Comments were much easier to read on a black background because the color of the comment was changed to a teal/auqa looking color instead of the darker blue color of the default scheme.


i can't seem to get that to work on fedor2. ideally i'd like to use that linux console as my default, so i'm wondering:


a. does anyone know what i'm talking about


b. if so, how would i get that done?



if you are running rh9 go to your terminal and right click over the terminal, and this should bring up a settings menu. If you go settings->session you should see something like linux console or linux session - select it. now open a file that has comments #comment or /** comment */ - the color scheme is a little different and a lot more friendlier on the eyes when you have a black background.



do i sound nuts? or does anyone know what i'm talking about?



thanks for the help,



nevermind...after all this time wondering all i had to do is $ TERM=linux.







if you right click in the console and choose


'edit current profile' then click on 'colors' there are options in there for linux console (palette) and system themes or you can create your own


i dunno if that helps but hopefully it will :)





i now have $TERM=linux but it seems to break vim. when i open a file i get crazy garbled text, and when i write i don't get anything.


does anyone know why using the linux terminal doesn't play nice?