Linux-Noob Forums

Full Version: How do I enable jcomponent called universe?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The terminal states "You will have to enable component called 'universe'" when I try to install ndiswrapper.

you must be using Ubuntu,


here's how I did it here and I quote


Quote:Configuring Ndiswrapper 

As I'm new to Ubuntu (but not new to linux), It seemed that I had to first enable the universe. This wiki advised me to open the Synaptic Package Manager tool (gui front end for apt), unfortunately I didn't get very far as point 3 referred to the following:-


"In the new dialog that opens, click the Add button on the right side of the dialog."


However no such dialog appeared [screenshot]. It did turn out that 'community-maintained open source software' was already selected (and that was what I needed), so I continued on with the next step and became root:-


sudo -i


I downloaded this file and proceeded to do as follows:-


root@anyweb-laptop:~# apt-get install bcm43xx-fwcutter


That will prompt you 'yes/no' to install the firmware, so obviously answer yes if you want to get wireless to work. Next (and this is where the linux-noobs and windows users must be getting confused) it's time to patch the firmware so I did this:-


anyweb@anyweb-laptop:~$ sudo bcm43xx-fwcutter -w /lib/firmware ~/Desktop/wl_apsta.o


And off it went....done yet ? no. Next I had to do this...


anyweb@anyweb-laptop:~$ sudo bcm43xx-fwcutter -w /lib/firmware/`uname -r` ~/Desktop/wl_apsta.o


Nearly there, it tells me I need to bookmark this link and then reboot, so I do that. After the reboot everything looked the same and I was still connected to the internet via a wired connection, I removed the wired connection and issued:-


anyweb@anyweb-laptop:~$ modprobe bcm43xx


I then proceeded to disable the Wired connection in Network manager. Now ifconfig shows me eth1 (the wireless nic) and I can ping wirelessly, it worked ! *phew*