Linux-Noob Forums
add 3D enabled nvidia drivers to SLED 10 - Printable Version

+- Linux-Noob Forums (
+-- Forum: Distro Noob (
+--- Forum: SUSE (
+--- Thread: add 3D enabled nvidia drivers to SLED 10 (/thread-1847.html)

add 3D enabled nvidia drivers to SLED 10 - anyweb - 2006-08-17

if you register with Novell, then the nvidia drivers will be automagically added to yast download sources, however if you don't register with novell then you need to do the following:-



start up yast by


* click on Computer/More applications/System/yast


now that you are in the yast tool (enter the root password when prompted)


* click on 'Software' and then 'Installation Source', then click on 'Add'


add the following to the dialog box


Quote:Protocol: FTPServer Name: :

Directory on Server: novell
click accept to make the changes. 

Now take a wee pause, open up a terminal (console, try clicking on Computer/more applications/system/gnome terminal)


once in the terminal, lets find out what kernel we are running by typing


uname -r


the results should look like this (or similar, mine says SMP because of the hyperthreading CPU's)


Quote:anyweb@linux-j5hr:~> uname -r2.6.16.21-0.8-smp

Make a note of your kernel as next we want to get the nvidia drivers, so


* click on 'Software Management'



and search for the following


once found, select it by putting a 'check' mark in the empty box beside it 

next search for the following



Yast will probably list three kernels, choose the one that corresponds to the results from uname -r above (so in my case I chose the SMP kernel)


Select it, and click accept, then accept the nvidia license.


Once done, restart X (ctrl/alt/backspace) and notice any difference ? you can try and enable XGL now but remember to read the following first from [/url][url=]


Quote:NVIDIA / proprietary driver "nvidia" 

* OpenGL acceleration does not work well with Composite being active. This option in /etc/X11/xorg.conf should be disabled if it had been enabled before. Note: Xgl supports Composite anyway, even if it is disabled in xorg.conf. FBO's can be used with this driver instead of pbuffers for XVideo acceleration. Enable this by changing

DISPLAYMANAGER_XGL_OPTS="-accel glx:pbuffer -accel xv:pbuffer" to

DISPLAYMANAGER_XGL_OPTS="-accel glx:pbuffer -accel xv:fbo" in /etc/sysconfig/displaymanager. (The Desktop Effects tool sets this option by default.)

see below :-) running xgl with Nvidia Geforce 6800GT and its so smooth :)







<a class="ipsAttachLink ipsAttachLink_image" href="<fileStore.core_Attachment>/post-1-1155845578.png" data-fileid="639">[img]<fileStore.core_Attachment>/post-1-1155845578.png[/img]</a>