Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X config issues, mouse & keyboard do not respond on startup.
#1

Today I rebuilt my slackbox. I have tried 'X -configure', then starting X with the config it generates, when I do this I get a mess on the screen and the mouse and keyboard do not work.

 

I have my old XF86Config and also the new generated xorg.conf but I'm not sure how to compare them or what to change, as I am still relatively noob.

 

They are as follows:XF86Config.txtxorg.conf.new.txt

 

Any insight into what the problem is would be much appreciated, I'm keen to get this baby up and running!

 

Thanking you... In anticipation...



Attached Files
.txt   XF86Config.txt (Size: 6.96 KB / Downloads: 38)
.txt   xorg.conf.new.txt (Size: 2.81 KB / Downloads: 48)
Reply
#2

Quote:Today I rebuilt my slackbox. I have tried 'X -configure', then starting X with the config it generates, when I do this I get a mess on the screen and the mouse and keyboard do not work. 

I have my old XF86Config and also the new generated xorg.conf but I'm not sure how to compare them or what to change, as I am still relatively noob.

 

They are as follows:XF86Config.txtxorg.conf.new.txt

 

Any insight into what the problem is would be much appreciated, I'm keen to get this baby up and running!

 

Thanking you... In anticipation...
 

 

 

i dunno wtf the new file supposd to be, it seem fukked beyond belief... this mess you may / may not (i believe) seeing on screen is sure to no screens beign configured properly on the new xorg.conf .... try pointing X to the old .. xfree config ... X -config /etc/location_of_config_file ...

 

 

and oh... upload your xorg log too.....

 

it's at .. /usr/var/log/Xorg.0.log

Reply
#3

Quote:<blockquote data-ipsquote="" class="ipsQuote" data-ipsquote-contentcommentid="8588" data-ipsquote-username="ladeh_k" data-cite="ladeh_k" data-ipsquote-contentapp="forums" data-ipsquote-contenttype="forums" data-ipsquote-contentid="2331" data-ipsquote-contentclass="forums_Topic"><div>
Today I rebuilt my slackbox. I have tried 'X -configure', then starting X with the config it generates, when I do this I get a mess on the screen and the mouse and keyboard do not work.

 

I have my old XF86Config and also the new generated xorg.conf but I'm not sure how to compare them or what to change, as I am still relatively noob.

 

They are as follows:XF86Config.txtxorg.conf.new.txt

 

Any insight into what the problem is would be much appreciated, I'm keen to get this baby up and running!

 

Thanking you... In anticipation...
 

 

 

i dunno wtf the new file supposd to be, it seem fukked beyond belief... this mess you may / may not (i believe) seeing on screen is sure to no screens beign configured properly on the new xorg.conf .... try pointing X to the old .. xfree config ... X -config /etc/location_of_config_file ...

 

 

and oh... upload your xorg log too.....

 

it's at .. /usr/var/log/Xorg.0.log



</div></blockquote>
 

 

Here's the log.

 

 

Xorg.0.log.txt

 

I had previously tried to point X to the old XFree config but it doesnt like it. If you look down the bottom of the log, I tried again just so you could see for yourself.

 

Thanks.



Attached Files
.txt   Xorg.0.log.txt (Size: 59.16 KB / Downloads: 46)
.txt   XF86Config.txt (Size: 6.96 KB / Downloads: 38)
.txt   xorg.conf.new.txt (Size: 2.81 KB / Downloads: 48)
Reply
#4

ahhaa - it appears that your mouse works with whatever config file you just pointed Xorg to.

 

however the current kernel, i believee have removed support for teh legacy "keyboard driver" - - try replacing the line for the driver "keyboard" with

 

Driver "kbd" ....

 

it's

 

 

 

after this is fixed. you'll wanna replace the graphics driver...

 

just ignore this for.... let's focus on getting X up and running :-)

Reply
#5
slackware has xorgsetup
Reply
#6

First off .. put this file in /etc/X11/xorg.conf

 



Code:
# ServerLayout sections.
Section "ServerLayout"
Identifier  "Simple Layout"
Screen      0  "Screen 1" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

# Files section.  This allows default font and rgb paths to be set
Section "Files"
RgbPath    "/usr/X11R6/lib/X11/rgb"
FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
FontPath   "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath   "/usr/X11R6/lib/X11/fonts/CID/"
FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic/"
ModulePath   "/usr/X11R6/lib/modules"
EndSection

# Module section -- this  section  is used to specify
Section "Module"
Load  "dbe"
Load  "record"
Load  "type1"
Load  "freetype"
Load  "glx"
Load  "extmod"
Load  "dri"
Load  "glx"
Load  "xtrap"
EndSection

# Core keyboard's InputDevice section
Section "InputDevice"
Identifier    "Keyboard1"
Driver    "kbd"
#    Option     "XkbRules"      "xfree86"
#    Option     "XkbModel"      "pc101"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""
EndSection

# Core Pointer's InputDevice section
Section "InputDevice"
Identifier    "Mouse1"
Driver    "mouse"
Option "Protocol"    "imps/2"
Option "Device"      "/dev/input/mice"
#  Option  "Device"  "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection

# Monitor section
Section "Monitor"
Identifier  "My Monitor"
HorizSync   30.0 - 70.0
VertRefresh 50.0 - 160.0
#DisplaySize      330   250
#VendorName   "GSM"
#ModelName    "775FT Plus"    
#Option        "DPMS"
EndSection

# Graphics device section
Section "Device"
Identifier  "VESA Framebuffer"
Driver      "vesa"
EndSection

# nVidia?
Section "Device"
  Identifier  "nvidia0"
  Driver      "nv"
  VendorName  "nVidia Corporation"
  BoardName   "NV28GL [Quadro4 980 XGL]"
  BusID       "PCI:1:0:0"
EndSection

# Screen sections
Section "Screen"
Identifier  "Screen 1"
Device      "VESA Framebuffer"
#  Device     "nvidia0"
Monitor     "My Monitor"
DefaultDepth 24
Subsection "Display"
    Depth       8
    Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
    Depth       16
    Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
    Depth       24
    Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
    Depth       32
    Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection




 

 

There are a couple of sections in there that I have put "options" on :)

 

Like:



Code:
Device "VESA Framebuffer"
#Device "nvidia0"




 

You can switch from the basic driver (vesa) to the nvidia driver (nv) by commenting the first line and uncommenting the second.

 

Also:



Code:
Option "Device" "/dev/input/mice"
#Option "Device" "/dev/mouse"




 

If your mouse doesn't work, switch those and see if it does then :)

 

There is also some extra options with the Monitor and Keyboard, that aren't required but could be useful for tuning.

 

Anyway, hope that helps ladeh_k :)

Reply
#7
Thank you SO much znx! You rock!
Reply


[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:


Users browsing this thread: 1 Guest(s)