Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updating KDE 3.3 to 3.4 in Mandrake 10.2
#1

Hey guys,

Just wondering if anyone has had an issue upgrading KDE 3.3 to KDE 3.4 in Mandrake 10.2 (or LE 2005 whatever you prefer to call it). I am using Konstruct to install the KDE but I get this at the termination of the failed install...

 

=> `download/cyrus-sasl-2.1.21.tar.gz'

Resolving ftp.kde.org... 131.220.60.97

Connecting to ftp.kde.org[131.220.60.97]:21... connected.

Logging in as anonymous ... Logged in!

==> SYST ... done. ==> PWD ... done.

==> TYPE I ... done. ==> CWD /pub/kde/stable/3.4.2/src ... done.

==> PASV ... done. ==> RETR cyrus-sasl-2.1.21.tar.gz ...

No such file `cyrus-sasl-2.1.21.tar.gz'.

 

make[3]: *** [ftp//ftp.kde.org/pub/kde/stable/3.4.2/src/cyrus-sasl-2.1.21.tar.gz] Error 1

make[3]: Leaving directory `/home/steele/konstruct/libs/cyrus-sasl'

*** GAR GAR GAR! Failed to download download/cyrus-sasl-2.1.21.tar.gz! GAR GAR GAR! ***

make[2]: *** [download/cyrus-sasl-2.1.21.tar.gz] Error 1

make[2]: Leaving directory `/home/steele/konstruct/libs/cyrus-sasl'

make[1]: *** [dep-../../libs/cyrus-sasl] Error 2

make[1]: Leaving directory `/home/steele/konstruct/kde/kdebase'

make: *** [dep-../../kde/kdebase] Error 2

 

Is this just a server issue? Is there a way around it?

Appreciate any help!

 

PC:

-------------

AMD 2800+ Barton Core

1.5 GB DDR PC3200 RAM

60G & 80G Maxtor HD's

nVidia FX 5200 128MB Video Card

Hercules Muse LT Sound Card

WinTV PCI TV Board 881 Chip

Reply
#2

Quote:Is this just a server issue?  Is there a way around it?Appreciate any help!
 

ya looks like the file simply isn't there on the ftp server.

 

why install from source? why not just use RPM's... available on the very same ftp server...

 

[/url][url=ftp://ftp.kde.org/pub/kde/stable/3.4.2/Mandriva/10.2/i586/]ftp://ftp.kde.org/pub/kde/stable/3.4.2/Mandriva/10.2/i586/

Reply
#3

Ok I downloaded all of those RPM's but now it is saying they can't be installed...

I put them all in one folder and used this command...rpm -ivh *rpm and it gives me for example things like this..

error: Failed dependencies:

xscreensaver-gl is needed by kdeartwork-screensaver-gl-3.4.2-1mdk

tetex is needed by kdegraphics-kdvi-3.4.2-1mdk

gocr is needed by kdegraphics-kooka-3.4.2-1mdk

kdebase-progs <= 1:3.3.2 conflicts with kdelibs-common-3.4.2-1mdk

timidity-instruments is needed by kdemultimedia-kmidi-3.4.2-1mdk

ppp is needed by kdenetwork-kppp-3.4.2-1mdk

kdebase-common <= 1:3.3.2 conflicts with kdepim-common-3.4.2-1mdk

kdepim-common <= 1:3.4.0-10mdk conflicts with kdepim-kontact-3.4.2-1mdk

etc. etc. etc...........

 

what do I do with that??

Reply
#4

Quote:        xscreensaver-gl is needed by kdeartwork-screensaver-gl-3.4.2-1mdk        tetex is needed by kdegraphics-kdvi-3.4.2-1mdk

        gocr is needed by kdegraphics-kooka-3.4.2-1mdk

        timidity-instruments is needed by kdemultimedia-kmidi-3.4.2-1mdk

        ppp is needed by kdenetwork-kppp-3.4.2-1mdk
 

This means that you need other packages to install those parts of kde. You can move them out of the one folder and skip them for now, then later on download/install the missing packages.

 

Quote:        kdebase-progs <= 1:3.3.2 conflicts with kdelibs-common-3.4.2-1mdk        kdebase-common <= 1:3.3.2 conflicts with kdepim-common-3.4.2-1mdk

        kdepim-common <= 1:3.4.0-10mdk conflicts with kdepim-kontact-3.4.2-1mdk
 

Due to the fact that you have 3.3 installed.. you are causing conflicts my attempting to install two versions of KDE at the same time, you will need to remove the previous install to do manually install the new. Try this:

 



Code:
rpm --replacepkgs -ivh *rpm




 

See if that works..

 

(ty Jy ;))

Reply
#5

no dicee....I'll paste you everything in terminal see what you think...it's pretty big though

 

[root@localhost KDE 3.4.2]# rpm --replacepkgs -ivh *rpm

error: Failed dependencies:

xscreensaver-gl is needed by kdeartwork-screensaver-gl-3.4.2-1mdk

tetex is needed by kdegraphics-kdvi-3.4.2-1mdk

gocr is needed by kdegraphics-kooka-3.4.2-1mdk

kdebase-progs <= 1:3.3.2 conflicts with kdelibs-common-3.4.2-1mdk

timidity-instruments is needed by kdemultimedia-kmidi-3.4.2-1mdk

ppp is needed by kdenetwork-kppp-3.4.2-1mdk

kdebase-common <= 1:3.3.2 conflicts with kdepim-common-3.4.2-1mdk

kdepim-common <= 1:3.4.0-10mdk conflicts with kdepim-kontact-3.4.2-1mdk

automake1.7 is needed by kdesdk-3.4.2-1mdk

valgrind-plugins is needed by kdesdk-kcachegrind-3.4.2-1mdk

apmd is needed by kdeutils-3.4.2-1mdk

kdeutils-ark = 3.4.2-1mdk is needed by kdeutils-3.4.2-1mdk

cpufreq is needed by kdeutils-klaptop-3.4.2-1mdk

tpctl is needed by kdeutils-klaptop-3.4.2-1mdk

libnetsnmp.so.5 is needed by kdeutils-ksim-3.4.2-1mdk

mjpegtools is needed by kino-0.7.6-2mdk

ffmpeg is needed by kino-0.7.6-2mdk

smilutils is needed by kino-0.7.6-2mdk

libquicktime.so.0 is needed by kino-0.7.6-2mdk

libsamplerate-devel is needed by kino-devel-0.7.6-2mdk

libdv-devel is needed by kino-devel-0.7.6-2mdk

libgnomeui2-devel is needed by kino-devel-0.7.6-2mdk

libxml2-devel is needed by kino-devel-0.7.6-2mdk

devel(libart_lgpl_2) is needed by libkdeaccessibility1-kttsd-devel-3.4.2

-1mdk

devel(libfam) is needed by libkdeaccessibility1-kttsd-devel-3.4.2-1mdk

devel(libidn) is needed by libkdeaccessibility1-kttsd-devel-3.4.2-1mdk

libdbus-qt-1.so.1 is needed by libkdebase4-3.4.2-1mdk

kdeartwork <= 3.3.2-14mdk conflicts with libkdebase4-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdebase4-devel-3.4.2-1mdk

devel(libfam) is needed by libkdebase4-devel-3.4.2-1mdk

devel(libidn) is needed by libkdebase4-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdebase4-kate-devel-3.4.2-1mdk

devel(libfam) is needed by libkdebase4-kate-devel-3.4.2-1mdk

devel(libidn) is needed by libkdebase4-kate-devel-3.4.2-1mdk

libmdns is needed by libkdecore4-3.4.2-1mdk

libdns_sd.so is needed by libkdecore4-3.4.2-1mdk

libkdebase4 <= 1:3.3.2 conflicts with libkdecore4-3.4.2-1mdk

mandrakelinux-create-kde-mdk-menu is needed by libkdecore4-devel-3.4.2-1

mdk

devel(libart_lgpl_2) is needed by libkdecore4-devel-3.4.2-1mdk

devel(libfam) is needed by libkdecore4-devel-3.4.2-1mdk

devel(libidn) is needed by libkdecore4-devel-3.4.2-1mdk

libboost_python.so.1 is needed by libkdeedu1-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdeedu1-devel-3.4.2-1mdk

devel(libfam) is needed by libkdeedu1-devel-3.4.2-1mdk

devel(libidn) is needed by libkdeedu1-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegames1-devel-3.4.2-1mdk

devel(libfam) is needed by libkdegames1-devel-3.4.2-1mdk

devel(libidn) is needed by libkdegames1-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegraphics0-common-devel-3.4.2-1md

k

devel(libfam) is needed by libkdegraphics0-common-devel-3.4.2-1mdk

devel(libidn) is needed by libkdegraphics0-common-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegraphics0-kghostview-devel-3.4.2

-1mdk

devel(libfam) is needed by libkdegraphics0-kghostview-devel-3.4.2-1mdk

devel(libidn) is needed by libkdegraphics0-kghostview-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libexif) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libfam) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libgphoto2) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libgphoto2_port) is needed by libkdegraphics0-kooka-devel-3.4.2-1m

dk

devel(libidn) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libieee1284) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libsane) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libusb-0.1) is needed by libkdegraphics0-kooka-devel-3.4.2-1mdk

devel(libGLU) is needed by libkdegraphics0-kpovmodeler-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegraphics0-kpovmodeler-devel-3.4.

2-1mdk

devel(libfam) is needed by libkdegraphics0-kpovmodeler-devel-3.4.2-1mdk

devel(libidn) is needed by libkdegraphics0-kpovmodeler-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegraphics0-ksvg-devel-3.4.2-1mdk

devel(libfam) is needed by libkdegraphics0-ksvg-devel-3.4.2-1mdk

devel(libfribidi) is needed by libkdegraphics0-ksvg-devel-3.4.2-1mdk

devel(libidn) is needed by libkdegraphics0-ksvg-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdegraphics0-kview-devel-3.4.2-1mdk

devel(libfam) is needed by libkdegraphics0-kview-devel-3.4.2-1mdk

devel(libidn) is needed by libkdegraphics0-kview-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdemultimedia1-noatun-devel-3.4.2-1

mdk

devel(libartsgui_idl) is needed by libkdemultimedia1-noatun-devel-3.4.2-

1mdk

devel(libartsgui_kde) is needed by libkdemultimedia1-noatun-devel-3.4.2-

1mdk

devel(libfam) is needed by libkdemultimedia1-noatun-devel-3.4.2-1mdk

devel(libidn) is needed by libkdemultimedia1-noatun-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdenetwork2-common-devel-3.4.2-1mdk

devel(libfam) is needed by libkdenetwork2-common-devel-3.4.2-1mdk

devel(libidn) is needed by libkdenetwork2-common-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdenetwork2-kopete-devel-3.4.2-1mdk

devel(libfam) is needed by libkdenetwork2-kopete-devel-3.4.2-1mdk

devel(libidn) is needed by libkdenetwork2-kopete-devel-3.4.2-1mdk

devel(libxml2) is needed by libkdenetwork2-kopete-devel-3.4.2-1mdk

devel(libxslt) is needed by libkdenetwork2-kopete-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdepim2-common-devel-3.4.2-1mdk

devel(libfam) is needed by libkdepim2-common-devel-3.4.2-1mdk

devel(libidn) is needed by libkdepim2-common-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdepim2-kaddressbook-devel-3.4.2-1m

dk

devel(libfam) is needed by libkdepim2-kaddressbook-devel-3.4.2-1mdk

devel(libidn) is needed by libkdepim2-kaddressbook-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdepim2-kontact-devel-3.4.2-1mdk

devel(libfam) is needed by libkdepim2-kontact-devel-3.4.2-1mdk

devel(libidn) is needed by libkdepim2-kontact-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdepim2-korganizer-devel-3.4.2-1mdk

devel(libfam) is needed by libkdepim2-korganizer-devel-3.4.2-1mdk

devel(libidn) is needed by libkdepim2-korganizer-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdepim2-kpilot-devel-3.4.2-1mdk

devel(libfam) is needed by libkdepim2-kpilot-devel-3.4.2-1mdk

devel(libidn) is needed by libkdepim2-kpilot-devel-3.4.2-1mdk

devel(libpisock) is needed by libkdepim2-kpilot-devel-3.4.2-1mdk

devel(libreadline) is needed by libkdepim2-kpilot-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdepim2-ktnef-devel-3.4.2-1mdk

devel(libfam) is needed by libkdepim2-ktnef-devel-3.4.2-1mdk

devel(libidn) is needed by libkdepim2-ktnef-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdesdk1-devel-3.4.2-1mdk

devel(libidn) is needed by libkdesdk1-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdesdk1-kbabel-devel-3.4.2-1mdk

devel(libfam) is needed by libkdesdk1-kbabel-devel-3.4.2-1mdk

devel(libidn) is needed by libkdesdk1-kbabel-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdeutils1-common-devel-3.4.2-1mdk

devel(libfam) is needed by libkdeutils1-common-devel-3.4.2-1mdk

devel(libidn) is needed by libkdeutils1-common-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdeutils1-khexedit-devel-3.4.2-1mdk

devel(libidn) is needed by libkdeutils1-khexedit-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdeutils1-klaptop-devel-3.4.2-1mdk

devel(libidn) is needed by libkdeutils1-klaptop-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdeutils1-ksim-devel-3.4.2-1mdk

devel(libidn) is needed by libkdeutils1-ksim-devel-3.4.2-1mdk

devel(libart_lgpl_2) is needed by libkdevelop3-devel-3.2.2-1mdk

devel(libfam) is needed by libkdevelop3-devel-3.2.2-1mdk

devel(libidn) is needed by libkdevelop3-devel-3.2.2-1mdk

devel(libart_lgpl_2) is needed by libkdewebdev0-kommander-devel-3.4.2-1mdk

dk

devel(libfam) is needed by libkdewebdev0-kommander-devel-3.4.2-1mdk

devel(libidn) is needed by libkdewebdev0-kommander-devel-3.4.2-1mdk

Reply
#6

Two methods.. install the 'needed' items.. of move the RPMs that are missing out.. for example:

 



Code:
xscreensaver-gl is needed by kdeartwork-screensaver-gl-3.4.2-1mdk




 

Either install xscreensaver-gl

or

mv kdeartwork-screensaver-gl* needs/ (make the directory needs first)

 

Now for the 'conflicts':

 



Code:
kdebase-progs <= 1:3.3.2 conflicts with kdelibs-common-3.4.2-1mdk




 

Simply remove kdebase-progs.

 

Also I notice that a lot of -devel packages are in that list.. you don't need these to run KDE, so move them away as well:

mv *-devel* devels/ (make the directory again!)

Reply



[-]
Quick Reply
Message
Type your reply to this message here.


Forum Jump:


Users browsing this thread: 1 Guest(s)