Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Secondary hard drive disappeared?

Someone else set this computer up for me some time ago, but I had a secondary hard drive mounted that worked fine just yesterday, and has decided to permanently unmount itself. Worse, I had a lot of stuff on it that I would be crushed to lose!


So today I tried to download something to it, and at first it appeared normal, went through the directories no problem. But for some reason Firefox's download window didn't come up, and when I tried to go look at the file in the folder, suddenly the folder wouldn't load. The rest of the drive loaded, just that one folder wouldn't come up. Then later on the whole drive seemed to be empty. I'm really sure the file wasn't the problem, as not only do I trust the source, but I later downloaded it to my main hard drive, so I wouldn't be here now if it was an evil hard-drive killing file.


I did what every noob does--tried rebooting. Maybe it'll sort itself out, right? Well, it started off the boot with a message that it couldn't mount that hard drive, and offered F1 for continue, and F2 for setup. I chose setup initially, but I didn't know what, if anything, I should change, so I let it be. It now boots without mounting this drive.


I tried to run FSCK on it, but it doesn't seem like FSCK can find it. If I've even got the right place. The mount point seems to refer to /mnt/hdd, and that seems to refer to /dev/hdd1, but this....does not exist?


I suspect my main hard drive may actually be the corrupt one, as sometimes files seem to unexpectedly break or get lost. Could it be that some file involved in mounting this drive just up and vanished? How do I find out if this is so or not, and if it is, how do I replace/repair it? If I'm completely off base (wouldn't be the first time!) what do I do now? Are my files salvageable? In a word, help!


(btw, I am running Gentoo. It seemed like a good idea back when I had someone who liked me enough to fix things for me. >.>)


I would suggest booting from a live CD (if you have the disc that Gentoo is installed from, great) and testing the drives using fsck from there.


That way, if the first hard drive (boot drive) is a problem, you can run the system software independently from it and therefore test that too, as well as testing the secondary drive in an environment that you know works.


Unfortunately, though, from the sound of what you describe, at least one of the drives is failing... :(


Forum Jump:

Users browsing this thread: 1 Guest(s)