Jump to content

FXP with vsFTPd


Recommended Posts

hey im using vsFTPd and i cant get it to let me FXP from other ftp servers

it times out and takes the next file when if comes to this place in flashFXP command

 

[L] 226 Directory send OK.

[L] List Complete: 115 bytes in 0,73 seconds (0,2 KB/s)

[R] PASV

[R] 227 Entering Passive Mode (**,***,*,**,**,***)

[L] PORT **,***,*,**,**,***

[L] 200 PORT command successful. Consider using PASV.

[L] STOR lxr.mfog.sfv

 

i dont know why it does this but if somone have any ideas please post them.

if sombody could show me the .conf file they are using it would be much appriciated so i can compare it to mine.

 

anon_mkdir_write_enable=YES

anon_other_write_enable=YES

anon_upload_enable=YES

anonymous_enable=NO

check_shell=NO

dirmessage_enable=YES

force_dot_files=YES

listen=YES

local_enable=YES

local_umask=022

pasv_promiscuous=YES

port_promiscuous=YES

write_enable=YES

file_open_mode=7777

ftp_data_port=20

listen_port=21

pam_service_name=vsftpd

userlist_enable=YES

Link to post
Share on other sites

Are you behind a router? Or is there any firewall blocking ports? If so limit the port range for passive transfers using 'pasv_min_port' and 'pasv_max_port' and forward/accept the selected range.

Link to post
Share on other sites
Are you behind a router? Or is there any firewall blocking ports? If so limit the port range for passive transfers using 'pasv_min_port' and 'pasv_max_port' and forward/accept the selected range.

no firewall at all all ports everything is forwarded to the box its a rented dedicated server should i still try pasv_min_port and pasv_max_port if what should i try setting it to ??

Link to post
Share on other sites

It defines the port range the ftpd uses in order to make passive connections, for example 3000 and 3100. The setting tells the ftpd to use those 100 ports for passive connections. But if you're not behind a router or firewall all you normally need is pasv_promiscuous and port_promiscuous to allow data connections from foreign sources... :blink: The other server is configured fine? Post your entire configuration file if you don't mind.

Link to post
Share on other sites

anon_mkdir_write_enable=YES

anon_other_write_enable=YES

anon_upload_enable=YES

anonymous_enable=NO

check_shell=NO

dirmessage_enable=YES

force_dot_files=YES

listen=YES

local_enable=YES

local_umask=022

pasv_promiscuous=YES

port_promiscuous=YES

setproctitle_enable=YES

write_enable=YES

file_open_mode=7777

ftp_data_port=20

listen_port=21

pam_service_name=vsftpd

userlist_enable=YES

nopriv_user=test

 

 

thats my entire conf file

 

Does it mean anything that im able to FXP from my server but not to my server ??

Link to post
Share on other sites

Well I'm not using vsFTPd but your configuration looks fine to me. Again, are you sure the server you're trying FXP with is configured correctly? Is there anything in the logs (system logs, ftpd logs, ...)? Maybe you should join us on IRC, we can troubleshoot easier there.

Link to post
Share on other sites

I found out somthing wierd though if i use FlashFXP v 3.0.2 buil 1044 i works like a charm but if i use FlashFXP v 3.2.0 build 1080 it dosnt work thats a big proble, since alot of difrent ppl should be abled to FXP to and from my FTP server

 

any one knows anything about this problem ??

 

 

edit :

 

FTP command: Client "*.*.*.*", "SIZE motp.haf.svcd.nfo"

FTP response: Client "*.*.*.*", "550 Could not get file size."

FTP command: Client "*.*.*.*", "PORT *.*.*.*,195,153"

FTP response: Client "*.*.*.*", "200 PORT command successful. Consider using PASV."

FTP command: Client "*.*.*.*", "STOR motp.haf.svcd.nfo"

FTP response: Client "*.*.*.*", "425 Failed to establish connection."

FAIL UPLOAD: Client "*.*.*.*", "/-/motp.haf.svcd.nfo", 0.00Kbyte/sec

FTP command: Client "*.*.*.*", "MKD /-/CD1"

OK MKDIR: Client "*.*.*.*", "/-/CD1"

FTP response: Client "*.*.*.*", "257 "/-/CD1" created"

FTP command: Client "*.*.*.*", "CWD /-/CD1/"

FTP response: Client "*.*.*.*", "250 Directory successfully changed."

FTP command: Client "*.*.*.*", "PWD"

FTP response: Client "*.*.*.*", "257 "/-/CD1""

FTP command: Client "*.*.*.*", "PASV"

FTP response: Client "*.*.*.*", "227 Entering Passive Mode (*,*,*,*,199,129)"

FTP command: Client "*.*.*.*", "LIST -al"

FTP response: Client "*.*.*.*", "150 Here comes the directory listing."

FTP response: Client "*.*.*.*", "226 Directory send OK."

FTP command: Client "*.*.*.*", "SIZE motp.haf.cd1.sfv"

FTP response: Client "*.*.*.*", "550 Could not get file size."

FTP command: Client "*.*.*.*", "PORT *,*,*,*,195,156"

FTP response: Client "*.*.*.*", "200 PORT command successful. Consider using PASV."

FTP command: Client "*.*.*.*", "STOR motp.haf.cd1.sfv"

Link to post
Share on other sites
  • 1 month later...

by a couple of weeks googleing i found out that the new version of FlashFXP standard settings is set to not allow FXP transfers on port 21 so i just moved it to port 21000 and now it works

 

just thougt it might come in handy for other users !

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...