Jump to content
Sign in to follow this  
anyweb

FC5 with bcm43xx support (HOWTO)

Recommended Posts

heres a good howto, so have a read for those of you with broadcom wireless nics and Fedora Core Release 5

 

cheers

 

anyweb

 

From: David Woodhouse <dwmw2@infradead.org>

Subject: Re: FC5 with bcm43xx support (HOWTO)

To: Robert Allerstorfer <roal@anet.at>

Cc: fedora-ppc@lists.infradead.org, fedora-test-list@redhat.com,

linville@redhat.com

Message-ID: <1143283932.28632.83.camel@pmac.infradead.org>

Content-Type: text/plain

 

Cross-posting since I was planning to send something like this anyway. I

was going to wait till the kernel and bcm43xx-fwcutter were actually in

the repositories and thus skip the first couple of paragraphs, but since

I've been asked....

 

 

On Sat, 2006-03-25 at 03:13 +0100, Robert Allerstorfer wrote:

> are there any step-by-step instructions on how to enable bcm43xx

> support on Fedora Core 5 ppc? I think the default 2.6.15-1.2054_FC5

> kernel should be good.

 

If you haven't already done so, update to the 2.6.16-1.2071_FC5 or later

kernel, from http://people.redhat.com/davej/kernels/Fedora/FC5/ if it

isn't in the official repos yet. The bcm43xx driver _does_ work in the

2054 release kernel, and I've been using it like that for months, but

it's far less picky about its initialisation in 2071, and doesn't lose

the network every time NetworkManager scans -- so for the sake of the

HOWTO it's just easier if you upgrade. The improvements to the driver

_will_ be in the official kernel update when it eventually comes out.

 

Install the bcm43xx-fwcutter package from Extras. It's in extras-devel,

but not yet in extras-fc5 yet because my request to create the branch

hasn't been honoured yet. There's a copy of it at

http://david.woodhou.se/bcm43xx-fwcutter-003-2.ppc.rpm (there's also

i386 and src rpms there).

 

(By next week, hopefully the above will be reduced to

'yum update kernel ; yum install bcm43xx-fwcutter')

 

Then proceed as described

in /usr/share/doc/bcm43xx-fwcutter-003/README.Fedora:

 

As root, extract the firmware from your Windows or MacOS driver by

running the command

bcm43xx-fwcutter -w /lib/firmware <DRIVERFILE>

 

The README file in the same directory (not README.Fedora but just

README) contains a bunch of links to drivers if you don't have one.

Apparently, any of them should be OK; it doesn't matter which you use.

 

Load the driver by 'modprobe bcm43xx'. NetworkManager should work with

it, as should system-config-network and the standard initscripts.

 

WEP works, and according to my limited testing WPA works too, as long as

your AP is broadcasting its ESSID (that latter restriction seems to

apply to _many_ cards, in fact. There's a hack to work around it at

http://david.woodhou.se/wpa_supplicant-hack.patch)

 

We disabled the automatic loading of the bcm43xx driver in FC5 because

it's quite new and experimental, and partly because of the bugs which

have now been fixed in the 2071 kernel. To make sure the driver gets

loaded automatically, either add '/sbin/modprobe bcm43xx' to

your /etc/rc.local script, or copy the alias list

from /usr/share/doc/bcm43xx-fwcutter-003/modprobe.bcm43xx into

the /etc/modprobe.d directory, which tells the module loaded which PCI

IDs to associate with the bcm43xx driver.

 

Finally, give us feedback in bugzilla so we can know if/when we should

enable the driver by default again:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186329

 

Please leave feedback even if it's working -- if the only people we hear

from are those who can't get it to work, then we're _never_ going to

enable it by default. :)

 

If you can't get it to work, try bringing it up by hand using 'ifconfig'

and 'iwconfig' commands, and show/attach the kernel output ('dmesg')

from when you do so. Also try adjusting the rate (iwconfig eth1 rate 2M)

and setting the SSID again. We already default to 11M, but that might

not be slow enough in some situations -- we don't automatically fall

back when the link is poor, so you have to set the speed manually.

 

--

dwmw2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...