Jump to content

Using older libraries


Recommended Posts

I am currently running SuSE 10.0 which uses kde3 (3.4.2) and qt 3.3.4

 

I am trying to compile an app that was built with older versions of the kde and qt libraries. Specifically, kdelibs-1.1.2 and qt-1.4.4. If I install these lib's will it screw up my desktop and/or other apps that rely on kde/qt?

 

I should note that I have tried to load the rpm and Yast gives me package dependancy errors referring to these libs.

Link to post
Share on other sites

in my experience, if it compiles (i am an archlinux user).... it will work, in your case i'd say you have nothing to worry about, so long as it installs.

btw - are you sure you can't find a newer version of this app?

 

 

this is my first post after my into...

Link to post
Share on other sites

well its a bit of a tricky process.. you would want to configure them both with like --preifx=/opt/app

 

so in order to get kdelibs installed you would need to first use qt.. so --preifx=/opt/qt then make sure your QTDIR is set to /opt/qt and such.. you might run into a lot of other issues since those are so old like glibc being too new and such

Link to post
Share on other sites
in my experience, if it compiles (i am an archlinux user).... it will work, in your case i'd say you have nothing to worry about, so long as it installs.

btw - are you sure you can't find a newer version of this app?

 

 

this is my first post after my into...

:ph34r: well i stand back on this one matey ... i don't like top touch the --prefix=..too many dependency issues due to packages begin installed in the wrong place.

 

like i said, you don't have anything to worry about so long as you get the thing installed. the problem will lie in whether the older applications runs or not after installing due to possible newer libraries being installed.

 

with that said, you'll wanna try installing the new/current libraries firsts then if you get the app installed, try running it. it most likely will tell what libs are missing , these are usually just a versioned name. like libssl.so.0. 7.7 while you have libssl.so.0.7.8 so you simply soft-link the available lib. it usually runs.

 

 

i just came up with this tactic today after fukking my gnome start-up with my bleeding edge software installs from the archlinux testing and unstable branches. it turned out that most apps that require gnutls 1.2 don't like the libs from the 1.4 series and the same with the ssl lib as well, they just don't like the new version so i simply tricked it into using it, and what do you know.

 

we have gnome back up in no time :-)

Link to post
Share on other sites

Ok, I found a newer version of the app (kmud btw) There hasn't been any development work on it since 2002, but the website says it will compile with kde3 libs. I had to replace the /admin directory with one provided that supposedly would work, but when I ran make I got the following:

 

pc92:~ # cd /home/tomr/kmud2
pc92:/home/tomr/kmud2 # make -f Makefile.dist
This Makefile is only for the CVS repository
This will be deleted before making the distribution

./admin/cvs.sh: line 30: autoconf: command not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.52 or 2.53
make[1]: *** [cvs] Error 1
make: *** [all] Error 2

So, where do I go from here?

 

I'm a programmer, but I'm not familiar with the linux environment.

Link to post
Share on other sites

you'll need to install autoconf....

http://www.gnu.org/software/autoconf/

 

 

although you may wanna look for a package for ur distro .. i assume ur using an rpm or deb based distro.

 

hey is this the prog~ u r using...

 

what if you just download it....

 

 

ftp://ftp.kmud.de/pub/kmud/kmud-1.0-linux-i386.tar.gz <<< direct link

to the distro that contains (they say) pretty much every lib needed by the app~

 

http://www.kmud.de/index.html?file=download.html <<<download page

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...