Jump to content

How to install the NVIDIA drivers in Red Hat Linux


Recommended Posts

First things first i'd suggest you PRINT this document if you have access to a printer.

 

By default, and out of the box with Red Hat 9 you will have no OpenGL acceleration with your Nvidia card. It will not be optimised for 3D games, or opengl applications. Installing this driver will hopefully fix that and allow you to play Quake 3 and more ;-)

 

To get this support back, you'll need to get nvidias 3d accelerated linux driver and install it as follows, so click on the nvidia link below (for Intel Pentium based systems) or, go to their website directly to download your computers version.

 

nvidia

 

Download that rpm somewhere handy (or check here and get the right driver for your machine) and do as follows:-

 

login as root in a console by typing:-

 

su -

 

Then do

 

sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

 

Now i'm willing to bet that you will get the following error:-

 

NVIDIA Accelerated Graphics Driver for Linux-x86 (1.0-4496)

 

ERROR: You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at www.nvidia.com.

 

OK

 

NVIDIA Software Installer for Unix/Linux www.nvidia.com

 

Dont worry about that, i'm just proving a point here, so lets press 'ok' and fix that problem.

 

Pressing ok will pop up this MESSAGE:

 

Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

 

One more 'ok' exits from the routine.

 

So.... how do i fix the 'log out of X windows' problem ?

 

do as follows: open a console and login as

 

su -

 

then, as root type the following:-

 

cp /etc/inittab /etc/inittab.org

 

That has just copied (cp) a text file called 'inittab' to a new text file called 'inittab.org'. The reason for that is incase you accidently screw up the text editing that comes next ;-)

 

 

 

once done, type the following:-

 

vi /etc/inittab

 

that opens a pretty cool (or anal depending on how you think) console based text editor, and opens a text file. Use your up and down (and left and right) cursor keys to navigate the flashing cursor around this file.

Scroll down to the line that reads:

 

id:5:initdefault:

 

^^ yes that line there ^^

 

and change the number five (5) to a number three (3) so that it now reads

 

id:3:initdefault:

 

^^ now it's a 3 ^^

 

 

If you find you cannot type the number 3, try pressing the INSERT key on your keyboard. (hint: pressing INSERT will toggle between INSERT and REPLACE mode, also, pressing ESC will CANCEL out of those modes and allow you to enter commands).

 

Once you have managed to get the line looking like this

 

id:3:initdefault:

 

press ESC to get control back, and press

 

:wq

 

Thats right, just a colon with a w (to write) and a q (to quit)

ok, you are done !

 

now let's exit from X windows, you could exit from X by pressing CTRL + ALT + BACKSPACE together or the easiest way is to reboot ! so go ahead and reboot, once you have rebooted you'll be presented with a console login prompt...

 

login as root and type this

 

sh NVIDIA-Linux-x86-1.0-4496-pkg1.run

 

Click ACCEPT to accept the license and then click OK to the 'compiling the kernel' message, and watch as it works it's way...

 

Once done you are nearly there. Let's BACKUP a file thats fairly critical to our X windows operation, by logging in as root and typing:

 

cp /etc/X11/XF86Config /etc/X11/XF86Config.org

 

Now, you have to edit the original file, your XF86config file.

 

Login again as root (if you are not already) and type:

 

vi /etc/X11/XF86Config

 

find the line with Driver "nv" (or Driver "vesa") and REPLACE WITH

 

Driver "nvidia"

 

now (taken directly from the Nvidia README)

 

In the Module section, make sure you have: Load "glx" You should also remove the following lines: Load "dri" Load "GLcore" (if they exist).

 

Thats it, save your settings with

 

:wq

 

ok, .... finally, lets test ! logout as root and login as normal user

 

type

 

startx

 

 

 

you'll KNOW you have succeeded becuase the big NVIDIA WHITE login splash screen is there :)

 

(to get Xwindows to load automatically at boot time change the 3 in /etc/inittab back to 5).

 

well done !!

Link to post
Share on other sites

Maybe you right, but i think anyweb must've done it. coz he using Fedora himself. so i think there is other way to do it. so i'll wait to see if anyweb would say something.

Link to post
Share on other sites
  • 4 weeks later...
  • 1 month later...

O.K.

I've done that but my problem is That I Upgrade my kernel with rpm and have a new kernel running but the nvidia drivers wont install

Error the installer can't find the source of new kernel so i dl and install source from rpm's

make symlinx and steel wont work the installer

 

" sh NVIDIA-Linux-x86-1.0-5336-pkg1.run --kernel-name='KERNEL_NAME' "

 

'KERNEL_NAME' = " uname -a "

Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...

This didn't work for me. :o

 

I am using an AMD 1.3 Ghz Firebird with a GeForce 3 ti200. I followed the instructions exactly as written. It compiles and everything but when I log onto my normal account and do the: startx, the screen just goes blank, and nothing happens. I had to reboot and replace the new configfile for the x-thingie with the original.

 

Any ideas?

 

Let me know if you need more information about my system, or anything. <_<

Link to post
Share on other sites
  • 2 weeks later...
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...