Jump to content

How To Get Xscreensaver Properly Running in KDE Environment


Recommended Posts

I've been having a lot of headaches with the screensaver in my Suse 10.1 installation using KDE. Sometimes the screensaver would work, other times it wouldn't. Sometimes it would fade in/out in a cool effect, sometimes it wouldn't (I'll show you that little trick as well).

 

For the most part, I think I got it covered, and I'd like to share how I managed to 'fix' it up a little by reading a FAQ from the xscreensaver site:

Instead of using the usual xscreensaver mechanisms, the KDE folks have chosen to roll their own screen saver wrapper that is inferior to the xscreensaver-demo way of doing things in any number of ways.

 

The only sensible (and secure) way to use a screen saver under KDE is to turn off KDE's built-in screen saver, and use xscreensaver instead. How you go about this is explained in the "Using KDE" section of the xscreensaver manual.

 

The GNOME people used to have the same class of bugs as the KDE folks now have, but the GNOME crew finally came to their senses, and we worked together to come up with a solution that resulted in their being one and only one xscreensaver configurator, instead of two: mine and theirs.

 

Will the KDE people wise up and do the same? Only time will tell. I encourage you to encourage them.

 

Here are the steps that I took to resolve it. It's not very tricky, so this shouldn't take a lot of time at all.

 

1.) I opened "Personal Settings" (AKA "Control Center" Located in "My System" in the KDE Launcher or Kicker).

 

2.) Then I clicked on "Appearance and Themes".

 

3.) Then I clicked on "Screensaver" and disabled the screensaver by unchecking "Start Automatically".

 

4.) I closed the "Personal Settings" window and opened up the "Run Command" by pressing ALT+F2.

 

5.) I typed in "xscreensaver-demo" to open up the true xscreensaver wrapper.

 

6.) I picked out my favorite screensaver (XAnalogTV) and then set the time to be "Blank After" 3 minutes and then exited the "xscreensaver-demo" program.

 

Ta-da! Finished. Now at least the screensaver should work a little better!

 

There has been some note to add a file called xscreensaver.desktop to your /home/[username]/.kde/Autostart directory with this as it's contents (I can't confirm or deny that this step is needed):

[Desktop Entry]
Exec=xscreensaver
Name=XScreensaver
Type=Application
X-KDE-StartupNotify=false

 

Now for the Fade in/out trick. It's a lot easier than you would imagine, but it sure adds a nice touch to the desktop.

 

1.) Open the "xscreensaver-demo" window again by using ALT+F2 and typing in "xscreensaver-demo".

 

2.) Click on the "Advanced" tab next to "Display Modes"

 

3.) In the "Fading and Color Maps" section of this tab, make sure that the proper options are checked. The rest is self explainatory I believe.

Link to post
Share on other sites

Great tutorial!

 

Note that this is very useful if you are running Xgl+Compiz, as for some reason this makes the internal KDE screensaver system not work.

 

So KDE users running Compiz, do the above to get your screensaver back!

 

:D

Link to post
Share on other sites
  • 11 months later...

this works as long as you allow the screensaver to start on its own. if you try to lock session normally it will still use the old screensaver system, not xscreensaver. you'd have to run xscreensaver-demo => click File => click Lock Screen Now :P

 

to fix this i just made an executable file on my desktop called Lockout with the following command in it "xscreensaver-command -lock"

 

now whenever i want to lock session i just click the icon and its perfect everytime ;)

 

i'm running compiz-fusion and this is a perfect solution to my screensaver problems, thank you!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...