Jump to content
Deltanoob

Nvidia + Livna nvidia drivers+ compiz= compiz not working???

Recommended Posts

I think i already posted this but i can't find it? so here it is again.

 

Ok so i get fedora 8, install the kmod-nvidia drivers from livna and the installed drivers from nvidias site.

After that i installed Compiz and enabled desktop effects.....

 

but when i try to start compiz nothing happens...wtf?

i get no errors and nothing saying it crashed it just doesn't start.

Also i noticed that the nvidia splash doesn't flash on xserver start...but the drivers where installed.

 

this is my xorg.conf:

 

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier	 "Default Layout"
Screen	  0  "Screen0" 0 0
InputDevice	"Mouse0" "CorePointer"
InputDevice	"Keyboard0" "CoreKeyboard"
Option		"AIGLX" "true"
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load  "glx"
Load  "dbe"
Load  "extmod"
EndSection

Section "ServerFlags"
Option		"AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier  "Mouse0"
Driver	  "mouse"
Option		"Protocol" "auto"
Option		"Device" "/dev/input/mice"
Option		"Emulate3Buttons" "no"
Option		"ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver	  "kbd"
Option		"XkbModel" "pc105"
Option		"XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Unknown"
ModelName	"Unknown"
HorizSync	30.0 - 110.0
VertRefresh  50.0 - 150.0
Option		"DPMS"
EndSection

Section "Device"
Identifier  "Videocard0"
Driver	  "nv"
Option		"XAANoOffscreenPixmaps" "true"
Option		"Composite" "Enable"
Option		"TripleBuffer" "true"
Option		"RenderAccel" "true"
EndSection

Section "Screen"
Identifier "Screen0"
Device	 "Videocard0"
Monitor	"Monitor0"
DefaultDepth	 24
SubSection "Display"
	Viewport   0 0
	Depth	 24
	Option		"AddARGBGLXVisuals" "true"
EndSubSection
EndSection

Section "Extensions"
Option		"Composite" "Enable"
EndSection

 

thanks guys :)

Share this post


Link to post
Share on other sites

after i posted this i tried to make sure everything was right.

I checked desktop effects and it was disabled? i tried to enable but i could't!?!?

it was working yesterday...?

Share this post


Link to post
Share on other sites

When starting compiz with the console i get this:

 

[Delta@localhost ~]$ fusion-icon

* Detected Session: gnome

* Searching for installed applications...

* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING

* Using the GTK Interface

* Interface not installed

... Trying another interface

* Using the Qt4 Interface

* Interface not installed

... Trying another interface

* Using the Qt3 Interface

* Interface not installed

*** Error: All interfaces failed, aborting!

[Delta@localhost ~]$

 

i installed gtk (i think ) and now i get this:

 

[Delta@localhost ~]$ fusion-icon

* Detected Session: gnome

* Searching for installed applications...

* No GLX_EXT_texture_from_pixmap with direct rendering context

... nor with indirect rendering, this isn't going to work!

Traceback (most recent call last):

File "/usr/bin/fusion-icon", line 57, in <module>

from FusionIcon.interface import choose_interface

File "/usr/lib/python2.5/site-packages/FusionIcon/interface.py", line 23, in <module>

import start

File "/usr/lib/python2.5/site-packages/FusionIcon/start.py", line 64, in <module>

env.set()

File "/usr/lib/python2.5/site-packages/FusionIcon/environment.py", line 140, in set

if not self.Xgl and self.glx_vendor == 'NVIDIA Corporation':

AttributeError: Environment instance has no attribute 'glx_vendor'

[Delta@localhost ~]$

 

so....i have no idea what any of that means.. :(

Share this post


Link to post
Share on other sites

If the above is your most current xorg.conf it's not using the nvidia driver.

Section "Device"

Identifier "Videocard0"

Driver "nv" <--- Should read "nvidia" and not "nv".

Option "XAANoOffscreenPixmaps" "true"

Option "Composite" "Enable"

Option "TripleBuffer" "true"

Option "RenderAccel" "true"

EndSection

Share this post


Link to post
Share on other sites

i edited my xorg and added

 

Identifier "Videocard0"

Driver "nv"

Option "XAANoOffscreenPixmaps" "true"

Option "Composite" "Enable"

Option "TripleBuffer" "true"

Option "RenderAccel" "true"

 

to Section "Device"

restarted xserver and...xserver won't start..?

 

i have a copy of my original xorg.conf on my desktop whats the command (in bash) to replace one file with another?

 

like replace /etc/X11/xorg.conf WITH /home/Delta/Desktop/xorg.conf ?

 

thanks

Share this post


Link to post
Share on other sites
i edited my xorg and added

 

Identifier "Videocard0"

Driver "nv"

Option "XAANoOffscreenPixmaps" "true"

Option "Composite" "Enable"

Option "TripleBuffer" "true"

Option "RenderAccel" "true"

 

to Section "Device"

restarted xserver and...xserver won't start..?

That section was already there. All you needed to do was change nv to nvidia.
i have a copy of my original xorg.conf on my desktop whats the command (in bash) to replace one file with another?

 

like replace /etc/X11/xorg.conf WITH /home/Delta/Desktop/xorg.conf ?

 

thanks

cp /home/deltanoob/Desktop/xorg.conf /etc/X11/ and say yes when asked to overwrite the file. Look though, replace deltanoob with whatever your login name is, i.e. /home/yourloginname/Desktop/xorg.conf

Share this post


Link to post
Share on other sites
damn! it didn't work...it should have!!!

 

is there a way to edit the xorg.conf from inside the bash command console?

Yes. Use nano or vi. Nano is probably easier, if it's available.

Share this post


Link to post
Share on other sites

it worked! i changed nvidia to nv, alot of stuff in the section wasn't there so i am going to re-write it again if it goes wrong now i know 2 ways to fix it!!!!

THANKS!!!

Share this post


Link to post
Share on other sites
it worked! i changed nvidia to nv, alot of stuff in the section wasn't there so i am going to re-write it again if it goes wrong now i know 2 ways to fix it!!!!

THANKS!!!

Nice! And look at it this way, you're learning a lot about Linux at the same time.

Share this post


Link to post
Share on other sites

hmm...

 

i copied everything into the section "device"

 

restarded and it failed :(

 

i tried to reinstall the nvidia drivers because i thought that maybe the drivers didn't install right..that didn't help.

so i am lost :(

 

this is my current corg.conf:

 

 

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:29:35 PDT 2007

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier	 "Default Layout"
Screen	  0  "Screen0" 0 0
InputDevice	"Mouse0" "CorePointer"
InputDevice	"Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath	  "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load		   "glx"
EndSection

Section "ServerFlags"
Option		 "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier	 "Mouse0"
Driver		 "mouse"
Option		 "Protocol" "auto"
Option		 "Device" "/dev/input/mice"
Option		 "Emulate3Buttons" "no"
Option		 "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier	 "Keyboard0"
Driver		 "kbd"
Option		 "XkbModel" "pc105"
Option		 "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier	 "Monitor0"
VendorName	 "Unknown"
ModelName	  "Unknown"
HorizSync	   30.0 - 110.0
VertRefresh	 50.0 - 150.0
Option		 "DPMS"
EndSection

Section "Device"
Identifier	 "Videocard0"
Driver		 "nvidia"
EndSection

Section "Screen"
Identifier	 "Screen0"
Device		 "Videocard0"
Monitor		"Monitor0"
DefaultDepth	24
Option		 "XAANoOffscreenPixmaps" "true"
Option		 "Composite" "Enable"
Option		 "TripleBuffer" "true"
Option		 "RenderAccel" "true"
SubSection	 "Display"
	Viewport	0 0
	Depth	   24
EndSubSection
EndSection

Section "Extensions"
Option		 "Composite" "Enable"
EndSection

Share this post


Link to post
Share on other sites
hmm...

 

i copied everything into the section "device"

 

restarded and it failed :(

 

i tried to reinstall the nvidia drivers because i thought that maybe the drivers didn't install right..that didn't help.

so i am lost :(

 

this is my current corg.conf:

 

 

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:29:35 PDT 2007

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier	 "Default Layout"
Screen	  0  "Screen0" 0 0
InputDevice	"Mouse0" "CorePointer"
InputDevice	"Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath	  "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load		   "glx"
EndSection

Section "ServerFlags"
Option		 "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier	 "Mouse0"
Driver		 "mouse"
Option		 "Protocol" "auto"
Option		 "Device" "/dev/input/mice"
Option		 "Emulate3Buttons" "no"
Option		 "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier	 "Keyboard0"
Driver		 "kbd"
Option		 "XkbModel" "pc105"
Option		 "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier	 "Monitor0"
VendorName	 "Unknown"
ModelName	  "Unknown"
HorizSync	   30.0 - 110.0
VertRefresh	 50.0 - 150.0
Option		 "DPMS"
EndSection

Section "Device"
Identifier	 "Videocard0"
Driver		 "nvidia"
EndSection

Section "Screen"
Identifier	 "Screen0"
Device		 "Videocard0"
Monitor		"Monitor0"
DefaultDepth	24
Option		 "XAANoOffscreenPixmaps" "true"
Option		 "Composite" "Enable"
Option		 "TripleBuffer" "true"
Option		 "RenderAccel" "true"
SubSection	 "Display"
	Viewport	0 0
	Depth	   24
EndSubSection
EndSection

Section "Extensions"
Option		 "Composite" "Enable"
EndSection

Go back to the last xorg.conf that worked. Once you prove that it works back it up as something like xorg.conf.works (cp xorg.conf xorg.conf.works). Now you can play with the nvidia drivers and see f you can get them working, all the while confident that when you get frustrated with nvidia you can revert to a working xorg.conf easily. I wouls suggest re-installing the NVidia drivers and I would try kmod-nvidia, (yum install kmod-nvidia). You may have to figure out how to remove the old NVidia drivers first if there are any reported conflicts when you try to install kmod.

Share this post


Link to post
Share on other sites
i installed boht the livna and the drivers from nvidia.com....at the same time.

 

so....

If the drivers from NVidia were an .rpm file you can do rpm -e name of file. If not, I'm not sure. I don't want to mis-inform you and cause you to break your system.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...