Jump to content

ifconfig Woes...

Recommended Posts

Hello everyone,


Firstly let me say that I've tried su - and /sbin/ifconfig it's not there. For some reason I seem to have "lost" it or something because ever since I installed the distro a while back it hasn't been there. I'm running Debian. I do have iwconfig, which for most of my needs works but I'm trying to get the loopback (lo) interface running but without ifconfig that's kind of difficult :P


I do have commands for ifup and ifdown but they don't work because (I'm assuming from reading error outputs) that they call on ifconfig.


If someone could help me out on how to fix/get ifconfig i'd greatly appreciate it.


Thank you

Link to post
Share on other sites

I'm not sure which package ifconfig belongs to, and I wasn't able to immediately find out. I don't have a Debian system handy, but could you try:


dpkg --search ifconfig




dpkg --search ifup


Hopefully, one of those (possibly only the second command) should show you which package those programs belong to. Once you know that package name, you should be able to reconfigure it to fix the absence of ifconfig:


dpkg-reconfigure packagename


Alternatively if you do have a package name which looks right, you could attempt to apt-get install the package again to try and reinstall it.


Again, I'm not sure exactly that this is the best way of going about fixing this, so other people with more Debian knowledge may be able to help further. Hopefully it's a place to start.

Link to post
Share on other sites

Thanks guys for the help. Yes it appears that the net-tools package is the same here in Debian. I've tried the dpkg-reconfigure command and the apt-get install. dpkg-reconfigure doesn't seem to fix the problem and apt-get install doesn't allow it to occur as it says I have the newest version of net-tools so it wouldn't re-install it.


Any suggestions?



Link to post
Share on other sites

Try running this as root:


apt-get --reinstall install net-tools


That should force the reinstallation of the whole package even though it is present, and with any luck, drop ifconfig back onto your system. Let us know how it goes. :)

Link to post
Share on other sites
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...