Jump to content
Sign in to follow this  
Charles Anthony

Can not log into encrypted directory after update

Recommended Posts

I am in dire need of help again.

 

After doing the latest updates on my Eee1000 Fedora13 netbook, I get the usual screen that asks for my /home directory password:

/home is password protected

but my password is not accepted. I can not get past this stage of boot up and yes, I am typing the correct password.

 

I booted up a live version on a USB drive and tried to read the directory but failed. As expected, I was prompted for the password, entered it and access was still denied. the message in the error window says:

[b]Unable to mount location[/b]  
Error unlocking device: cryptsetup exited with exit code 255: No key available with this passphrase.

 

 

 

Where do I go from here to get access to this partition?

 

 

 

 

 

Here are some more messages that might give clues:

/home is password protected:  *********
/dev/mapper/temporary-cryptsetup-759: lsetfilecon failed: No such file or directory  
/dev/mapper/temporary-cryptsetup-759: open failed: No such file or directory  
Failed to open temporary keystore device.  
Failed to read from key storage.  

/home is password protected:  

Share this post


Link to post
Share on other sites

so this happened after an update ? have you tried a yum update + reboot since then ?

Share this post


Link to post
Share on other sites

I tried to get into the single user mode but received a peculiar error message. I did not manage to try a "yum update" to solve it. However, it gave me the idea of trying a newer live os usb key and that seemed to do the trick.

 

I loaded the latest Fedora 13 Live and it had no problem reading the files. I entered the exact same original encryption key and it read the files as expected.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...