Jump to content

Recommended Posts

I am new to linux. I started with running kuki linux from a live CD on an Acer Aspire one. It worked great for what I wanted,which is an OS with minimal apps on install that I can customize as I learn more about linux and surf the web. I chose kuki because its designed specifically for the Acer Aspire one and its SSD hd, and the wifi was said to work "out of the box" (with maybe a little tweaking), which knowing a tiny bit about linux I didnt expect anything to work out of the box.

 

When I ran it live everything worked out of the box, so I installed it. After install the wifi doesn't work. Half the time it doesn't detect any networks, when it does I cannot connect to WPA secured connection (gets stuck on authorization), sometimes I can connect unsecured for a few minutes before it looses the signal, but it usually get stuck obtaining IP address. It looks like the kernel did not update after install, so I think I'm probly missing some drivers and maybe a bunch of other stuff, I'm really new to this so I don't know what I should have or where to look to see what is there and what is not, I hope someone knows what I mean. I looked thru other forums, this seems to be a common problem for kuki and ubuntu on the acer aspire one, I tried the solutions and they didnt work, but I think those solutions assume you have a LAN connection or something which right now I dont.

 

some of the solutions I came accross: Putting wireless drivers on a cd and then installing them, I cant figure out how, the "make" commands on the tutorial seem to not work. Someone said to reinstall WICD network manager, I can't figure out how to "reinstall". I tried making an ad hoc connection to another laptop, would not detect. I tried updating on the sketchy unsecured connection but the signal was too weak and it couldnt complete.

 

 

Does it seem like my issue could be the update?

 

how do I update the kuki kernel with no internet connection?

 

How do I narrow down the problem so I at least know what is not causing it?

 

Thank you in advance to anyone who helps. If there are answers for me elsewhere on the forum, I apologize for missing them and starting a new topic, please point me to them. I tried to be detailed without writing a novel, I tried linux long ago and got flamed for both, lol. In the meantime I will try and find a wired connection to borrow and see if maybe my wifi card is bad or something. Thanks again.

  • Like 3

Share this post


Link to post
Share on other sites

I tried to be detailed without writing a novel, I tried linux long ago and got flamed for both, lol.

 

Our goal here would never be to flame someone for trying Linux, or for not immediately being an expert at everything! If anyone does ever that to you here, they certainly do not meet with the site's approval.

 

Let's see if we can work out the best way to get the wifi behaving. smile.png

 

A first point -- Kuki Linux is an older distribution that doesn't appear to be getting updated anymore. It might be that the problem will already be fixed if we can get to a newer distribution of Linux, or we may be able to stick with it and find a solution to the problem where we are at the moment.

 

To start doing some research, I looked at this page. It looks like there are multiple models of computer that can be called the Aspire One. Do you know which one yours is?

 

There might be quite significant differences between the different Aspire One models that will affect our decision as to the best way to solve the wifi problem!

 

If you've only very recently looked at Kuki Linux, it's possible it was designed for earlier Aspire Ones, and that it might now be better to look for a different distribution that really will support the wifi out of the box. Or, if we can do some research with the model number, there might be some fixes other people have put together and shared that we can put into place.

 

Let us know the model number if you can, and any other information on how you get on! smile.png

Share this post


Link to post
Share on other sites

I tried to be detailed without writing a novel

The more information is supplied, teh better to diagnose the issue. You've no idea how many people expect you to diagnose complex errors from a simple "it doesn't WORK!" message...

I tried linux long ago and got flamed for both, lol.

As Hybrid mentions, I don't think you got flamed for trying Linux... I think you got flamed by idiots that didn't take the time to assist in your struggles.

 

I've been around in the Linux community for quite some time (but probably less than Hybrid) and I can honestly say that I've met my fair share of arrogant pigheads intermingled with helpful posters. What's really shameful is the Linux zealots display exactly the same self-centred ignorant attitudes as "Windows Fanbois" - they're both as bad as each other - and it serves either community no good, but are the vociferous minority that people will remember and judge by. I'm glad to see your previous bad experiences haven't put you off (you're clearly made of sterner stuff!) so I hope we can assist you in any way possible.

 

You're correct in that there's quite a bit of info on these forums you may not have discovered in a search but... welllll.... I honestly can't remember your query having been raised before (but then I'm a relative newcomer here) so I don't see an issue with you starting a new thread.

 

Welcome to the forums, anyway - hope you enjoy your stay!

Share this post


Link to post
Share on other sites

The model is KAV60 but it looks like its also called D250 later on. I decided to try and take a look at my wireless network when I boot into windows XP and I am having similar problems, so I either also dont have the drivers in Windows (which is possible because I don't know who did what before I got ahold of it) or the wireless card is bad or . I still havent had a chance to hook up a network cable and see if that works.

 

And thanks for the help after looking at what the $sudo lshw command had to offer, I see that my aspire one has a SATA HDD, and is not the Acer Aspire one (SSD) that kuki was designed for. I dont know how much of a difference that makes, but I'm closer to the right track if I actually find out what hardware I'm using etc (duh) rather than just assume and jump the gun, but hey thats what noobs are for. You guys seem a lot nicer than in forums I have been to before, I appreciate it.

Share this post


Link to post
Share on other sites

There used to be a site aimed at Linux distros for netbooks - I looked at http://www.linux-netbook.com/linux/distributions but don't think that was the one I originally saw.

 

From what I remember, it started out because the default distro on a specific netbook wasn't optimised for the hardware, so someone rebuilt an image containing all the correct modules (drivers), stripped out unnecessary bloat (server services) and added in more netbook-specific apps (chat clients, codecs, etc). The idea caught on and other contributors began building different distros for that hardware, then other netbooks.

 

Nowadays, many COTS distros seem to work quite well on netbook architecture. I dropped Mint onto a USB pen and found it working pretty well for a Lenovo X100e netbook that I installed it to a SD chip then boot off that (company kit so I can't replace the disk OS). If you still have issues with your current OS, you could consider trialing out others off some external bootable media.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...