Jump to content
Sign in to follow this  
hijinks

Loads of RPMS!!!

Recommended Posts

Want to have access to almost all apps you can think of that are rpms and can easily be installed via apt-get? I know i do. This is like redhat's version of portage in a way. Its community supported in a way.

 

Just edit your /etc/apt/sources.list and add the following line in for whatever distro you use

 

Fedora core 2
rpm http://apt.physik.fu-berlin.de fedora/2/en/i386 at-testing

Fedora core 1
rpm http://apt.physik.fu-berlin.de fedora/1/en/i386 at-testing

RH 9
rpm http://apt.physik.fu-berlin.de redhat/9/en/i386 at-testing

 

then run

 

apt-get update && apt-get dist-upgrade

 

that will prompt you to upgrade some of the packages probably. Just type Y to continue

 

Once you are fully upgraded run

 

apt-get update

 

once more. You'll now notice you have a bunch more apt sources to find stuff in

 

 

if you run into this error on the apt-get update

 

 

rpmdb: unable to join the environment
error: db4 error(11) from dbenv->open: Resource temporarily unavailable
error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
error: cannot open Packages database in 
E: could not open RPM database

 

don't worry.. just run the following commands to fix your rpm DB. Sometimes doing mass upgrades will cause RPM to confuse itself or error out. Repairing it fixes it 99% of the time

 

rm -rf /var/lib/rpm/__db.00*
rpm -vv --rebuilddb
apt-get update

 

another one from the J to the Y

Share this post


Link to post
Share on other sites

everything went great just like you said but i got the folllowing issues:

 

Fetched 165MB in 9m31s (289kB/s)
Executing RPM (-e)...
Executing RPM (-Uvh)...
Preparing...                ########################################### [100%]
  1:atrpms                 ########################################### [  1%]
  2:sgml-common            warning: /etc/sgml/catalog saved as /etc/sgml/catalog.rpmorig
########################################### [  2%]
  3:opensp                 ########################################### [  3%]
  4:docbook-dtds           ########################################### [  3%]
Failed to remove entry from /etc/sgml/catalog
Failed to remove entry from /etc/sgml/catalog
Failed to remove entry from /etc/sgml/catalog
Failed to remove entry from /etc/sgml/catalog
Failed to remove entry from /etc/sgml/catalog
Failed to remove entry from /etc/sgml/catalog
Failed to remove entry from /etc/sgml/catalog
  5:docbook-style-dsssl    ########################################### [  4%]
  6:openjade               ########################################### [  5%]
  7:libxml2-python         ########################################### [  6%]
  8:libxml2-devel          ########################################### [  7%]
  9:libxml2                ########################################### [  8%]
 10:xml-common             warning: /etc/xml/catalog saved as /etc/xml/catalog.rpmsave
########################################### [  8%]
warning: /usr/share/sgml/docbook/xmlcatalog saved as /usr/share/sgml/docbook/xmlcatalog.rpmsave
 11:jadetex                ########################################### [  9%]
 12:tetex                  ########################################### [ 10%]

 

what did i do wrong and how can i fix it ?

-tek-

Share this post


Link to post
Share on other sites

it would seem i spoke to soon, upon further inspection , my box no longer thinks apt-get update is a command. oh my.

Share this post


Link to post
Share on other sites

Worked fine for me, had a small problem with a dep.. which Jy fixed for me..

 

 

[root@xaser root]# rpm -Uvh http://download.atrpms.net/other/packages/fedora-1-i386/atrpms/atrpms-kickstart-20-1.rhfc1.at.i386.rpm
Retrieving http://download.atrpms.net/other/packages/fedora-1-i386/atrpms/atrpms-kickstart-20-1.rhfc1.at.i386.rpm
warning: /var/tmp/rpm-xfer.kTFF8D: V3 DSA signature: NOKEY, key ID 66534c2b
error: Failed dependencies:
       apt = 0.5.15cnc3-0.1.fr is needed by (installed) apt-devel-0.5.15cnc3-0.1.fr

 

 

i did this:

 

rpm -e apt-devel

 

then ran it again, worked great :)

 

 

square@EFnet

Share this post


Link to post
Share on other sites

yeah im using rh 9.

Share this post


Link to post
Share on other sites

THose warnings are ok. They are just letting you know file changes. If you can still use the apt-get command everything should be working

Share this post


Link to post
Share on other sites

when i try and use the apt-get command now, all i get is the following:

-bash-2.05b# apt-get
-bash: /usr/bin/apt-get: No such file or directory

 

any ideas?

Share this post


Link to post
Share on other sites

downloaded those 3 rpms, tried to install got this:

 

-bash-2.05b# rpm -Uvh libapt-pkg-0.5*.rpm
error: Failed dependencies:
       libbeecrypt.so.6 is needed by libapt-pkg-0.5.15cnc6-49.rh9.at
-bash-2.05b# rpm -Uvh libapt-pkg-devel*.rpm
Preparing...                ########################################### [100%]
  1:libapt-pkg-devel       ########################################### [100%]
-bash-2.05b# rpm -Uvh libapt-pkg-0.5*.rpm
error: Failed dependencies:
       libbeecrypt.so.6 is needed by libapt-pkg-0.5.15cnc6-49.rh9.at
-bash-2.05b# rpm -Uvh apt-*.rpm
error: Failed dependencies:
       /etc/apt/apt.conf is needed by apt-0.5.15cnc6-49.rh9.at
       /etc/apt/sources.list is needed by apt-0.5.15cnc6-49.rh9.at
       libapt-pkg = 1:0.5.15cnc6-49.rh9.at is needed by apt-0.5.15cnc6-49.rh9.at
       libapt-pkg-libc6.3-5.so.0 is needed by apt-0.5.15cnc6-49.rh9.at
       libbeecrypt.so.6 is needed by apt-0.5.15cnc6-49.rh9.at

 

So then i tried to install the libbeecrypt but it says this :

-bash-2.05b# rpm -Uvh bee*.rpm
warning: beecrypt-3.1.0-3.i386.rpm: V3 DSA signature: NOKEY, key ID e01260f1
error: Failed dependencies:
       beecrypt = 2.2.0-8 is needed by (installed) beecrypt-devel-2.2.0-8

 

still havent gotten it right, but what confuses me is if beecrypt-devel* is installed why is it still failing dependencies?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...