Jump to content
Sign in to follow this  

how to stop ssh sessions timing out

Recommended Posts

if you connect to another pc via ssh, you may notice that after a period of inactivity, that the ssh session idles and disconnects you (you cannot type anymore in the cosole for example)


to get around this, simply edit the following file as below and add the following line to auto ping a packet (keepalive as it were)


vi /etc/ssh/sshd_config

in the file add the following line: ClientAliveInterval 30

example below:-

#       $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $
# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.
# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin
# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.
Port 22
ClientAliveInterval 30
#Protocol 2,1
#ListenAddress ::


save ( ESC :wq )


and restart your sshd server


service sshd restart




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...