Jump to content

apt-get broken


Recommended Posts

Hey, I followed this how-to, but I had httpd, mysql, and php installed from the default Disk install, so I removed php, mysql, and httpd before evreything using rpm -e and now whenever I run apt-get I get the following error,

[root@seeno root]# apt-get update && apt-get upgrade && apt-get dist-upgrade
Get:1 http://ayo.freshrpms.net redhat/9/i386 release [1171B]
Fetched 1171B in 2s (448B/s)
Hit http://ayo.freshrpms.net redhat/9/i386/os pkglist
Hit http://ayo.freshrpms.net redhat/9/i386/os release
Hit http://ayo.freshrpms.net redhat/9/i386/updates pkglist
Hit http://ayo.freshrpms.net redhat/9/i386/updates release
Hit http://ayo.freshrpms.net redhat/9/i386/freshrpms pkglist
Hit http://ayo.freshrpms.net redhat/9/i386/freshrpms release
Reading Package Lists... Done
Building Dependency Tree... Done
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
 MyODBC: Depends: libmysqlclient.so.10
 MySQL-python: Depends: libmysqlclient.so.10
               Depends: mysql but it is not installed
 htdig-web: Depends: webserver
 libdbi-dbd-mysql: Depends: libmysqlclient.so.10
 mailman: Depends: webserver
 mod_auth_mysql: Depends: httpd (>= 2.0.40) but it is not installed
                 Depends: httpd-mmn (= 20020628)
                 Depends: libmysqlclient.so.10
 mod_auth_pgsql: Depends: httpd (>= 2.0.40) but it is not installed
                 Depends: httpd-mmn (= 20020628)
 mod_perl: Depends: httpd (>= 2.0.40) but it is not installed
           Depends: httpd-mmn (= 20020628)
           Depends: libapr.so.0
           Depends: libaprutil.so.0
 mod_python: Depends: httpd (>= 2.0.40) but it is not installed
             Depends: httpd-mmn (= 20020628)
 mod_ssl: Depends: httpd but it is not installed
          Depends: httpd-mmn (= 20020628)
 namazu-cgi: Depends: webserver
 nut-cgi: Depends: webserver
 perl-DBD-MySQL: Depends: libmysqlclient.so.10
 php-imap: Depends: php (= 4.2.2-17.2) but it is not installed
 php-ldap: Depends: php (= 4.2.2-17.2) but it is not installed
 php-manual: Depends: php (= 4.2.2-17.2) but it is not installed
 php-mysql: Depends: libmysqlclient.so.10
            Depends: php (= 4.2.2-17.2) but it is not installed
 php-odbc: Depends: php (= 4.2.2-17.2) but it is not installed
 php-pgsql: Depends: php (= 4.2.2-17.2) but it is not installed
 php-snmp: Depends: php (= 4.2.2-17.2) but it is not installed
 qt-MySQL: Depends: libmysqlclient.so.10
 redhat-config-httpd: Depends: httpd but it is not installed
 squirrelmail: Depends: httpd but it is not installed
               PreDepends: httpd but it is not installed
               Depends: php (>= 4.0.4) but it is not installed
 webalizer: Depends: webserver
 wordtrans-web: Depends: php (>= 4.2.2-10) but it is not installed
                Depends: webserver
E: Unmet dependencies. Try using -f.

How do I fix this? :(, I did apt-get -f install but I don't want apache, php, and mysql to be installed again, I already have them, just not rpms, from source ;).

 

Thanks :D

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...