Jump to content

Whats up with eth0?


Recommended Posts

Hello all,

 

Well, I am fumbling through my new Fedora c2 setup (first time on Linux) and last night I managed to get on line with my DSL. I set up a new DSL connection, activated it and was good to go. Now this "new" connection appears under my eth0 object so logic dictates that I should have activated my eth0 to get on line but it wont activate. I launched a browser to try to generate an error to work up from by VIOLA! I was on line. But that still doesn't answer the question as to why eth0 wont activate. Am I interpreting "activation" out of context? I am likening it to having a NIC card on my 2K system defined as "disabled" which if that was the case I would not be able to use it to connect to a network/internet.

 

After being an Admin for Windows networks for years, this Linux stuff is REALLY refreshing.

 

If you could recommend one book on learning Linux/Fedora, which would you recommend?

Link to post
Share on other sites

as root do this

 

ifconfig

 

it should give you the information for your network adaptors

 

paste the output here

 

cheers

 

anyweb

Link to post
Share on other sites
Guest Guest_Kikaida

Here it is, when I try to activate it it returns an error of "Cannot determine IP address" and wont activate....But here I am on line? Just trying to understand.

 

Thanks,

 

 

[root@localhost root]# ifconfig

eth0 Link encap:Ethernet HWaddr 00:06:5B:BA:4D:44

inet6 addr: fe80::206:5bff:feba:4d44/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:466 errors:0 dropped:0 overruns:0 frame:0

TX packets:502 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:414420 (404.7 Kb) TX bytes:74241 (72.5 Kb)

Interrupt:11 Base address:0xec80

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:5129 errors:0 dropped:0 overruns:0 frame:0

TX packets:5129 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:5404685 (5.1 Mb) TX bytes:5404685 (5.1 Mb)

 

ppp0 Link encap:Point-to-Point Protocol

inet addr:68.121.247.234 P-t-P:151.164.184.5 Mask:255.255.255.255

UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1

RX packets:450 errors:0 dropped:0 overruns:0 frame:0

TX packets:470 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:3

RX bytes:403492 (394.0 Kb) TX bytes:58459 (57.0 Kb)

Link to post
Share on other sites

It's pretty much similar to Windows when using DSL or something similar. You can assign an IP address to the interface connected to the modem or not. That doesn't really matter. If the device was disabled (just like disabled on Windows) it wouldn't appear on 'ifconfig' and you couldn't dialup. So don't add "ONBOOT=no" but add an IP address instead (you could use 'redhat-config-network' or 'setup' to do so).

 

But anyways the device isn't being used directly - as you are "dialing" in the PPPd is used to establish the PPPoE connection. And that daemon creates an own device to handle its IP address and routing - ppp0. So nothing to worry at all. :P

 

z0ny

Link to post
Share on other sites
Guest Guest_kikaida

Yeah, disable on boot killed my DSL. I assaigned it a static 192.168.x.x IP and it came up fine on boot BUT my SBC PPP connection failed to fire up on boot. wierd huh. Oh well, I'll keep goofin with it. It;s not hurting anything and playing around with it helps with the learning :D

 

Thanks guys.

Link to post
Share on other sites

Yeah, I can get on line. Its just at boot up it lags as its trying to acquire an IP for eth0. I guess since there are no DHCP servers to acquire from it bombs out, then it sends out its DSL request with the log on params and it acquires successfully. So its active in one sense and not in another.

 

I wonder if I should report this to bugzilla? If I assign eth0 a static IP it fires up fine at boot but the DSL connection bombs and I have to manually activate it. Then at the point, both objects are activated even though they are truly one.

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...