Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
diskless booting troubles

I compiled my client kernel to be vm-linuz-2.6.21-prepclient(FC7), where the client was configured to be NFS bootable.


I have two network cards on my client node, and both should be configured to run on different networks.


If my node is numbered node 2, then eth0 has and eth1 has . Likewise, node 3 has eth0 configured and eth1 is and so on.


First, on power on, the client contacts the server using eth0 with a dhcp request, and gets the correct ip configured to it. Subsequently, diskless booting happens through this network. At the time when eth1 is configured, however, the network fails saying "some other host already uses the address". No matter what address I use, it gives the same error.


Prior to activating the network service, I have netfs and rpcbind going up.


After the system is booted, I tried manually assigning the ip address, using


/sbin/ifconfig eth1 up


But this dosent help. The DHCP server seems to be running ok and the configuration file too looks ok to me.


Can anybody help me with this problem?


Forum Jump:

Users browsing this thread: 1 Guest(s)