Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fedora Core Release 1 Yarrow

I work at a school that has the following setup


Cable Modem

with ethernet going into

Dell Computer running Fedora Core Release 1

from which one ethernet goes to a machine running windows server 2003

and another ethernet cable goes to a different machine running windows server 2003

These two servers are the domain controllers for the Teachers and Students servers

The servers have completely different IP addresses (one is and the other is


This system has been running for a few years with no one taking care of it. The last IT person who knew how to use this system (a teacher) left on bad terms apparently, and did not leave any of the log in information behind. Since he left, another IT person has come and gone, but they never had anything to do with the Fedora machine, they only knew how to log into the two Windows Server 2003 systems.


The school is now involved in an international project called Rock Our World ( which requires iChat to be used so classes around the world can communicate.


At home, the Apple iBook connects to iChat (using AIM) instantly. There are no problems. At work, it is not able to connect. I imagine this is a firewall problem.


I plugged the iBook directly into the Cable Modem at work (disabling the Internet connection for the rest of the school) and iChat worked right away. I then connected the iBook to one of the ethernet cables coming out of the machine running Fedora and iChat wouldn't connect. This happened again when I tried the other ethernet cable. This leads me to believe that the Fedora machine (which I know nothing about) is blocking the ports that iChat needs to see outside. Is Fedora operating as a firewall for the system?


I have been trying to figure out what on earth to do... The Fedora computer's monitor is just a bunch of numbers (mac addresses etc). When I try to type something, a log in prompt comes up. Sadly, I do not know what username or password to use. It is impossible to get this information. I have never had any exposure to Fedora or Linux before, but there has got to be some solution...


Does anyone have any suggestions? A lot of kids will be pretty thrilled if this gets figured out.




R. Johnson

The Glenfir School


welcome to the forums.


first of all, before i go any further, the fedora core release 1 computer needs to be updated, to the current release which is fedora core release 5 - more details > [/url]


why ? because if nothing is being done with it then it's likely that it is already owned by someone else (hacker whatever) and therefore your kids and anyone who uses that computer network is at risk of having their internet details hijacked and worse,


now on to the next bit, how to regain control over the box you have, quite simple really.


you are going to have to boot the box from a CD and reset the root accounts password. To do that you'll need either the first CD of the installation cd's or the rescuecd.


head over here


and download this


that's the rescue cd. Once done, burn that iso (burn image FROM iso). Once that is done insert it into your fedora machine, and reboot it (ctrl_alt_del should be enough).


Make sure that the bios is set to boot to CD before HDD, which it probably already is. Once you start booting from the rescue cd, you'll need to mount the linux partition on the Fedora core release 1 box. to do that follow this


chroot mnt/sysimage


next up, reset root's password. Set the new root password with by typing:





And then enter your new root password when asked.

Reboot your machine, and you will now be able to log in as root with the new password that you entered.


good Luck !


more info > [url=]





OK, I downloaded the .iso and have burned the image to a cd (thank you)


Before I try to move forward, will doing this ruin any of the present settings?


I know it is important to get control of this box, but it is on a live system that a lot of people depend on.


- - -


also... in order to change the root passage, will a prompt come up to allow me to enter the code:

chroot mnt/sysimage




I am a total noob, and have become exhausted over the past month in trying to find someone who has linux experience. Can anyone give me more information about what I should expect when I CTRL ALT DEL this machine?




it shouldnt do anything drastic (ctrl_alt_del) except to force a controlled shutdown.


using this cd should allow you to merely reset roots password and that's your aim, once done you can reboot the system again and all should be good PLUS you'll be able to login as root to see what's going on


any concerns ? join us on IRC (efnet server) join #linux-noob






Forum Jump:

Users browsing this thread: 1 Guest(s)