Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
changed distros now getting Grub error 17

Ok, I'm getting Grub error 17 in a way that seems to make some of the explanations impossible in my case.


This week, I bought a Shuttle K64. Nice, and it cost me only about $200 from Fry's


It comes without a DVD player.


I bought a Samsung Trudirect EXTERNAL player. Also nice.


But... It plays movies fine. It has Foresight Linux installed, and I would like to change it to another distro.


When I insert, say, an disk created from an iso for Sidux and boot, I get the aforementioned Grub error.


When I insert, say, a disk created from an iso for some other distro and boot, I get the same Grub error.


The system comes with a Foresight disk.


When I insert the Foresight disk and boot, it appears to work normally; I do NOT get the Grub error.


So, this apparently doesn't have to do with boot order or anything like that.


I guess there must be a difference between the Foresight disk and the other disks?


I have installed Linux hundreds of times, so I sorta know what I am doing.


Ideas or suggestions? How would I figure out what is different about the disk, if that seems a likely clue?


BTW: it doesn't seem to have anything to do with WHERE the disk is created, because if I create the disk from the Truedirect external dvd or from a Compaq Presario laptop I have, the same error message occurs.


Hmm. It just occurred to me that the disks that give the Grub error are RW and the Foresight one is probably read only. Do you think that would do it?


is this external cdrw/dvd player USB ? if so have you tried using different USB slots on the computer ? some bios's don't enable certain usb ports until the OS has completely initialised





Forum Jump:

Users browsing this thread: 1 Guest(s)