Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
openGL slowdown
#1

Hi,

Im using FC2 with the latest drivers from nvidia. My card is chaintech gf4 MX 440. For the last few months I have experienced terrible slowdown in openGL games and screensavers. It seems as though there is no more 3D acceleration.

glxgears shows about 210fps in average. But the games feel really slow. I have used the drivers successfully before and out of nowhere this started to happen.

My xorg.conf:



Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
       Identifier     "single head configuration"
       Screen      0  "Screen0" 0 0
       InputDevice    "Mouse0" "CorePointer"
       InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
       RgbPath      "/usr/X11R6/lib/X11/rgb"
       FontPath     "unix/:7100"
EndSection

Section "Module"
       Load  "dbe"
       Load  "extmod"
       Load  "fbdevhw"
       Load  "glx"
       Load  "record"
       Load  "freetype"
       Load  "type1"
#       Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
       Identifier  "Keyboard0"
       Driver      "kbd"
       Option      "XkbModel" "pc105"
       Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
       Identifier  "Mouse0"
       Driver      "mouse"
       Option      "Protocol" "IMPS/2"
       Option      "Device" "/dev/input/mice"
       Option      "ZAxisMapping" "4 5"
       Option      "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
       Identifier   "Monitor0"
       VendorName   "Monitor Vendor"
       ModelName    "NEC MultiSync LCD1525V"
       DisplaySize  310        230
       HorizSync    24.0 - 60.0
       VertRefresh  55.0 - 75.0
       Option      "dpms"
EndSection

Section "Device"
       Identifier  "Videocard0"
       Driver      "nvidia"
       VendorName  "Chaintech A-G440"
       BoardName   "NVIDIA GeForce 4 MX440"
#       Option "CursorShadow"
#       Option "TwinView"
#       Option "SecondMonitorHorizSync"     "30-50"
#       Option "SecondMonitorVertRefresh"   "60"
#       Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x4 80;"
#       Option "TVStandard" "NTSC-M"
#       Option "TVOutFormat" "COMPOSITE"
#       Option "TwinViewOrientation" "Clone"

EndSection

Section "Screen"
       Identifier "Screen0"
       Device     "Videocard0"
       Monitor    "Monitor0"
       DefaultDepth     24
       SubSection "Display"
               Viewport   0 0
               Depth     24
               Modes    "1024x768" "800x600" "640x480"
       EndSubSection
EndSection

Section "DRI"
       Group        0
       Mode         0666
EndSection




Any ideas?

Reply
#2
Fixed it by simply reinstalling the drivers. The problem was that BZFlag (a game) somehow altered my nvidia drivers, so if anyone is going to experience something like this, reinstall the drivers and never run BZFlag again.
Reply
#3

pofkezas if you updated your kernel then you lose the nvidia drivers

 

every time you update the kernel, you must reinstall the nvidia drivers

 

i doubt bzflag would kill the drivers to be honest

 

cheers

 

anyweb

Reply
#4
Nope, I did not update my kernel or anything of that nature. This slowdown particulary happened after running BZFlag, I just didnt pay much attention to it. BZFlag was very problematic for me, it crashed a lot, etc. Also during the reinstall of drivers, I have gotten this message that my drivers were altered since the installation. And now that I reinstalled my drivers and did not run BZFlag at all, I did not experience any slowdowns so far. I'm not 100% sure that it was BZFlag, but its only logical to assume that.
Reply
#5

Quote:Nope, I did not update my kernel or anything of that nature. This slowdown particulary happened after running BZFlag, I just didnt pay much attention to it. BZFlag was very problematic for me, it crashed a lot, etc. Also during the reinstall of drivers, I have gotten this message that my drivers were altered since the installation.  And now that I reinstalled my drivers and did not run BZFlag at all, I did not experience any slowdowns so far. I'm not 100% sure that it was BZFlag, but its only logical to assume that.

 

most weird o_O

 

i cannot see a direct reason as to why bzflag would 'alter' your drivers. i can see your logic in the fact that the slowdown occured when bzflag was installed and worked again when it was uninstalled but i still see no reason for bzflag to do this.

 

mmm browsed the bzflag forums .. give The game is running too slow on linux a once over.. is it related?

 

i note dri is disabled in your setup too... ?

Reply



[-]
Quick Reply
Message
Type your reply to this message here.


Forum Jump:


Users browsing this thread: 1 Guest(s)