Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
apt-get kernel 2.6

want to know how to install 2.6 via apt. Well its easy. Add the following line to your /etc/apt/sources.list file


rpm [/url][url=] arjanv/2.6 kernel


then run the following commands


apt-get update
apt-get install kernel#2.6.1-1.131


that was when 2.6.1-1.131 was the newest. You can get a complete listing by running


apt-get install kernel


NOTE: This was done on a fedora core1 box. RH 9 might have some depandancy issues :)


Ok I just installed it using RH 9.


You need to do an upgrade because it needs a version of mkinitrd and a few other rpms that aren't shipped with RH 9 but that apt-get site has them for download


apt-get update
apt-get upgrade
apt-get install kernel#2.6.1-1.131


ive tried this in fedora core release 1

and while the apt-get part worked perfectly, the kernel itself was a total disasater on my laptop (dell latitude c400)


it completelyhung during boot (after kudzu and some other services were started)


a reboot started fsck which FAILED and forced another reboot,


needless to say i tried on and off about 6 times and i could not get the kernel to work




so for me it was a disaster,


be careful !






No problems at all for me. I have done this on 9 and fedora.


[root@xwing root]# date && cat /etc/redhat-release && uname -a

Thu Jan 22 11:11:19 CST 2004

Fedora Core release 1 (Yarrow)

Linux 2.6.1-1.141 #1 Wed Jan 21 04:33:51 EST 2004 i686 i686 i386 GNU/Linux


that's why you should just use gentoo, it's as easy as ...


emerge genkernel
emerge gentoo-dev-sources
genkernel --config


I can do it in a single line with redhat:

apt-get install kernel-smp#2.6.1-1.141

apt-get schmat-get, but does you being able to do it in one command make you special?
no, just pointing out that redhat is easier than gentoo, and much less of pain to set up.

Hi there, I wonder if someone could say why this has happened, I have updated Ubuntu Ibex to the Ubuntu Jaunty version via the update manager only the kernel says its still Ubuntu 8.10, kernel 2.6.27-14-generic, can I change this and how would l do that, feel like I read my eyes out! now I'm near to Boot and Nuke....thought I'd ask first.


Also when I start the terminal after the new install I get these two lines first.


bash: /home/china/.bashrc: line 102: unexpected EOF while looking for matching `"'

bash: /home/china/.bashrc: line 103: syntax error: unexpected end of file




I have took some screen shots of other errors on this install, still abit new but if you got time I'm all ears, thanks again

did you reboot yet ? kernel updates require a reboot

Forum Jump:

Users browsing this thread: 1 Guest(s)