Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
help i deleted /dev/fd0

sup guys ,

ok so i accidently overwrote the file /dev/fd0 and now my floopy wont work at all. i know why it wont work but is there a way to restore the file or if not how do i make a new one ? im using rh9 if that info helps.




disconnect the fdd cable, reboot, let kudzu find it is now gone, then turn off, reconnect the cable, let kudzu find it again,


or.. wait for someone to post a clever answer, hehe :)






if you deleted the /dev/fd0. you can recreate by using makdev.


need to login as a root.

$ su -




# cd /dev

# ./makedev fd0


that should do


dunno if it work. but worth a try, coz i never del any /dev or /mnt



ok so i tried disconnecting and that didnt work for me i'm getting the following errors:


At the RH9 startup screen(lotsa text followed by [ok] ) i get this:


Updating /etc/fstab unexpected filetype for /dev/fd0 [FAILED]


When i try to access the floppy(clicking on icon on desktop), i get the following error:


Could not mount device.

The reported error was:

mount: /dev/fd0 is not a block device (maybe try `-o loop'?)


I also tried venom's trick but im thinkin since i overwrote the file an didnt actually delete it that this is why it didnt work. So from here i see 2 choices , the -o loop thing which i honestly i dont have a clue about,

or i was think'n maybe delete the fd0 file and then try venoms trick again. Thoughts ideas, comments?

Have Fun, [img]<___base_url___>/uploads/emoticons/default_wacko.png[/img]


Make sure you do not have /dev/fd0 in /etc/fstab. If the device is gone it will only cause problems trying to mount it. You can comment out that line with # and then remove the cable reboot, it will detect that it is gone. Then plug the cable back in and reboot, kudzu should now detect it and go through the config again.

well ermm im stumped, ive tried all suggestions and nothing seems to be working, its says its not of the block type so i did file on it an it comes up as an ascii file whereas fd1 comes up as a block type file. anyway for me to make a block file ?

have fun ,


you need to delete /dev/fd0, remove the fd0 line from /etc/fstab, remove the floppy cable, reboot, plug the cable in, reboot

just tried yer idea grep, still not workin new error message though,


Could not mount device.

The reported error was:

mount: can't find /mnt/floppy in /etc/fstab or /etc/mtab


it just doesnt seem to be recognizing that its there.

when it was lookin for new hardware during startup it didn't

pause or mention that it found the floppy drive either(though i dont know

what it does when it find new hardware).






The way it sounds is that you tried to recreate the fd0 device. Then tried to unplug, comment out, and reboot. If you still had the recreated fd0 you are going to have problems.


If you have not done this.


unplug the device


rm -rf /dev/fd0


vi /etc/fstab

'comment out #/dev/fd0'




turn on.


let it detect. It shouldn't find the floppy.




plug in,


turn on, and you should be on your way.


Sup guys,

i got a new fd0 file from the original rpm, But i dont have the fd0 line in my fstab cuz i took it out.

anychance someone could paste the fd0 line from fstab for me ? i have a basic idea but i could use an example.



Forum Jump:

Users browsing this thread: 1 Guest(s)