Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can not log into encrypted directory after update

I am in dire need of help again.


After doing the latest updates on my Eee1000 Fedora13 netbook, I get the usual screen that asks for my /home directory password:

/home is password protected

but my password is not accepted. I can not get past this stage of boot up and yes, I am typing the correct password.


I booted up a live version on a USB drive and tried to read the directory but failed. As expected, I was prompted for the password, entered it and access was still denied. the message in the error window says:

[b]Unable to mount location[/b]  
Error unlocking device: cryptsetup exited with exit code 255: No key available with this passphrase.




Where do I go from here to get access to this partition?






Here are some more messages that might give clues:

/home is password protected:  *********
/dev/mapper/temporary-cryptsetup-759: lsetfilecon failed: No such file or directory  
/dev/mapper/temporary-cryptsetup-759: open failed: No such file or directory  
Failed to open temporary keystore device.  
Failed to read from key storage.  

/home is password protected:

so this happened after an update ? have you tried a yum update + reboot since then ?

I tried to get into the single user mode but received a peculiar error message. I did not manage to try a "yum update" to solve it. However, it gave me the idea of trying a newer live os usb key and that seemed to do the trick.


I loaded the latest Fedora 13 Live and it had no problem reading the files. I entered the exact same original encryption key and it read the files as expected.


Forum Jump:

Users browsing this thread: 1 Guest(s)