Jump to content
Sign in to follow this  
anyweb

ongoing ipv6 problem

Recommended Posts

hi,

i have ipv6 setup nicely now with freenet (becuase sixxs.net SUCK TOTALLY both in attitude to users and support or rather complete lack of support /rant )

 

but... i have a problem with it, it happens every day at different times so i guess it could be the broker problem

 

heres the output when i try to start it

 

[root@localhost root]# /usr/local/tspc2/bin/tspc -vvvf /usr/local/tspc2/bin/tspc.conf
tspc - Tunnel Setup Protocol Client v2.1
Initializing (use -h for help)


Connecting to server with reliable udp
Using TSP protocol version 2.0.0
Establishing connection with tunnel broker...
Getting capabilities from server
tspGetCapabilities error 2: SOCKET_ERROR
if you are using udp, there is probably no udp listener at broker.freenet6.net
Reliable udp connection failed, fallback to tcp and V6V4

Connecting to server with tcp
Using TSP protocol version 2.0.0
Establishing connection with tunnel broker...
Unable to establish connection with broker.freenet6.net

All transports failed, quitting

Error is 2: SOCKET_ERROR
TSP session done

 

of course, when this happens my psybnc goes into gaga mode and i'm dropped from irc...

 

any ideas what i need to check ?

 

cheers

 

anyweb

Share this post


Link to post
Share on other sites

notice now how it looks when the service returns (such as now 30 minutes later...)

 

[root@localhost root]# /usr/local/tspc2/bin/tspc -vvvf /usr/local/tspc2/bin/tspc.conf
tspc - Tunnel Setup Protocol Client v2.1
Initializing (use -h for help)


Connecting to server with reliable udp
Using TSP protocol version 2.0.0
Establishing connection with tunnel broker...
Getting capabilities from server
Connection established
Authenticating anyweb
Using authentification mecanism DIGEST-MD5
Authentication success
Asking for a tunnel
sent: Content-length: 351
<tunnel action="create" type="v6anyv4" proxy="no">
<client>
 <address type="ipv4">192.168.0.117</address>
<keepalive interval="30"><address type="ipv6">::</address></keepalive>  <router>   <prefix length="48"/>
  <dns_server>
    <address type="dn">ns1.vandyk.candlefire.net</address>
  </dns_server>
 </router>
</client>
</tunnel>

recv:
200 Success
<tunnel action="info" type="v6udpv4" lifetime="604800">
 <server>
   <address type="ipv4">206.123.31.116</address>
   <address type="ipv6">2001:05c0:8fff:fffe:0000:0000:0000:0436</address>
 </server>
 <client>
   <address type="ipv4">81.229.173.235</address>
   <address type="ipv6">2001:05c0:8fff:fffe:0000:0000:0000:0437</address>
   <router>
     <prefix length="48">2001:05c0:8160:0000:0000:0000:0000:0000</prefix>
   </router>
   <keepalive interval="30">
     <address type="ipv6">2001:05c0:8fff:fffe:0000:0000:0000:0436</address>
   </keepalive>
 </client>
</tunnel>


Processing response from server
sent: Content-length: 35
<tunnel action="accept"></tunnel>

Got tunnel parameters from server, setting up local tunnel
Checking for linux ipv6 support...
IPv6 support found
keepalive interval: 30

Going daemon, check tspc.log for tunnel creation status
[root@localhost root]#

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...