Jump to content
Sign in to follow this  
modernbob

keyboard problem

Recommended Posts

After I updated to FC4 the number pad part of my keyboard isn't working. I have plugged this keyboard into a winxp machine and it works fine. I am assuming that there is a problem somewhere with keyboard set up, perhaps xorg.conf? Anyone have any idea's?

Share this post


Link to post
Share on other sites

or make sure you select the right type of keyboard from installation??

Share this post


Link to post
Share on other sites
After I updated to FC4 the number pad part of my keyboard isn't working. I have plugged this keyboard into a winxp machine and it works fine. I am assuming that there is a problem somewhere with keyboard set up, perhaps xorg.conf? Anyone have any idea's?

 

no ideas.. ty come again :D

 

my keyboard setup from xorg.conf

 

Section "InputDevice"
       Identifier      "Keys"
       Driver          "keyboard"
       Option          "CoreKeyboard"
       Option          "XkbRules"      "xfree86"
       Option          "XkbModel"      "pc105"
       Option          "XkbLayout"     "gb"
EndSection

Share this post


Link to post
Share on other sites
Please tell me this.

 

1. Is Num Lock On?

2. What keyboard layout do you have?

 

 

here is my entire xorg.conf. No matter what I try when I restart X it stops and say that I have the wrong keyboard spec. It alway rewrites it and restarts X. I need a numpad. Again, this all orked fine in FC3.

 

# Xorg configuration created by system-config-display

 

Section "ServerLayout"

Identifier "single head configuration"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

EndSection

 

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the

# file minus the extension (like ".txt" or ".db"). There is normally

# no need to change the default.

 

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Red Hat 6.0 and later now use a font server independent of

# the X server to render fonts.

 

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "unix/:7100"

EndSection

 

Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

Load "dri"

EndSection

 

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))

# Option "Xleds" "1 2 3"

 

# To disable the XKEYBOARD extension, uncomment XkbDisable.

# Option "XkbDisable"

 

# To customise the XKB settings to suit your keyboard, modify the

# lines below (which are the defaults). For example, for a non-U.S.

# keyboard, you will probably want to use:

# Option "XkbModel" "pc102"

# If you have a US Microsoft Natural keyboard, you can use:

# Option "XkbModel" "microsoft"

#

# Then to change the language, change the Layout setting.

# For example, a german layout can be obtained with:

# Option "XkbLayout" "de"

# or:

# Option "XkbLayout" "de"

# Option "XkbVariant" "nodeadkeys"

#

# If you'd like to switch the positions of your capslock and

# control keys, use:

# Option "XkbOptions" "ctrl:swapcaps"

# Or if you just want both to be control, use:

# Option "XkbOptions" "ctrl:nocaps"

#

Identifier "Keyboard0"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection

 

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "yes"

EndSection

 

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "Samsung SyncMaster 213T/CX210T"

HorizSync 30.0 - 81.0

VertRefresh 56.0 - 75.0

Option "dpms"

EndSection

 

Section "Device"

Identifier "Videocard0"

Driver "nv"

VendorName "Videocard vendor"

BoardName "NVIDIA GeForce FX 5500"

EndSection

 

Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 16

Modes "800x600" "640x480"

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 24

Modes "1600x1200" "1400x1050" "1280x960" "1280x800" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

EndSection

 

Section "DRI"

Group 0

Mode 0666

EndSection

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...