Jump to content

connecting 2 computers


Recommended Posts

I try to connect two computers with fedora core 4 using a crossover cable and an ethernet device on each computer.

 

I configured each device with

pc1:

ifdown eth0

ifconfig eth0 192.168.0.1

 

pc2:

ifdown eth0

ifconfig eth0 192.168.0.2

 

routes seem ok (it creates by default a network route) and I am also sure that the ethernet cards and the cross-over cable work, but I am unable to ping from one machine to another. Any suggestions what could be wrong?

Thanks in advance.

Link to post
Share on other sites

welcome to the forums

 

can you paste the output of ifconfig on both pc's here please

 

did you check if the firewall (lokkit) was enabled while testing this ?

 

tried another network cable ?

 

cheers

 

anyweb

Link to post
Share on other sites

Thank you for the help

here are the results from ifconfig

 

eth0 Link encap:Ethernet HWaddr 00:40:F4:5D:9A:26

inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::240:f4ff:fe5d:9a26/64 Scope:Link

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:177 Base address:0x8400

 

eth0 Link encap:Ethernet HWaddr 00:0C:6E:8E:CA:3C

inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::20c:6eff:fe8e:ca3c/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:185 Base address:0x8800

 

I have the firewall disabled and I use the cable that connects me to the internet so i am sure it works...

Link to post
Share on other sites
I have the firewall disabled and I use the cable that connects me to the internet so i am sure it works...

 

are you sure this cable is crossover ? if it isnt then you'll be seeing exactly what you are seeing now

 

a quick way to check is to put a hub between the two pcs (that'll mean you'll need one more ethernet cable)

 

cheers

 

anyweb

Link to post
Share on other sites

maybe check to see if the default routes are set correctly.. that is 192.168.0.1 has a default route of 192.168.0.2 and vice versa..

Link to post
Share on other sites
are you sure this cable is crossover ?

 

Hmm this could be the issue. I thought all cables were crossover cables :blink:

Can you make a crossover cable from a regular one? And how can you be sure a certain cable is/isn't a crossover cable?

Link to post
Share on other sites
I try to connect two computers with fedora core 4 using a crossover cable and an ethernet device on

 

I think when connecting two machines together just going straight to the ethernet card you need

to use straight through cable if your using a hub or a switch you use cross over cable.

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...