Jump to content


Recommended Posts

I've been having this problem for a while now, but have not managed to fix it yet.


I'm using SuSE 9.0 Personal and I want to install new versions of the graphical apps it has. Whenever I try to ./configure any of these apps - I get:


checking for Qt... configure: error: Qt (>= Qt 3.3) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!


I have tried recompiling it numerous times (with and without thread support), installing an RPM, but the funny thing is, the graphical apps using QT that come with SuSE are already installed and working fine. How do I install QT stuff?


Also, I now seem to have a similar problem with GTK apps. I tried to ./configure The GIMP 2.2.8, and I get:


checking for pkg-config... no
checking for GLIB - version >= 2.4.5... no
*** A new enough version of pkg-config was not found.
*** See http://www.freedesktop.org/software/pkgconfig/
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.



I don't understand what I'm doing wrong to prevent installation of graphical apps :blink:


Any help would be greatly appreciated. :)

Link to post
Share on other sites

I think I better split this up, so we'll just go for QT here.


I definitely have installed qt-devel-3.3.4 and have tried compiling it with and without threads support.

Link to post
Share on other sites
  • 3 weeks later...

Since I have SUSE 10 now, this is no longer an issue.


Thanks for the help, though. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...