Jump to content
Sign in to follow this  
modernbob

ATI Driver problem.

Recommended Posts

I installed ATI drivers in FC4-x64 and although they appear to operate they lock my machine up if I let DRI load. I have to comment out the DRI section of xorg.conf.

Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

# Load "dri"

EndSection

 

If I run glxgears I get the following.

Xlib: extension "XFree86-DRI" missing on display ":0.0".

508 frames in 6.0 seconds = 84.667 FPS

480 frames in 6.0 seconds = 80.000 FPS

360 frames in 5.0 seconds = 72.000 FPS

 

I am running an ATI 9700 Pro card. The ATI control panel works fine but again if I enable DRI the machine will lock up as soon as Fedora loads the driver. I have looked all over the place for an answer to this one and can't seem to find anything definite. If anyone has managed to get this driver to work please tell me how or at least post your xorg.conf as I have nothing to compare this to. My xorg.conf is listed below.

 

# XFree86 4 configuration created by pyxf86config

 

Section "ServerLayout"

Identifier "Default Layout"

Screen 0 "aticonfig Screen 0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

EndSection

 

Section "Files"

 

# RgbPath is the location of the RGB database. Note, this is the name of the

# file minus the extension (like ".txt" or ".db"). There is normally

# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Red Hat 6.0 and later now use a font server independent of

# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "unix/:7100"

EndSection

 

Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

# Load "dri"

EndSection

 

Section "InputDevice"

 

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))

# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the

# lines below (which are the defaults). For example, for a non-U.S.

# keyboard, you will probably want to use:

# Option "XkbModel" "pc102"

# If you have a US Microsoft Natural keyboard, you can use:

# Option "XkbModel" "microsoft"

#

# Then to change the language, change the Layout setting.

# For example, a german layout can be obtained with:

# Option "XkbLayout" "de"

# or:

# Option "XkbLayout" "de"

# Option "XkbVariant" "nodeadkeys"

#

# If you'd like to switch the positions of your capslock and

# control keys, use:

# Option "XkbOptions" "ctrl:swapcaps"

# Or if you just want both to be control, use:

# Option "XkbOptions" "ctrl:nocaps"

#

Identifier "Keyboard0"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection

 

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "yes"

EndSection

 

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "Samsung SyncMaster 213T/CX210T"

HorizSync 30.0 - 81.0

VertRefresh 56.0 - 75.0

Option "dpms"

EndSection

 

Section "Monitor"

Identifier "aticonfig Monitor 0"

EndSection

 

Section "Device"

Identifier "Videocard0"

Driver "radeon"

VendorName "Videocard vendor"

BoardName "ATI Radeon 9700 Pro"

Option "VideoOverlay" "on"

EndSection

 

Section "Device"

Identifier "ATI Graphics Adapter 0"

Driver "fglrx"

Option "(null)"

Option "DesktopSetup" "Single"

Option "OverlayOnCRTC2" "0"

BusID "PCI:1:0:0"

EndSection

 

Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 24

Modes "1600x1200" "1280x1024" "1024x768"

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 24

Modes "1600x1200" "1400x1050" "1280x960" "1280x800" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

EndSection

 

Section "Screen"

Identifier "aticonfig Screen 0"

Device "ATI Graphics Adapter 0"

Monitor "aticonfig Monitor 0"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 24

EndSubSection

EndSection

 

Section "DRI"

Group 0

Mode 0666

EndSection

Share this post


Link to post
Share on other sites

are you totally up to date with all updates ?

 

try

 

yum -y update

 

then see do things improve

 

cheers

anyweb

Share this post


Link to post
Share on other sites

Well, did all updates and still when I enable dri I get the hour glass and four vertical lines on the screen when fedora loads. I should have kept the nvidia card I had as those drivers loaded up properly and they worked right. In any case I have noticed that there are a lot more problems with ATI drivers working linux than Nvidia drivers or at least it appears so. I guess it's not a big deal as I am not playing games on this machine but it would be really great to get these working properly. Thanks for the help RWO

 

 

 

are you totally up to date with all updates ?

 

try

 

 

yum -y update

 

then see do things improve

 

cheers

anyweb

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...