Jump to content
Sign in to follow this  
Black Ghost

make install to /usr/local/bin

Recommended Posts

Well, I decided to be adventurous and install something from source. While Fedora's not a source-based distribution, I know, I've found some things work better when compiled from source.

 

Specifically, I'm speaking of Wine, which I decided to compile from source from someone's recommendation. I downloaded the source tar.gz, extracted it, followed the directions to install, and it seemed to work perfectly. Unfortunately, after the installer copied all the compiled files to their default directories, I couldn't get Wine to work as a normal user. As root, no problem, but as a user, it refused to work.

 

When I found the executables, I found they'd been put in /usr/local/bin. That seems right, because I read or heard somewhere that it's the default directory for compiled software, or something like that. But it doesn't seem to be working for me.

 

So what should I be doing or changing here? And also, just randomly, why is there no useradd utility?

Share this post


Link to post
Share on other sites

This is due to your PATH settings (although fedora should be looking there).

 

Edit the file ~/.bashrc and at the bottom append:

export PATH=$PATH:/usr/local/bin

 

That should amend it to YOUR login only, if you wish it to be global then you will need to look in the /etc/profile file. I'm not sure of the layout to this file but the solution should be similar.

 

why is there no useradd utility

 

When you chose to become root you MUST use this

su -

 

The - indicates the addition of superuser PATH's etc (as before!). This will let you "see" the useradd binary.

Share this post


Link to post
Share on other sites

Hi,

 

Fedora by default does search the /usr/local/bin could to do the following:

 

ls -ltr /usr/local/bin/wine

Share this post


Link to post
Share on other sites
This is due to your PATH settings (although fedora should be looking there).

 

Edit the file ~/.bashrc and at the bottom append:

export PATH=$PATH:/usr/local/bin

 

That should amend it to YOUR login only, if you wish it to be global then you will need to look in the /etc/profile file. I'm not sure of the layout to this file but the solution should be similar.

 

why is there no useradd utility

 

When you chose to become root you MUST use this

su -

 

The - indicates the addition of superuser PATH's etc (as before!). This will let you "see" the useradd binary.

Ahh, thank you very much, znx! Of course, I'll have to reinstall Fedora to do this, I thought it was a problem with my install or something, so I deleted the partitions :D

 

Here's another question, this time about Gnome. Is there a way to have a particular application grab ALL keyboard/mouse shortcut combos when it's got focus? Specific example being:

Ctrl + Alt + D

is grabbed by Gnome, and minimizes all windows. But it's actually a keyboard shortcut for a game I play, and I'd like the game to recieve the keystrokes and not Gnome. How might I go about this?

Share this post


Link to post
Share on other sites
Ahh, thank you very much, znx!

Sweet .. :)

 

How might I go about this?

 

You can simply remap the Gnome key settings, so that some other keypress (or disable it of course) will do the minimize all windows.

 

You will probably find the preferences ..

Fedora > Preferenes > Keyboard Shortcuts .. or at least i hope :P

 

In there you can search for the binding and remove it .. or alter it.

Share this post


Link to post
Share on other sites
In there you can search for the binding and remove it .. or alter it.

Ah... But I'd like to keep the binding, yet have it nonfunctional within one of my games. Heh... would the best way to do that be to simply run the game without a window manager?

Share this post


Link to post
Share on other sites
Ah... But I'd like to keep the binding, yet have it nonfunctional within one of my games. Heh... would the best way to do that be to simply run the game without a window manager?

 

You can run the game .. by adding it into the .xinitrc on its one and startx .. i suppose if you were happy enough you could even start the game on another display :1 .. and keep it there (then Ctrl+Alt+8 .. say to play Ctrl+Alt+7 to get back)..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...