Jump to content

NTFS under linux


Recommended Posts

Hey fellow linux users!

 

Since monday I installed Xubuntu in a DUALBOOT configuration at work.

Now I need Xubuntu to get NTFS support, and it would be great if it automounted at boot-up.

Could you guys help me out here?

Gimme a step by step and such.

Link to post
Share on other sites

I thought ubuntu had ntfs read support built in already ?

 

what version of xubuntu are you using and do any 'hard discs' show up in the file system section

 

see this screenshot

 

http://shots.osdir.com/slideshows/753/19.gif

Link to post
Share on other sites

The new NTFS support for Ubuntu is available via the snoptics package manager as long as you have all sources enabled.

(Universe and all other sources)

 

My wife wanted to try MythTV and I ended up installing Ubuntu as a dual boot with WindowsXP, which was already on one of her PC's. In order to burn DVD's I wanted to be able to copy the mythburn.iso file to her Windows side. Ubuntu comes with a read only driver for NTFS but the new driver, NTFS-G3, which was released in September of 2006, is available for installation through synoptics package manager, and I imagine whichever packmanager you use for Ubuntu. I have Ubuntu 6.10, which is the latest version as of this writing. Installation of NTFS-G3 is done by just selecting it in the package manager and hitting apply.

 

Now, as far as setting it up so it mounts automatically.

 

There may be other utilities to do this but I used the vi editor and modified the fstab file.

 

The fstab file is located in /etc/fstab

 

You have to sudo to root in order to write to fstab.

 

Here is the line I added and the line it replaced in my fstab file.

 

(line replaced)

# /dev/hdb1

# UUID=141C45601C453DCC /media/hdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

 

(line added)

# ntfs-3g mount for hdb1

UUID=141C45601C453DCC /media/hdb1 ntfs-3g defaults,nls=utf8,umask=007,gid=46 0 1

 

basically all I did, after installation of the ntfs-3g package was change the line that mounted the windows file system from ntfs to ntfs-3g. You can note the pound sign, "#" I placed at the beginning of the old line in order to make the system ignore it. It is always a good idea to not delete things when you are changing system settings as you may need to revert back to the original settings if something goes wrong. I did reboot the system after the change to fstab as drives are normally mounted during the system start up. They can be mounted at other times but you mentioned you wanted it to automatically mount the drive for you.

 

For some reason ubuntu referred to the device as a UUID number rather than a /dev/hdb1 entry. I am not sure why this is but I figured if it could find it as a read only file system that way it would probably work as a read write system the same way.

 

If you are not comfortable with using vi then you would have to modify the file with an editor you are comfortable with. The problem is that the GUI, Graphical User Interface, will not let you log in as root so you would have to copy the fstab file to some other file name and then modify that file using your editor. You could then open a terminal session and sudo to root and copy and rename the file to fstab, overwriting the original. It is always wise to keep a backup copy of any files to be overwriten, like a fstab_old or some such.

 

I hope this helps.

 

dzimmerm

Link to post
Share on other sites

as root

 

fdisk -l

 

the output may look something like this

/dev/hda1 * 1 1360 10924168+ c Win95 FAT32 (LBA)

/dev/hda2 1361 4863 28137847+ f Win95 Ext'd (LBA)

/dev/hda5 1361 3059 13647186 7 HPFS/NTFS

/dev/hda6 3060 3077 144553+ 83 Linux

/dev/hda7 3078 4776 13647186 83 Linux

/dev/hda8 4777 4863 698796 82 Linux swap

the partition listed as

 

/dev/hda5 1361 3059 13647186 7 HPFS/NTFS

 

is the NTFS windows partition

 

cheers

anyweb

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...