Jump to content
anyweb

how do i get firefox to play videos via mplayer plugin

Recommended Posts

hi guys,

 

i'd like my media to play in mplayer instead of totem.

 

when i click on some (usually mms or windows video links) totem starts and then complains that it can't play the file.

 

if i run the file via cli (the terminal) as below, then it works fine in mplayer

 

[anyweb@localhost ~]$ mplayer mms://a1441.v165327.c16532.g.vm.akamaistream.net/7/1441/16532/v0001/nhl.download.akamai.com/16532/wm.nhl.na-central/comp/best_of/07/bestof_theweek_vol_7_700.wmv

MPlayer 1.0rc1-rpm.livna.org-4.1.1 © 2000-2006 MPlayer Team

CPU: Intel® Pentium® M processor 1400MHz (Family: 6, Model: 9, Stepping: 5)

CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Compiled with runtime CPU detection.

mplayer: could not connect to socket

mplayer: No such file or directory

Failed to open LIRC support. You will not be able to use your remote control.

 

Playing mms://a1441.v165327.c16532.g.vm.akamaistream.net/7/1441/16532/v0001/nhl.download.akamai.com/16532/wm.nhl.na-central/comp/best_of/07/bestof_theweek_vol_7_700.wmv.

 

so my question is, how can I force firefox to use mplayer instead of totem for these files ?

 

cheers

anyweb

Share this post


Link to post
Share on other sites

Well, I don't know how to add it to mplayer-plugin but it's easy enough to setup firefox to magically open mplayer when it sees that protocol.

  1. Open about:config
  2. In the filter field type network.protocol-handler
  3. Right click and select New > String if you don't see network.protocol-handler.app.mms. Once you have the entry setup the path to be the full path to mplayer (something like /usr/bin/mplayer).
  4. Right click and select New > Boolean if you don't see network.protocol-handler.external.mms. Set that entry to be true.
  5. Restart firefox.
  6. Type in the stream URL into the address bar, firefox will indicate that you are opening an external program, check the box and click on launch.

That's it, now when encountered firefox will open mplayer for all the mms:// protocols. You can use a similar method to have firefox open lots of different applications for various different protocols (say mailto: opening your preferred mail client, etc).

Share this post


Link to post
Share on other sites

i have the mplayer plugin loaded already as per the fedora core release 6 goodies post,

 

however firefox still defaults to playing certain videos in totem, i'll try what znx suggested later and post the results here

 

cheers

anyweb

Share this post


Link to post
Share on other sites
Or , if you want Multimedia Player (MPlayer) with Plug-in for Mozilla Firefox

 

Sorry to say but the mplayer plugin doesn't add support for the mms:// protocol.

Share this post


Link to post
Share on other sites

well what (if anything) does add support for it ?

 

I tried the suggestions above (editing about:config) and while it plays the original link that i did via cmd line before, now when i click on a video link in bbc's newsite., i get another totem error

 

why ?

post-1-1166380544.png

post-1-1166380549.png

Share this post


Link to post
Share on other sites

Hrmm, well I guess that Gnome is somehow overriding the default within firefox :(

 

Try this:

$ gconftool-2 -t string -s /desktop/gnome/url-handlers/mms/command "/usr/bin/mplayer %s"

 

This adds support for the protocol at the Gnome level, rather than the firefox level.

Share this post


Link to post
Share on other sites

ok fixed it by doing this

 

(as root)

[root@localhost ~]# yum -y remove totem
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package totem.i386 0:2.16.3-1.fc6 set to be erased
--> Running transaction check
Setting up repositories
Reading repository metadata in from local files
--> Processing Dependency: libtotem-plparser.so.1 for package: totem-mozplugin
--> Processing Dependency: libtotem-plparser.so.1 for package: rhythmbox
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package rhythmbox.i386 0:0.9.5-7.fc6 set to be erased
---> Package totem-mozplugin.i386 0:2.16.3-1.fc6 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
Package				 Arch	   Version		  Repository		Size 
=============================================================================
Removing:
totem				   i386	   2.16.3-1.fc6	 installed		 4.9 M
Removing for dependencies:
rhythmbox			   i386	   0.9.5-7.fc6	  installed		 6.4 M
totem-mozplugin		 i386	   2.16.3-1.fc6	 installed		 275 k

Transaction Summary
=============================================================================
Install	  0 Package(s)		 
Update	   0 Package(s)		 
Remove	   3 Package(s)		 

Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
 Removing  : totem						######################### [1/3]
 Removing  : rhythmbox					######################### [2/3]
 Removing  : totem-mozplugin			  ######################### [3/3]

Removed: totem.i386 0:2.16.3-1.fc6
Dependency Removed: rhythmbox.i386 0:0.9.5-7.fc6 totem-mozplugin.i386 0:2.16.3-1.fc6
Complete!

 

in the screenshot below the black box is actually video from bbc news's website, for some reason taking a screenshot of it doesnt show the 'video'

 

but it works now so thanks all

 

cheers

anyweb

post-1-1166381900.png

Share this post


Link to post
Share on other sites
Well, I don't know how to add it to mplayer-plugin but it's easy enough to setup firefox to magically open mplayer when it sees that protocol.
  1. Open about:config
  2. In the filter field type network.protocol-handler
  3. Right click and select New > String if you don't see network.protocol-handler.app.mms. Once you have the entry setup the path to be the full path to mplayer (something like /usr/bin/mplayer).
  4. Right click and select New > Boolean if you don't see network.protocol-handler.external.mms. Set that entry to be true.
  5. Restart firefox.
  6. Type in the stream URL into the address bar, firefox will indicate that you are opening an external program, check the box and click on launch.

That's it, now when encountered firefox will open mplayer for all the mms:// protocols. You can use a similar method to have firefox open lots of different applications for various different protocols (say mailto: opening your preferred mail client, etc).

 

Hello,

This setup doesn't work for me...

Click on the icon of a video file

-> Open: x.wmv from www.y.com

File of type: video Microsoft ASF

Open with: Totem (default)... no other choice

 

TIa for any further suggestion

DanBE

Linux/Mandriva 2006/KDE/Firefox

Share this post


Link to post
Share on other sites
This setup doesn't work for me...

 

Well see the protocol handler's are for streaming data therefore it expects something like: mms://some/url/here/file.wmv

 

Most likely you have a: http://some/url/here/file.wmv

 

So what I will suggest you try installing the mplayer plugin for firefox (and removing totem!).

 

to add the mplayer plugin see this post (scroll down to point 4.) https://www.linux-noob.com/forums/index.php?showtopic=2533

Edited by anyweb
added the mplayer plugin point 4. url

Share this post


Link to post
Share on other sites
This setup doesn't work for me...

 

Well see the protocol handler's are for streaming data therefore it expects something like: mms://some/url/here/file.wmv

 

Most likely you have a: http://some/url/here/file.wmv

 

So what I will suggest you try installing the mplayer plugin for firefox (and removing totem!).

 

to add the mplayer plugin see this post (scroll down to point 4.) https://www.linux-noob.com/forums/index.php?showtopic=2533

Thank you very much for your answer.

 

- Indeed, it is a http://www.x.com/y.wmv link

- For the streaming protocol (mms), I have installed the MediaPlayerConnectivity Firefox extension

- It works for most of the streaming links...

 

- When I *left* click on a video link (.mpeg or .wmv), Firefox offers me only to open it with Totem (default)

- If I *right* click on the link, I can play the video file with the player of my choice, thru the MediaPlayerConnectivity option

 

- How can I change the Firefox *left* click (default) to Kaffeine or mPlayer or MediaPlayerConnectivity ?

- or add them to the 'Open with' list ?

 

- >>I will suggest you try installing the mplayer plugin for firefox<<

--- No incompatibility between the mplayer plugin and the MediaPlayerConnectivity/mplayer extension ?

- >>(and removing totem!)<<

--- from Firefox? How?

--- from the installed programs? Why?

 

WHAT I would like to know is WHERE the default video player link for Firefox is stored !!!

 

TIA for your help.

DanBE

Mandriva 2006/KDE/Firefox

Share this post


Link to post
Share on other sites
I will suggest you try installing the mplayer plugin for firefox<<

- No incompatibility between the mplayer plugin and the MediaPlayerConnectivity/mplayer extension ?

and removing totem!

- from Firefox? How?

- from the installed programs? Why?

 

(1) To see the default applications that work by left click do this:

  • Edit > Preferences
  • Content > Click on Manage
  • Search for 'wmv' > Click Change Action
  • Select "Open with default" which is set normally by Desktop Manager or "Open with this application" to browse to your own or "Save" to automatically save the file or "Use this Plugin" (if it exists!) plugins need to identify the types they support before they turn up here.

(2) You should be able to run to extensions alongside one another even if they are responsible for the same types as the above can shift which one you want to look after it.

 

(3) Removing Totem from firefox involves using method (1) from above.

 

(4) From installed programs, mainly because Totem is not very good at what it does and there is better out there (gmplayer for one, xine too!).

Share this post


Link to post
Share on other sites
(1) To see the default applications that work by left click do this:
  • Edit > Preferences
  • Content > Click on Manage

Thanks again.

Sorry, but there is no "Manage" button in Edit-> Preferences-> Content

My Firefox is 1.5 and in French, but I don't think that it does matter...

However, in Edit-> Preferences-> Download, I have a "Show and Modify Actions..." button.

But, the "Download actions" list is empty...

How does Firefox know that it has to use Totem to show .WMV files ???

(3) Removing Totem from firefox involves using method (1) from above.
Obviously, this can't work... :-)

Somebody told me that I have to remove the Totem plugin from the Mozilla/Firefox/Plugins directory.

But I can't find this plugin...

(4) From installed programs, mainly because Totem is not very good at what it does and there is better out there (gmplayer for one, xine too!).

I don't know why Totem was ever installed... by Firefox, I guess...

I usually use (g)mplayer, or sometimes Kaffeine...

 

DanBE

Share this post


Link to post
Share on other sites

What I did:

 

1) remove Totem from the system (with Mandriva Control Center)

Now, when I left click, in Firefox, on a .MPEG (or .WMV) link, the only option is:

Save this file on disk

 

2) install the mplayer-plug-in (with Mandriva Control Center)

mplayerplugin-3.11-1mdk

After that, the only option is still:

Save this file on disk

 

3) I am completely lost !!!

 

NB: if I RIGHT click on the link, then on the MediaPlayerConnectivity item in the drop down Menu, I can select to play the file in gmplayer...

 

DanBE

Share this post


Link to post
Share on other sites

Good news !

 

After a reboot, a click on a .WMV/.MPEG link in FireFox does now launch mplayer !

 

Thank you all for your help !

 

DanBE

Share this post


Link to post
Share on other sites

Phew .. I was just about to say "I think you did it all right" .. hehe!

 

Glad its working

Share this post


Link to post
Share on other sites
Phew .. I was just about to say "I think you did it all right" .. hehe!

 

Glad its working

znx,

 

And what about Thunderbird ?

 

Since I replaced OOo 1.5 with OOo 2.1, Thunderbird does not know anymore how to open ms-word documents (.doc), or offers to open them with KWord, on the machines where OOffice is installed.

I have to save the document; I can then open it in Konqueror.

 

How could I force Thunderbird to respect the system settings, or change the Thunderbird (Default) for opening .doc, and populate the choices of "Open with:": KWord, Aboword, ooWrite, etc... ?

 

You can use a similar method to have firefox open lots of different applications for various different protocols (say mailto: opening your preferred mail client, etc).

Where could i find documentation on these parameters in Firefox OR in Thunderbird ?

 

TIA for your help.

 

DanBE

Linux Mandriva 2006/KDE/Thunderbird 1.5

Share this post


Link to post
Share on other sites

For opening protocols within TB its actually the same technique as Firefox:

"Tools -> Options -> Advanced -> General -> Config Editor (button)" (which is same as about:config under Firefox) then add the network.protocol-handler. Documentation and example

 

For altering a default application its slightly different, again documentation is available on mozillazine. Which does it better than I can tell you here :) If you are interested in handling the configuration files manually then you can look at this piece of documentation that describes the "mimeTypes.rdf" file (although it says "Firefox", TB uses the same type of file).

 

Hope that helps?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...