Jump to content

Standalone box and ISA proxy and yum update


Recommended Posts

With my box FC5 at work (Active Directory), I have been able to access the net , I have not logged in with my AD account , I logged in as username : root and password : forum,,,fake one (I know security implication, I have done this for test ).

 

First time when I tried to open a browser, window popped up asking me username and password for authentication to use internet (I entered my username: zillah and password:ad123 my active directory account,,,fake ), then I was able to browse the net.

 

When I tried to use the command below (via Terminal):

 

[root@local]#yum install yum (yumes),,,,It did not work, I believe because of the authentication (ISA proxy) that I mentioned above.

 

With the proxy , I followed the link below :

 

http://fedora.redhat.com/docs/yum/sn-yum-proxy-server.html

 

1- I added the line below to /etc/yum.conf

proxy=http://proxy.ewrq.au:8080,,,,,,,,,,,,,,,, because our ISA uses 8080 proxy
proxy_username=zillah,,,,,,,,,,,,,,,,,,,,,,,,,,,fake username
proxy_password=ad123,,,,,,,,,,,,,,,,,,,,,,,,,,,fake password

Then I tried to use this :

[root]#yum update yum,,,,,,,,,,,,,,,,,,I received this error :

 

Loading "installation" Plugin

Settingup Update Process

Setting up repositories

Can not find a valid baseurl for repo:case

Error: Cannot find valid baseurl for repo:core

 

 

2- I removed the configuration above and I tried these:

http_proxy=" http://zillah:ad123@proxy.ewrq.au:8080 "
export http_proxy
yum update

[root@localhost # yum update yum

Traceback (most recent call last):

File "/usr/bin/yum", line 29, in ?

yummain.main(sys.argv[1:])

File "/usr/share/yum-cli/yummain.py", line 80, in main

base.getOptionsConfig(args)

File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig

self.doConfigSetup(fn=opts.conffil* e, root=root)

File "/usr/lib/python2.4/site-packages/* yum/__init__.py", line 102, in doConfigSetup

self.conf = config.readMainConfig(fn, root)

File "/usr/lib/python2.4/site-packages/* yum/config.py", line 567, in readMainConfig

confparser.read(configfile)

File "/usr/lib/python2.4/site-packages/* yum/parser.py", line 126, in read

ConfigParser.read(self,filename)

File "/usr/lib/python2.4/ConfigParser.p* y", line 267, in read

self._read(fp, filename)

File "/usr/lib/python2.4/ConfigParser.p* y", line 490, in _read

raise e

ConfigParser.ParsingError: File contains parsing errors: /etc/yum.conf

[line 15]: 'export http_proxy\n'

[line 16]: 'yum update\n'

  • Like 1
Link to post
Share on other sites

You should be able to add those lines to yum.conf

 

proxy=http://proxy.ewrq.au:8080
proxy_username=zillah
proxy_password=ad123

 

And it should work, if it doesn't there might be something else at work!

 

Using the shell, not the yum configuration file do:

 

# export http_proxy="http://zillah:ad123@proxy.ewrq.au:8080"
# yum update

 

Notice this is run in the shell directory and no spaces around the proxy details!

 

Looking here:

ConfigParser.ParsingError: File contains parsing errors: /etc/yum.conf

[line 15]: 'export http_proxy\n'

[line 16]: 'yum update\n'

 

So you added the information into the configuration file, which is incorrect :) Hope all that makes sense!

 

Finally .. the issue might be with an ISA proxy, see the bugzilla discussion

Link to post
Share on other sites
And it should work, if it doesn't there might be something else at work!

Yes, I believe so that there is something else

 

 

Using the shell, not the yum configuration file do:
You meant : I can write it directly into a terminal console screen or adding thme user's shell profile (~/.bash_profile.) .

 

 

So you added the information into the configuration file, which is incorrect

Yes, you are right.

Link to post
Share on other sites

1- First I updarded (not fresh installation) from FC5 to FC6

 

2- Then I configured /etc/yum.conf with this :

proxy=http://proxy.ewrq.au:8080

proxy_username=zillah

proxy_password=ad123

 

3- I tried from a shell console as root

[root@localhost ~]# yum update yum

Loading "installonlyn" plugin

Setting up Update Process

Setting up repositories

Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mi...ore-6&arch=i386 error was

[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>

Error: Cannot find a valid baseurl for repo: core

 

 

4- [root@localhost ~]# yum clean all

Loading "installonlyn" plugin

Cleaning up Everything

 

 

5- [root@localhost ~]# yum update yum

Loading "installonlyn" plugin

Setting up Update Process

Setting up repositories

Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mir...re-6&arch=i386 error was

[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>

Error: Cannot find a valid baseurl for repo: core

[root@localhost ~]#

Link to post
Share on other sites

'Name or service not known'

 

This suggests not a proxy problem but a DNS issue, can you resolve IP -> Name? Check your /etc/resolv.conf has valid information for the nameservers.

 

You might need to use NTLM Authorization to get authorization of your ISA Proxy (I have been poking around).

Link to post
Share on other sites
what are the contents of /etc/yum.conf
[root@localhost ~]# gedit /etc/yum.conf

[main]

cachedir=/var/cache/yum

keepcache=0

debuglevel=2

logfile=/var/log/yum.log

pkgpolicy=newest

distroverpkg=redhat-release

tolerant=1

exactarch=1

obsoletes=1

gpgcheck=1

plugins=1

metadata_expire=1800

proxy=http://proxy.ewrq.au:8080,,,,,,,,,,,,,,this is our real port for proxy

proxy_username=zillah,,,,,I tried this as well EWRQ\zillah

proxy_password=ad123

# PUT YOUR REPOS HERE OR IN separate files named file.repo

# in /etc/yum.repos.d

 

 

 

 

 

 

[root@localhost yum.repos.d]# gedit fedora-core.repo

[core]

name=Fedora Core $releasever - $basearch

#I uncomment baseurl and comment mirrorlist

baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/os/

#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=core- $releasever&arch=$basearch

enabled=1

gpgcheck=1

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

 

[core-debuginfo]

name=Fedora Core $releasever - $basearch - Debug

#I uncomment baseurl and comment mirrorlist

baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/debug/

#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=core-debug-$releasever&arch=$basearch

enabled=0

gpgcheck=1

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

 

[core-source]

name=Fedora Core $releasever - Source

#I uncomment baseurl and comment mirrorlist

baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/source/SRPMS/

#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=core-source-$releasever&arch=$basearch

enabled=0

gpgcheck=1

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

 

 

Then I tried :

[root@localhost ~]# yum update

Loading "installonlyn" plugin

Setting up Update Process

Setting up repositories

http://download.fedora.redhat.com/pub/fedo...ata/repomd.xml: [Errno 4] IOError: <urlopen error nonnumeric port: '8080?'>

Trying other mirror.

Error: Cannot open/read repomd.xml file for repository: core

[root@localhost ~]#

Link to post
Share on other sites
Yes, it does have valid name, i will check the authentication

 

How goes it with that? Any further along?

 

[root@localhost ~]# yum update

Loading "installonlyn" plugin

Setting up Update Process

Setting up repositories

http://download.fedora.redhat.com/pub/fedo...ata/repomd.xml: [Errno 4] IOError: <urlopen error nonnumeric port: '8080?>

Trying other mirror.

Error: Cannot open/read repomd.xml file for repository: core

[root@localhost ~]#

 

Oh odd error, plainly 8080 is numeric. Try adding a trailing / to your proxy line:

proxy=http://proxy.ewrq.au:8080/

 

It might be that it needs that to see the end of the line, maybe.

Link to post
Share on other sites
  • 6 months later...
Oh odd error, plainly 8080 is numeric. Try adding a trailing / to your proxy line:

proxy=http://proxy.ewrq.au:8080/

 

It might be that it needs that to see the end of the line, maybe.

 

Hi,

 

I had exactly the same problem and a trailing slash fixed the problem for me. Thanks!

Link to post
Share on other sites
I had exactly the same problem and a trailing slash fixed the problem for me. Thanks!

 

Ah its great to know that it works with the trailing / :D

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...