Jump to content
satimis

Virtural users

Recommended Posts

Hi folks,

 

CentOS 4.4 amd64 - server

 

I follow following howto building "Virtual Users"

Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner, ClamAV On CentOS

http://www.howtoforge.com/virtual_users_po...r_clamav_centos

 

I started "screen" recording all typing/keystrokes and output on the Terminal.

 

"sudo" sometimes requested for password. root password did not work. Another time it worked without requesting password. I can't understand WHY.

 

If root password did not satisfy the request I have to run "su" or "su -" to proceed. After executing commands ran "exit" to exit.

 

$ sudo cat /etc/sudoers | tail

# Same thing without a password
# %wheel		ALL=(ALL)	   NOPASSWD: ALL

# Samples
# %users  ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
# %users  localhost=/sbin/shutdown -h now

satimis ALL=(ALL) NOPASSWD:ALL
vmail  ALL=(ALL)  ALL

 

$ cat /etc/group | grep satimis

wheel:x:10:root,satimis
satimis:x:500:

 

On runing; (page 1)

sudo rpmbuild -ta courier-authlib-0.58.tar.bz2

root password did not work. I have to run;

$ su -
Password
# rpmbuild -ta courier-authlib-0.58.tar.bz2

 

After compiling;

cd $HOME/rpm/RPMS/x86_64

can't find the directory.

 

On reading "screenlog.0" it was found;

......
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/courier-authlib-0.58-1-root
Wrote: /usr/src/redhat/SRPMS/courier-authlib-0.58-1.src.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-devel-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-userdb-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-ldap-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-mysql-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-pgsql-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-pipe-0.58-1.x86_64.rpm
Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-debuginfo-0.58-1.x86_64.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.3436
+ umask 022
...

The rpm packagaes were created on "/usr/src/redhat/RPMS/x86_64" NOT on "$HOME/rpm/RPMS/x86_64".

 

Pls advise how to fix the problems.

 

Create "/usr/src/redhat/RPMS/x86_64" and copy all rpm packages created to this directory?

 

TIA

 

 

B.R.

satimis

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...