Jump to content
Sign in to follow this  
anyweb

30 days with Ubuntu 7.04 (feisty fawn)

Recommended Posts

Day 1.

 

 

Backing up my data, and getting Ubuntu downloaded and installed

I started by first backing up my home directory (/home/anyweb) data in FCR6 to an external hdd, once done I scp'd my bookmarks.html (from firefox) via a terminal to my webserver. Next I proceeded to download the Ubuntu iso CD itself, that was easy just head over to Ubuntu's website and decide on the version you want, I chose the Desktop Edition (Ubuntu 7.04 - Supported to 2008) Standard personal computer (x86 architecture, PentiumTM, CeleronTM, AthlonTM, SempronTM).

 

I burned the ISO, labelled the cd and shutdown my FCR6 laptop and removed the hdd for later use. I inserted an old Windows 98 hdd (30gb) and started booting from the Ubuntu cd, I chose the first option which appeared after some moments, which was to 'Start or Install Ubuntu'.

 

It chugged away for a few minutes and presented me with a Ubuntu desktop, and from there, I chose to 'install to hdd' option which was 7 or so easy steps to go through.

 

post-1-1178097125.png

 

After about 30 minutes of file copying it said it was done and asked me to restart now, or continue using the live CD. I was ready to continue so I chose to restart.

 

Please note that if you had configured Gaim or another application prior to this restart then those changes will need to be done again, as I found out. The first thing that you notice after installing to hdd, is that it boots much faster than from the live cd, and that there are software updates available for download.

 

post-1-1178098140.png

 

Wireless issues.

 

After the restart I was connected to the internet via a WIRED connection, as the live cd install didn't load firmware for my wireless network card (what a surprise). The wireless network card is a Broadcom ( Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)) which is a pretty standard wireless card. So my first job was to get wireless working, to do that I clicked on 'system, administration and then 'network''. I selected to remove the tick from within 'Enable roaming mode' and input the wireless AP's ESSID and WEP key, but still no network connection and ifconfig doesnt even report a wireless device.

 

post-1-1178099383.png

 

root@anyweb-laptop:~# ifconfig

eth0 Link encap:Ethernet HWaddr 00:0B:DB:5B:25:48

inet addr:192.168.0.196 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::20b:dbff:fe5b:2548/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:62 errors:0 dropped:0 overruns:0 frame:0

TX packets:38 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:29737 (29.0 KiB) TX bytes:3799 (3.7 KiB)

Interrupt:11

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:8 errors:0 dropped:0 overruns:0 frame:0

TX packets:8 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:400 (400.0 B) TX bytes:400 (400.0 B)

 

 

It seems that I have to start googling (or check Ubuntu's wireless troubleshooter docs) to find the solution to this problem, and no doubt it'll be ndiswrapper to the rescue, strange though as I was under the impression that Ubuntu was designed to stop linux noobs from having to go through this type of hassle.

 

Configuring Ndiswrapper

As I'm new to Ubuntu (but not new to linux), It seems that I have to first enable the universe Going there advised me to open the Synaptic Package Manager tool (gui front end for apt), unfortunately I didn't get very far as point 3 refers to

 

"In the new dialog that opens, click the Add button on the right side of the dialog." however no such dialog appears. (see screenshot below). It did turn out that 'community-maintained open source software' was already selected, so on with the next step.

 

post-1-1178110112.png

 

Next I closed the Synaptic Package Manager (otherwise you'll get this error in the next stage)

 

root@anyweb-laptop:~# apt-get install bcm43xx-fwcutter

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

and then I

 

downloaded this file and proceeded to

 

 

root@anyweb-laptop:~# apt-get install bcm43xx-fwcutter

 

That will prompt you 'yes/no' to install the firmware, so obviously answer yes if you want to get wireless to work.

 

Next this is where the whole linux and windows users must be getting confused,

 

Time to patch the firmware so do this

 

anyweb@anyweb-laptop:~$ sudo bcm43xx-fwcutter -w /lib/firmware ~/Desktop/wl_apsta.o

 

And of it goes....done yet ? no. Next we have to do this...

 

anyweb@anyweb-laptop:~$ sudo bcm43xx-fwcutter -w /lib/firmware/`uname -r` ~/Desktop/wl_apsta.o

 

Nearly there, it tells me I need to bookmark this link and then reboot, ok I'll do that. After the reboot everything looked the same and I was still wired, I removed the wired connection and issued

 

anyweb@anyweb-laptop:~$ modprobe bcm43xx

 

followed by disabling the Wired connection in Network manager. Now ifconfig shows me eth1 (the wireless nic) and I can ping wirelessly, it worked ! *phew*.

 

post-1-1178103664.png

 

anyweb@anyweb-laptop:~$ ifconfig

eth0 Link encap:Ethernet HWaddr 00:0B:DB:5B:25:48

inet6 addr: fe80::20b:dbff:fe5b:2548/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:4 errors:0 dropped:0 overruns:0 frame:0

TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:648 (648.0 B) TX bytes:492 (492.0 B)

Interrupt:11

 

eth1 Link encap:Ethernet HWaddr 00:90:4B:B2:2B:83

inet addr:192.168.0.195 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::290:4bff:feb2:2b83/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:4346 errors:0 dropped:353 overruns:0 frame:0

TX packets:3135 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:5633395 (5.3 MiB) TX bytes:489322 (477.8 KiB)

Interrupt:11 Base address:0x4000

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:6 errors:0 dropped:0 overruns:0 frame:0

TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:300 (300.0 B) TX bytes:300 (300.0 B)

 

anyweb@anyweb-laptop:~$ ping www.google.com

PING www.l.google.com (209.85.135.104) 56(84) bytes of data.

64 bytes from mu-in-f104.google.com (209.85.135.104): icmp_seq=1 ttl=242 time=35.2 ms

 

 

 

 

 

Installing and Configuring the desktop

Meanwhile I let Ubuntu's update manager apply 11 or so updates in the background and proceeded to install xchat via apt-get. To do this I had to be root, and to become root in Ubuntu do as follows:-

 

anyweb@anyweb-laptop:~$ sudo -i

 

that prompts you for your current passsword (the one you set when installing the system) and then you are logged on as root.

 

As I was already familiar with apt-get from earlier fedora days (back when yum was in infancy) I issued the following:-

 

root@anyweb-laptop:~# apt-get install xchat

 

after some moments, it got the package(s) and installed it.

 

Reading package lists... Done

Building dependency tree

Reading state information... Done

The following extra packages will be installed:

tcl8.4 xchat-common

Suggested packages:

tclreadline libnet-google-perl

The following NEW packages will be installed:

tcl8.4 xchat xchat-common

0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.

Need to get 2354kB of archives.

After unpacking 6693kB of additional disk space will be used.

Do you want to continue [Y/n]? y

Get:1 http://se.archive.ubuntu.com feisty/main tcl8.4 8.4.14-0ubuntu1 [1163kB]

Get:2 http://se.archive.ubuntu.com feisty/universe xchat-common 2.8.0-0ubuntu4 [888kB]

Get:3 http://se.archive.ubuntu.com feisty/universe xchat 2.8.0-0ubuntu4 [303kB]

Fetched 2354kB in 2s (1169kB/s)

Selecting previously deselected package tcl8.4.

(Reading database ... 88008 files and directories currently installed.)

Unpacking tcl8.4 (from .../tcl8.4_8.4.14-0ubuntu1_i386.deb) ...

Selecting previously deselected package xchat-common.

Unpacking xchat-common (from .../xchat-common_2.8.0-0ubuntu4_all.deb) ...

Selecting previously deselected package xchat.

Unpacking xchat (from .../xchat_2.8.0-0ubuntu4_i386.deb) ...

Setting up tcl8.4 (8.4.14-0ubuntu1) ...

 

Setting up xchat-common (2.8.0-0ubuntu4) ...

 

Setting up xchat (2.8.0-0ubuntu4) ...

 

post-1-1178099902.png

 

Why did i do the above ? because xchat wasn't installed by default. Ok once done I was on IRC. Please note noobs, that if you don't like using the cli (command line interface, or terminal) then you can click on 'Applications, add/remove' to start the package manger gui.)

 

post-1-1178100581.png

 

Next up, I configured Gaim (not renamed to Pidgin yet ?) to use my msn and gmail accounts respectively. Once done, time to copy back the data I copied to the external hdd, I plugged it in, Ubuntu found it, I selected the windows 98 file system I had copied to (fat32) and copied back all my data from the Fedora Core install. Interestingly, Ubuntu also showed the two other partitions on that hdd, which were NTFS, Fedora didn't mount them at all as no NTFS plugin was installed.

 

post-1-1178100716.png

 

Configuring Firefox

 

Next up, I wanted to configure firefox to be able to play all the usual stuff, flash, java, media, and so on, I don't yet know if it's pre-configured but i'll soon find out.

 

I go to shockwave's home and straight away I'm prompted to 'click here to install plugin' so obviously Adobe Flash Player is not pre-installed, I accept the license agreement and off it goes. Done. I then head over to bbc.co.uk/news and click on a video to see what happens, it prompts for what type of viewer I will use, i choose realplayer (as it's already selected) and then click ok. It says plugin requied, and 'not available'. So I change it to 'windows viewer' and this time it starts up a media player (Totem browser plugin) but abrubptly stops.

 

post-1-1178115953.png

 

At this point I'm beginning to wonder why all the fuss about Ubuntu is there, I mean, I've had to configure the wireless using ndiswrapper, and I have to install plugins in firefox and now I cannot view online content, wasn't Ubuntu supposed to be taking care of all this unecessary hassle ?

 

<webany> i guess i was under the impression that ubuntu had ndiswrapper installed and preconfigured, and that it installed all the plugins/codecs.

<webany> how wrong i was

Share this post


Link to post
Share on other sites

Day 2.

 

Time for some music ?

 

Well back in front of my Ubuntu laptop, and after wiggling the mouse I note that I'm not prompted for a password to regain access to the desktop, odd that as I'm so used to entering my password when not having used my Fedora machine for more than 5 minutes or so. I guess that I'll have to set this up by going to System, preferences and setting a blank screensaver and including the option to 'lock the screen when screensaver is active. I'll test that and see what happens.

 

Anyway I decided that I'd leave my Firefox browser issues for now, until later and listen to some music, I right click 122 or so mp3's and choose to play them with 'rhythmbox' (that was the choice I had, apart from using Movie player, which seems odd for opening music files...), and then the system starts to act weird and goes slow, hdd is chugging and my topmost taskbar starts moving the gaim icon left and adding little music icons, heh.

 

post-1-1178220779.png

 

No music starts to play, instead it shows me a wizard to config my music library, i choose skip, and still no music, but lots of Rhythmbox's wizards to play with at least ;)

 

post-1-1178220882.png

 

 

 

I close the numerous Rhythmboxes and each one pops up with another Rhythmbox, which I close again, and this time i click on one single mp3, and now I'm prompted to 'Search for a suitable Codec'. I choose 'yes'.

 

That in turn brings up 'add/remove packages' listing three choices, the first of which is Gstreamer Extra plugins, which lists mp3 support so i select it. Doing so, prompts me that this is 'Restricted Software' and I should review the terms etc. I click ok, and ok again, it prompts for my password and installs the stuff, and then, low and behold, Abba starts to play "The Winner takes it all".

 

What I didn't like about this experience was how gnome got confused when I selected to so many files, and instead of passing them as args to the program I selected, it decided to open a whole batchful of them, thankfully not 122 (more like 10).

 

What I DID like about this process was that I was given the choice to get a codec, the procedure was relavtively straightforward and easy to do, and once done it plays mp3's. Nice.

 

post-1-1178221559.png

 

Great, now I have music to listen to.

 

post-1-1178225986.png

 

 

Remote desktop access

 

I realise that I need to apply an update to another box so I decide to vnc over ssh, and I'm glad to find that vncviewer is already installed in Ubuntu :)

 

I used the vnc connection for a while (about half an hour) and found it a bit slower than normal, in addition there was a bug with the scrolling bars (x/y axis) where once you scrolled down, you couldnt scroll back up again. Disconnecting and re-connecting the session seemed to fix that until you moved the scollbars again.

 

Next up I tried tsclient to remotely connect to a windows box.

 

post-1-1178228211.png

 

It too was pre-installed (I like that). No problems there !

 

post-1-1178228464.png

 

Whats that orange icon with a white shining star in it ?

 

I'm looking at my ever evolving desktop and see a red/orange icon that looks unfamiliar to me, i click on it and it reveals itself as the update manager, telling me I now have 4 new updates. I enter my password when requested and off it goes, no kernel updates so no need to reboot :)

Share this post


Link to post
Share on other sites

Day 3.

 

DVD playback

 

I inserted a DVD (Firewall/Harrison Ford) and Totem Movie Player popped up, with an error "An error occured: could not read from resource".

 

post-1-1178282347.png

 

At first I presumed that because I havn't installed any codecs yet, that this was why I was getting this error, but it seems a bit more complex. Trying to browse the DVD using 'places, home folder, cdrom 1' failed also, and I clicked on details to get more info.

 

mount: block device /dev/scd0 is write-protected, mounting read-only

 

mount: /dev/scd0 already mounted or /media/cdrom0 busy

 

mount: according to mtab, /dev/scd0 is already mounted on /media/cdrom0

 

This is an external usb DVD rom drive and works fine in Fedora, I did however attach it after booting so perhaps I need a reboot for it to be mounted correctly, so I reboot. After the reboot I insert the dvd again, and this time things look different, Totem starts again with a spinning circle as if it's thinking. Unfortunately nothing else happens, just Totem with an orange background and the spinning circle as if it's locked up. Issuing top via cli I can also see that Totem has hung, consuming approx 80% of available CPU bandwith and nothing to show for it. I try to close totem.

 

anyweb@anyweb-laptop:~$ top

 

top - 14:50:44 up 10 min, 2 users, load average: 2.67, 2.09, 1.04

Tasks: 101 total, 4 running, 97 sleeping, 0 stopped, 0 zombie

Cpu(s): 87.3%us, 12.0%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.3%hi, 0.3%si, 0.0%st

Mem: 644316k total, 637860k used, 6456k free, 544k buffers

Swap: 1253028k total, 512172k used, 740856k free, 39412k cached

 

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND

5525 anyweb 25 0 1355m 371m 7316 R 78.9 59.0 5:18.72 totem

 

After closing Totem, I re-insert the DVD only to get the original error I got the first time. So I try with a different DVD. I get the same error with another DVD so I guess I have other issues. Time to do a bit of research. To verify that Ubuntu can actually use this dvdrom drive, I insert an Audio CD and 'Sound Juicer' pops up and starts playing the music CD.

Good that works.

 

post-1-1178284376.png

 

 

Next I insert a data dvd and it shows the files correctly, so the DVD rom drive does work, and this must be a codec issue.

 

I start up 'add/remove packages' and select Multimedia, and scroll down to other two Gstreamer plugins, one of which lists Video codecs. While there I scroll down (looking for mplayer) and find that 'Movie player' is listed (selected) and below it (unselected) is Movie Player Totem (xine backend) so I choose to select that as well, as it's description is 'Play DVD, movies and songs via xine backend'. It prompts me do I want to install communinty based software (isn't that what linux is anyway ?) so I allow. While I'm there I cannot find mplayer, so scroll down and see VLC, I select it but get a warning "Cannot install 'vlc', this application conflicts with other installed software. To install 'vlc' the conflicting software must be removed first. Swith to the 'synaptic manager' to resolve this conflict."

 

post-1-1178286890.png

 

OK, I continue with vlc unselected.

 

Once the package manager is finished updating itself I re-insert a DVD movie, this time at least I get an error that makes sense

"Totem could not play 'dvd:///media/cdrom0 there is no plugin to handle this movie"

 

Groovy, well now that I installed some codecs via add/remove package manager you would have thought i'd be ok, wrong. I then tried to use mplayer so as root

 

apt-get install mplayer

 

now I get the mplayer essential codecs

wget http://www1.mplayerhq.hu/MPlayer/releases/codecs/essential-20061022.tar.bz2

 

I then extract them

 

 tar xjvf essential-20061022.tar.bz2

 

 

and finally I place them somewhere where mplayer should use them

 

mkdir /usr/local/lib/win32
mv essential-20061022/* /usr/local/lib/win32/

 

Once done, I fire up gmplayer and point it to the DVD, the DVD rom drive led lights up and it's spinning but nothing else, mplayer opens two windows on my desktop, one big, one small but no video, nada, zilch. I don't think playing a DVD is really happening today.

 

Well the above didn't work for me, so thanks to IRC (#ubuntu on EFNET) I was pointed to this > http://ubuntuguide.org/wiki/Ubuntu:Feisty#...ltimedia_Codecs

 

but before I tried that, i needed to remove what I just did so

 

root@anyweb-laptop:~# apt-get remove mplayer

 

followed by

root@anyweb-laptop:~# rm -rf /usr/local/lib/win32/

 

ok, now to try the guide...

 

sudo apt-get install ubuntu-restricted-extras libxine-extracodecs gstreamer0.10-plugins-base gstreamer0.10-plugins-good \
gstreamer0.10-plugins-bad gstreamer0.10-pitfdll

 

I have to accept some java license and a dlj license to continue, i do.

 

finally it's done, now for the W32 codecs.

 

sudo apt-get install w32codecs

 

unfortunately for me that errors out with the following

 

Package w32codecs is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

E: Package w32codecs has no installation candidate

 

So I re-read the guide again and see that it refers to how to add extra repos, I presume this is why i'm getting this error so I do that

 

http://ubuntuguide.org/wiki/Ubuntu:Feisty#...ra_repositories

 

I edit the /etc/apt/sources.list after backing it up to match what they tell me to do, then I

 

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -

 

then

 

wget -q http://lut1n.ifrance.com/repo_key.asc -O- | sudo apt-key add -

 

and then

 

sudo aptitude update

 

Easy wasn't it ? yep, now once done, I try to add the W32 codecs again. This time, I succeeded !

 

anyweb@anyweb-laptop:~$ sudo apt-get install w32codecsReading package lists... DoneBuilding dependency tree

Reading state information... Done

The following packages were automatically installed and are no longer required:

libxvidcore4 mplayer-skins libmp4v2-0 libggi2 libgii1 libgii1-target-x

libfaac0

Use 'apt-get autoremove' to remove them.

Suggested packages:

mplayer

The following NEW packages will be installed:

w32codecs

 

but that's not enough, inserting the dvd pops up totem again along with a libdvdcss encryption error,

 

post-1-1178295580.png

 

a quick read of this and I do as follows:-

 

sudo aptitude install libdvdcss2

 

and finally, after much messing around I can watch a DVD in Ubuntu. woohoo :)

 

More updates

 

The little orange box with a star in it is telling me there's 11 more updates, ok i go and install them plus there are two 'other updates', one is for k3b (which i sneaked in earlier via add/remove packages) and the other is for libk3b2, which of course is also part of k3b.

Share this post


Link to post
Share on other sites

Day 4.

 

Nothing much to report, it's the weekend, i'm knackered and I don't feel like installing or doing any configuring today ! :)

 

But I will note that closing the lid on the laptop does nothing in Ubuntu, in Fedora, it went into standby, must be a power management setting, I'll investigate that later next week.

Share this post


Link to post
Share on other sites

30 days with Ubuntu, is it just hype! I like the premise of your topic anyweb, as always you are leading the way for us.

 

Day 1 didn't seem to go too badly, the install was simple enough, most Linux systems have got that sussed now, nice to see that Ubuntu was one of them. I know you say you thought that ubuntu would support wireless out of the box, it does, unfortunately just not all of them. The fact is that if your card only works with ndiswrapper, wouldn't matter which distro, all would not support it out of the box. Nice to see you got it working too, that should help other with a similar card. First off you get x-chat .. priorities are striaght I see .. #linux-noob !! woot ;) Of course for a new user, the gaim/pidgin issue wouldn't be one, they would just look through the add/remove program list for an IM client. Does any Linux come with Java/Shockwave builtin? That might be a really nice idea for a package!

 

Day 2 - All I can say is .. hehee .. man loads of rhythmboxes! :P I think its really good that it identified the issue with MP3 and sorted it immediately. Nice indeed! I will say this, the experience you had with VNC, I had that too with Gnome on Centos, so it could be a Gnome thing, reducing the quality did improve the performance but not the scrollbars, how odd. The orange icon hehe, it is a standard now and I sort of like it, I believe it was Redhat would kicked this all off with their up2date applet, windows update isn't as nice or quick as any of these!

 

Day 3 - DVDs, sigh. Why isn't it easy to get DVDs going in this day, you would think it would just work. That is a more serious flaw you found there, certainly a bug in the works. It's good that you managed to work through it but could a new user? Probably not. I should point out that Totem would have used the Codecs that mplayer used too, when you installed them it was just in a different place that they expected for Ubuntu probably :o

 

Day 4 - When your laptop closes it lid you need to have "suspend" abilities (also known as ACPI S3 state) in your kernel to make it standby. You should find that gnome supports this out of the box, so maybe its just a matter of glancing at the power options under gnome?

 

Found this generic hacl, might be ok?

Found this more direct hack for ubuntu!

 

In conclusion, so far so good, ubuntu is at least providing you what you need. The hurdles you need to jump leaves the question, is this easy enough for a new user to overcome?

 

thanks anyweb!

Share this post


Link to post
Share on other sites

Very nice work so far.

 

Well, as a "long time" Ubuntu user, I do recognize a few things I struggled with myself.

 

Whenever there is something that doesn't work out of the box, first place to go is The Ubuntu Wiki. It has plenty of solutions for many things.

 

As Anyweb, I also bumped into the codec problems. Knowing that the Wiki is there, searched for Codecs, and click the RestrictedCodecs one. This page has loads of info for most media formats, and how to install them, including how to play media files in firefox.

 

Some things on the Wiki is not 100% updated for Feisty Fawn yet, so a little tinkering is sometimes needed.

 

If thw Wiki doesn't have an answer for you, it is possible to use the Ubuntu Formus. As this was actually a good source before, it is not anymore. I don't like this, but the fact is that the "Ubuntu hype" going on now has ruined the forums. This has happened because so many people just post new post about problems, over and over again, without looking for a already answered post.

 

The VNCviewer axis-problem is a common problem. To fix it you simply open synaptic, then you remove vnc-common and install vnc4-common. In short, replace vnc-common with vnc4-common. This should take care of the axis problem.

 

My impression of Ubuntu is that it is quite an OK Linux-Distro to start on for a beginner. The tinkering is fairly easy (as long as you know about the Wiki and forums), since the tinkering is not that bad. It's only one CD, that contains what you need to get it up and running (usuallu), but after that, you got to install backages. As I have learned new things, and gotten better at understanding Linux, I have found Ubuntu to be a little (I am not sure how to write this) hard or rigid, it's easy on the surface but has a hard core so to say. Because of this, I do not think experienced Linux users will like Ubuntu as much as other Distros. This has lead to, in my opinion, that Ubuntu is fine for a beginner. If the user will want more, they will move along to something else, if they are happy and content they will stick to it.

 

It's going to be interesting to see if what conclusion Anyweb will have after 30 days of Ubuntu. I plan to read this every day :=

Share this post


Link to post
Share on other sites

Day 5.

 

Enabling Desktop Effects

 

Well I'm back, and it's nice to read the replies to my posts, thanks for the info guys I'll be sure to look into it. Today I plan to enable desktop effects (compiz/xgl) in Ubuntu, to see what they'll look like (note: this is not Beryl). To do this, simply click on System, Preferences, then Desktop Effects, then click on 'Enable Desktop Effects'. This did work on my laptop (which is no surprise as I already had Beryl enabled just fine in Fedora Core release 6.

 

Once enabled all looked good except I momentarily lost the ability to type, but once I came back to here (I was typing here) then I got focus back and all was good.

 

post-1-1178478739.png

 

Installing/Enabling Beryl

 

Maybe it's just me, but once you've tried Beryl, you'll want to do it again, so after playing around with XGL/compiz above, I decided to see what Beryl looked like in Ubuntu. installing it was easy.

 

sudo aptitude install beryl emerald-themes beryl-manager

 

And then click on Applications, System Tools, Beryl Manager. Now you can do much more with your wobbly windows, stretch them, and see thumbnails of the app in the taskbar.

 

post-1-1178480994.png

 

Beryl is highly configurable with lots of nice themes (just right click on the beryl icon up in the top taskbar and choose 'Emerald Theme Manager'.

 

post-1-1178480985.png

 

Getting Help with Ubuntu

 

I clicked on the Blue help icon (third from left at top of the screen, a blue circle with a white question mark) and it opened an Ubuntu Help Center. It is pretty comprehensive too, and I like the idea, as it has help for Users migrating from Windows to Ubuntu, helping them to organise files, photos, settings and more. This is good and something similar should be present in all Linux distros if you ask me.

 

post-1-1178481639.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...