Jump to content

We use cookies to log you in, for ads and for analytics. OK


NMP-8602+ Issues

  • Please log in to reply
2 replies to this topic

#1 foobro42



  • Members
  • Pip
  • 4 posts

Posted 30 May 2007 - 03:57 AM

Recently, I purchased a NMP-8602+ miniPCI. I have tried using this card in a HP ze5470us running Fedora Core 6 with the atheros madwifi drivers. The latest madwifi. The drivers compile w/o errors. I am able to bring ath0 up (sometimes) but the system locks often. Most of the time it locks when I try to use the wireless. E.g. capture wireless traffic with airodump-ng or scan for wireless APs in the area. I check the system logs...here are the messages before it locks up.

May 28 08:59:29 steve-laptop pcscd: winscard.c:219:SCardConnect() Reader E-Gate 0 0 Not Found
May 28 08:59:29 steve-laptop last message repeated 3 times
May 28 09:57:37 steve-laptop kernel: wifi0: ath_reset: unable to reset hardware: '' (HAL status 0)
May 28 09:57:39 steve-laptop kernel: wifi0: rx FIFO overrun; resetting

I thought perhaps it was my configuration so I tried a popular security tools live distro Backtrack 2 w/ madwifi drivers. The card was detected but the system hangs just like in FC6.

I tried another laptop I had handy to see if it was hardware compatibility issues. I just tried a L2005cu. The laptop will not boot as it detects an "unapproved" wireless card.

I though i'd try another OS. I installed windows 2000 pro on the same HP ZE5470us. I downloaded the correct Atheros drivers for this card. When I do the install on the drivers (I tried 3 versions) the BSOD appears. The message displayed "DRIVER_IRQL_NOT_LESS_OR_EQUAL" with some memory addresses. I tried updating the BIOS as well to be sure.

So, I'm looking for some advice. Is this card perhaps bad? Incompatible? I am going to take the card to work tomorrow and try it in a few laptops. Have you heard of this incompatibility happening to anyone else?

Thanks in Advance!

#2 anyweb



  • Admin
  • PipPipPipPipPipPipPipPip
  • 3,692 posts

Posted 30 May 2007 - 01:30 PM

have you tried updating the laptops bios to latest version ?
i do windows too

#3 foobro42



  • Members
  • Pip
  • 4 posts

Posted 30 May 2007 - 10:59 PM

Thanks for the input, yes I did update the bios. To the latest version. I went from version 08 to version 25. Still it locks up when I try to do anything with the wireless card. For example. I just booted the bactrack 2 final and iwconfig shows ath0 as an interface. I go to launch Kismet and it locks up. No mouse, no keyboard. Sometimes I've noticed the caps lock light blink as its locked up.

Here is another example
Last night I installed FC6 from scratch. Formatted the HD etc. I updated all 253 packages.
I downloaded the newest Madwifi
gzip -d
tar xvf
cd madwifi....
make (no errors)
make install (no errors)
modprobe ath_pci
iwconfig (shows all my interfaces as well as the new ath0
ifconfig ath0 up (lockup!)

all of this as root of course

Other people have suggested 2 possibilities. 1) the card is defective. 2) the power that card needs is 1amp and perhaps my miniPCI slot does not provide that power. I am willing to try anything to test and find the problem.

OK, I have been able to test the NMP-8602+ in another similar laptop. I have a Dell Latitude C840 that the card is working. So far.... Perhaps I have answered my own question with some more testing. Its showing 31dBm TX. Odd though, airodump-ng has been working for a few min. Now its not showing those networks. If I bring the ath1 down then up and restart airodump-ng it detects the networks again. Thats no good since sometimes you have to monitor the network for an extended time period.

Any ideas? input?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users