Jump to content

Fedora 7 and Broadcom 43xx WI-FI drivers


Recommended Posts

If you just installed fedora 7 and have issues using older firmware drivers. You need newer version firmware for your wi-fi card to work in native mode. Here is what you need to do to get the latest firmware and how to make it work.

 

be sure you are root to install the packages and run the commands below

 

1. Install bcm4300-fwcutter

yum install bcm43xx-fwcutter

 

2.Download the 4.x broadcom firmware

wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2

 

3. extract the package

tar xjvf broadcom-wl-4.80.53.0.tar.bz2

 

4. run the bcm-43xx firmware cutter

bcm43xx-fwcutter -w /lib/firmware broadcom-wl-4.80.53.0/kmod/wl_apsta.o

 

5. You can either reboot or run the command below

modprobe bcm43xx

 

Now your broadcom wireless card should work with out any more issues.

Link to post
Share on other sites

Tried this with no luck. Apparently, my Fedora 7 installation forgot modprobe. Are there any other simple ways of getting Broadcom chipset cards installed on F7?

 

(I tried modprobe, and the command didn't exist. I also tried reboot, to no avail. And I simply copy-pasted all the commands you had here, so I'm not sure what went wrong.)

Link to post
Share on other sites

Are you running as root when trying to run modprobe? If not, you need to type this before doing the commands in the tutorial:

 

su -

 

Enter your root password when prompted.

Link to post
Share on other sites
Are you running as root when trying to run modprobe? If not, you need to type this before doing the commands in the tutorial:

 

su -

 

Enter your root password when prompted.

 

Yep. I executed ALL commands as root, as you said. (Opened terminal, su with password, then copy-pasted each in turn.)

 

There wasn't any problem until the last command (modprobe). It stated that the modprobe package didn't exist. So I tried installing it but couldn't find where to get it.

 

Also... The drivers I used to use with NDISWrapper are the bcmwl5 ones... It worked fine in Ubuntu (easy as pie to set up wireless) but I've had no luck yet with F7.

Link to post
Share on other sites
Yep. I executed ALL commands as root, as you said. (Opened terminal, su with password, then copy-pasted each in turn.)

 

try su -

 

instead of su

 

that's su with a space and a minus after it

 

su -

 

su gives you root

 

su - gives you root and root's path to stuff (like modprobe)

Link to post
Share on other sites

Still no luck, I'm going to try starting over from scratch.

 

You know what would be nice? A shell-script to do all of this automatically. If it doesn't already exist, someone should write it, as it seems all of this is just a simple shell command list anyways.

 

It would also be nice if the shell script were packaged with the firmware, so that it would just require one download.

 

I might try to do this myself...

 

I'll let you guys know.

Link to post
Share on other sites

No such luck. I ran through the entire command list numerous times, with various methods of being root.

 

First, tried logging in as normal user then opening terminal and 'su -' to root, then ran commands. Didn't work.

 

Second, (after restart) I tried doing it by logging in as root and running them all directly. Didn't work.

 

Third, (after restart), I tried going to System->Administration->Network and checking to see if the wireless was there.

 

It was, but it was inactive. When I tried to activate it (by clicking its entry and clicking "Activate") it didn't work, and it gave me this error:

 

tg3 device eth1 does not seem to be present, delaying initialization.

 

Any ideas?

Link to post
Share on other sites
  • 2 weeks later...

Will this bcm4300-fwcutter solution work on Fedora 6 too? I just installed fedora 6 and am getting the following error message:

 

Determining IP information for eth1 ... failed; no link present. Check cable?

 

I have the following hardware detected:

eth1 (Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller). I disabled firewall and SELinux and rebooted. Still didn't work. any help?

Link to post
Share on other sites
  • 2 weeks later...

i've tried this also, no errors whatsoever during the process but the wireless nic does not appear at all in neat,

 

any ideas why Randall ?

 

worked fine in ubuntu 7.04

 

and it shows up in lspci

 

01:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)

 

however it seems it's listed in iwconfig so i'll experiment with that...

 

[root@localhost ~]# iwconfig

lo no wireless extensions.

 

eth0 no wireless extensions.

 

wmaster0 no wireless extensions.

 

wlan0 IEEE 802.11g ESSID:""

Mode:Managed Channel:0 Access Point: Not-Associated

Retry min limit:7 RTS thr:off Fragment thr=2346 B

Encryption key:off

Link Quality:0 Signal level:0 Noise level:0

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Link to post
Share on other sites
  • 3 weeks later...

finally got it to work !

 

I had to do the above PLUS this as root via cli/terminal.

 

1. tell the wireless manager to connect to a wireless access point called 'wireless_g' with key '7177653935'

 

iwconfig wlan0 mode managed essid "wireless_g" key "7177653935"

 

2. assign an ip address to the wlan0 (wireless device) *if this doesnt work try point 3 below*

 

ifconfig wlan0 192.168.0.100

 

3. automatically get an IP from the DHCP server (in this case, the smoothwall linux server behind the access point)

 

dhclient

 

once done the command iwconfig correctly lists the card, and that it's associated and I can ping www.google.com !

 

wlan0 IEEE 802.11g ESSID:"wireless_g"

Mode:Managed Frequency:2.462 GHz Access Point: 00:90:4C:7E:00:64

Bit Rate=1 Mb/s

Retry min limit:7 RTS thr:off Fragment thr=2346 B

Encryption key:7177-6539-35

Link Quality=197/146 Signal level=-219 dBm Noise level=-46 dBm

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

 

ifconfig gives me this

 

wlan0 Link encap:Ethernet HWaddr 00:90:4B:B2:2B:83

inet addr:192.168.0.195 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::290:4bff:feb2:2b83/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1537 errors:0 dropped:0 overruns:0 frame:0

TX packets:1529 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:1357860 (1.2 MiB) TX bytes:319985 (312.4 KiB)

 

and the results from dhclient are here

[root@localhost ~]# dhclient

Internet Systems Consortium DHCP Client V3.0.5-RedHat

Copyright 2004-2006 Internet Systems Consortium.

All rights reserved.

For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801

/sbin/dhclient-script: configuration for wmaster0 not found. Continuing with defaults.

/etc/sysconfig/network-scripts/network-functions: line 78: wmaster0: No such file or directory

/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.

/etc/sysconfig/network-scripts/network-functions: line 78: wlan0: No such file or directory

wmaster0: unknown hardware address type 801

Listening on LPF/wmaster0/

Sending on LPF/wmaster0/

Listening on LPF/eth0/00:0b:db:5b:25:48

Sending on LPF/eth0/00:0b:db:5b:25:48

Listening on LPF/wlan0/00:90:4b:b2:2b:83

Sending on LPF/wlan0/00:90:4b:b2:2b:83

Sending on Socket/fallback

DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 4

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6

DHCPOFFER from 192.168.0.1

DHCPREQUEST on wlan0 to 255.255.255.255 port 67

DHCPACK from 192.168.0.1

/sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.

/etc/sysconfig/network-scripts/network-functions: line 78: wlan0: No such file or directory

bound to 192.168.0.195 -- renewal in 1597 seconds.

 

i initially tried to manually assign an ip to the wlan0 and while that allowed me to ping the firewall/dhcp server (smoothwall on 192.168.0.1) I couldnt ping anything outside of that namely the internet. Adding a nameserver in /etc/resolv.conf didn't help either, only dhclient got me working. !

echo "nameserver 192.168.0.1" > /etc/resolv.conf

 

 

I hope this helps someone with the same problem

 

 

 

cheers

anyweb

Link to post
Share on other sites
  • 2 weeks later...

The instructions here got it working for me

 

lsmod |grep bcm

bcm43xx_mac80211 400289 0

ssb 34757 1 bcm43xx_mac80211

mac80211 147017 2 rc80211_simple,bcm43xx_mac80211

 

uname -a

Linux laptop 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:10:34 EDT 2007 i686 i686 i386 GNU/Linux

 

 

However, internet is SLOW because I am only getting 1mb/s because of this driver! How can I not go back to ndiswrapper???

Bit Rate=1 Mb/s from iwconfig

Link to post
Share on other sites

Randall's and anyweb's instructions work for me (Fedora 7, 2.6.22-1-41.fc7, new Dell Latitude D520 with the BCM4311/BCM2050 chipset)... BUT it is painfully slow... worse than dial-up.

 

I saw some rumors elsewhere that there are problems prior to 2.6.22rc4 (http://lists.berlios.de/pipermail/bcm43xx-dev/2007-June/004859.html).

 

Any thoughts? Sounds like I'm not the only one with speed problems.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...