Jump to content
metalx

no remote after reboot

Recommended Posts

I'm trying to setup a Fedora 8 pc to run as a headless server (5 clients max) more of a project than anything. Problem is, when I reboot the computer it wont let me ssh or xdmcp into the pc until I physically goto the computer and login locally once, then everything works fine. Really quite confused here. Ports open of note are: tcp 22, tcp/udp 177,16001, 6000-6015, 35091. I guess my question is whats preventing me from connecting? Is there a default refuse all connections on boot and to bypass it I have to log in to load up my own configuration?

:ph34r:

Share this post


Link to post
Share on other sites

is selinux enabled or disabled ?

Share this post


Link to post
Share on other sites
is selinux enabled or disabled ?

I just check it and it's been in permissive mode since I installed. I thought that, that was what was the problem.

Share this post


Link to post
Share on other sites

so is the problem selinux related or not, i didn't quite understand your reply

Share this post


Link to post
Share on other sites
so is the problem selinux related or not, i didn't quite understand your reply

 

Sorry. From what I understand permissive just logs whats going, doesn't stop it. So i'm going to say that it probably isn't selinux. I'll disable it anyway to see if it'll change anything and get back to you.

Share this post


Link to post
Share on other sites

I've been doing a little research into this :ph34r: and it seems that the network connection isn't comming up on boot even though it shows the step in the start up script (Fedora 8). First tryed to connect to the server while I ran wireshark and the server didn't respond to any of the arp request. Then I ran a few ping sweeps to see what was on the network and it didn't show up. So it seems that when I log in locally on the computer it finishes Establishing a connection allowing me to remote into it after. :huh:

What I can't figure out now is why it still isn't connecting properly after a reboot.

I output a file listing all the services I'm running on startup (unfortunatly I couldn't attach it because the directory isn't writeable):

 

 

ConsoleKit 0:off 1:off 2:on 3:on 4:on 5:on 6:off

NetworkManager 0:off 1:off 2:on 3:on 4:on 5:on 6:off

NetworkManagerDispatcher 0:off 1:off 2:off 3:off 4:off 5:on 6:off

acpid 0:off 1:off 2:on 3:on 4:on 5:on 6:off

anacron 0:off 1:off 2:on 3:on 4:on 5:on 6:off

atd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

auditd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

avahi-daemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

bluetooth 0:off 1:off 2:on 3:on 4:on 5:off 6:off

capi 0:off 1:off 2:off 3:off 4:off 5:off 6:off

cpuspeed 0:off 1:on 2:on 3:on 4:on 5:on 6:off

crond 0:off 1:off 2:on 3:on 4:on 5:on 6:off

cups 0:off 1:off 2:on 3:on 4:on 5:on 6:off

dund 0:off 1:off 2:off 3:off 4:off 5:off 6:off

fedora-live 0:off 1:off 2:off 3:on 4:on 5:on 6:off

firstboot 0:off 1:off 2:off 3:on 4:off 5:on 6:off

gpm 0:off 1:off 2:on 3:on 4:on 5:off 6:off

haldaemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

httpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

ip6tables 0:off 1:off 2:on 3:on 4:on 5:off 6:off

iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

irda 0:off 1:off 2:off 3:off 4:off 5:off 6:off

irqbalance 0:off 1:off 2:off 3:on 4:on 5:on 6:off

isdn 0:off 1:off 2:on 3:on 4:on 5:on 6:off

kudzu 0:off 1:off 2:off 3:on 4:on 5:on 6:off

lm_sensors 0:off 1:off 2:off 3:off 4:off 5:off 6:off

mdmonitor 0:off 1:off 2:on 3:on 4:on 5:on 6:off

messagebus 0:off 1:off 2:on 3:on 4:on 5:on 6:off

microcode_ctl 0:off 1:off 2:on 3:on 4:on 5:on 6:off

multipathd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

netconsole 0:off 1:off 2:off 3:off 4:off 5:on 6:off

netfs 0:off 1:off 2:off 3:on 4:on 5:on 6:off

netplugd 0:off 1:off 2:off 3:off 4:off 5:on 6:off

network 0:off 1:off 2:off 3:off 4:off 5:on 6:off

nfs 0:off 1:off 2:off 3:off 4:off 5:off 6:off

nfslock 0:off 1:off 2:off 3:on 4:on 5:on 6:off

nmb 0:off 1:off 2:off 3:off 4:off 5:on 6:off

nscd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

ntpd 0:off 1:off 2:off 3:on 4:off 5:on 6:off

openvpn 0:off 1:off 2:off 3:off 4:off 5:off 6:off

pand 0:off 1:off 2:off 3:off 4:off 5:off 6:off

psacct 0:off 1:off 2:off 3:off 4:off 5:off 6:off

pure-ftpd 0:off 1:off 2:off 3:off 4:off 5:on 6:off

radiusd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

rdisc 0:off 1:off 2:off 3:off 4:off 5:off 6:off

restorecond 0:off 1:off 2:on 3:on 4:on 5:on 6:off

rpcbind 0:off 1:off 2:on 3:on 4:on 5:on 6:off

rpcgssd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

rpcidmapd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

rpcsvcgssd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

rsyslog 0:off 1:off 2:on 3:on 4:on 5:on 6:off

saslauthd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off

setroubleshoot 0:off 1:off 2:off 3:on 4:on 5:on 6:off

smartd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

smb 0:off 1:off 2:off 3:on 4:off 5:on 6:off

smolt 0:off 1:off 2:on 3:on 4:on 5:on 6:off

snmpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

snmptrapd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

sshd 0:off 1:off 2:off 3:on 4:off 5:on 6:off

udev-post 0:off 1:off 2:off 3:on 4:on 5:on 6:off

vsftpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

winbind 0:off 1:off 2:off 3:on 4:off 5:off 6:off

wpa_supplicant 0:off 1:off 2:off 3:off 4:off 5:off 6:off

ypbind 0:off 1:off 2:off 3:off 4:off 5:off 6:off

yum-updatesd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

Share this post


Link to post
Share on other sites
network 0:off 1:off 2:off 3:off 4:off 5:on 6:off

 

Off on all run levels except for 5. What runlevel are you on by default? A remote server.. I'd expect it to be 3. Even then its unusual for the network to be off on 2, 3 and 4?

 

Further .. why is iptables on with levels 3 and 4 .. when the network is off?

ip6tables 0:off 1:off 2:on 3:on 4:on 5:off 6:off

iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

 

So my guess is that you need to enable your network for runlevels 2, 3 and 4.

 

If you agree then:

 

# chkconfig --level 234 network on

 

Should fix it. Maybe checking your iptables to find out whats in there if its still broken?

Share this post


Link to post
Share on other sites

Alright lets see if I can answer all your questions. Fist off the server is currently run in run level 5 because it's at my girlfriends house and the motherboard on there pc is shot so there also using my computer for everyday tasks,for now. Also, I'm not 100 % comfortable in console, though I spend most of my time in there anyway.

Next, the fact that only run level 5 was the only one with networking on is because I activated it through the services gui and didn't bother changing the other run levels. So now 234 & 5 all have network service running but still no good. I rebooted the computer and tried to ssh into it and the connection timed out as it usually does after a reboot. After a reboot and before a log in the computer wont even respond to a ping. I'm running out of ideas so if there are logs that my help let me know so I can post them.

Thanks for the help

Share this post


Link to post
Share on other sites

So I think I figured out what was causing my lack of network problem...NetowrkManager. I'm not sure how it was preventing connections right after a reboot but I turned it off and reboot and I can still connect.

 

Thanks for all the help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...