Jump to content

vsftpd access remotely

Recommended Posts

You can find out your public IP address using a site such as http://checkip.dyndns.org.


You may also need to forward the FTP port (21) on your router so that people outside your local area network can actually get to the right machine when they try to access port 21 of your public IP. This process depends on your router, but you

Link to post
Share on other sites

Hi thanks for that.


though i couldnt still access it from the "outside world" using the public ip.


I added ftp to the virtual server,






I can still access it from the internal network on other computers, so this is still a router issue, or something related?


Also the firewall is completely off at the router for testing purposes,


Hope you can help soon,




Link to post
Share on other sites

From what I can see the screenshot shows those settings to be what I would expect to work.


So, a few more diagnosis questions:


  1. What make/model of router are you using?
  2. Which Linux distro are you using? Is there a client firewall running on your local OS?
  3. Use a service such as Shields Up and test 'All Service Ports'. When the scan finishes, locate port 21 in the grid (hovering over shows you which port it is, and use guide numbers along the side). Is Port 21 open (red), closed (blue) or stealthed (green)?

Link to post
Share on other sites

You'll also need to open port 20 for FTP data.


Check the VSFTP settings that incoming connections use PORT (not PASV) - and that you've got that connection in your FTP client also.


Lastly, check the logfiles - /var/log/xfer.log or so - for information regarding incoming connections. Usually they can tell you what is/isn't working.


BTW - I've just tried connecting on 124.171.*.* (your reported IP address) and I didn't get any response, so it looks like it's not NATing through correctly.


The last place I'd check is your firewall rules on the server itself - it may permit FTP connections from the LAN but not the WAN.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...