Jump to content
anyweb

error while trying yum update

Recommended Posts

today i was trying to update the centos server when i got this

 

Resolving Dependencies

--> Running transaction check

---> Package kernel.i686 0:2.6.18-194.3.1.el5 set to be installed

---> Package kernel-devel.i686 0:2.6.18-194.3.1.el5 set to be installed

---> Package kernel-headers.i386 0:2.6.18-194.3.1.el5 set to be updated

---> Package lvm2.i386 0:2.02.56-8.el5_5.1 set to be updated

--> Processing Dependency: device-mapper >= 1.02.39-1 for package: lvm2

---> Package mkinitrd.i386 0:5.1.19.6-61.el5_5.1 set to be updated

---> Package nash.i386 0:5.1.19.6-61.el5_5.1 set to be updated

---> Package nss_db.i386 0:2.2-35.4.el5_5 set to be updated

---> Package sudo.i386 0:1.7.2p1-6.el5_5 set to be updated

---> Package tzdata.i386 0:2010i-1.el5 set to be updated

--> Finished Dependency Resolution

lvm2-2.02.56-8.el5_5.1.i386 from updates has depsolving problems

--> Missing Dependency: device-mapper >= 1.02.39-1 is needed by package lvm2-2.02.56-8.el5_5.1.i386 (updates)

--> Running transaction check

---> Package kernel.i686 0:2.6.18-164.9.1.el5 set to be erased

---> Package kernel-devel.i686 0:2.6.18-164.9.1.el5 set to be erased

---> Package lvm2.i386 0:2.02.56-8.el5_5.1 set to be updated

--> Processing Dependency: device-mapper >= 1.02.39-1 for package: lvm2

--> Finished Dependency Resolution

lvm2-2.02.56-8.el5_5.1.i386 from updates has depsolving problems

--> Missing Dependency: device-mapper >= 1.02.39-1 is needed by package lvm2-2.02.56-8.el5_5.1.i386 (updates)

Error: Missing Dependency: device-mapper >= 1.02.39-1 is needed by package lvm2-2.02.56-8.el5_5.1.i386 (updates)

You could try using --skip-broken to work around the problem

You could try running: package-cleanup --problems

package-cleanup --dupes

rpm -Va --nofiles --nodigest

The program package-cleanup is found in the yum-utils package.

 

this is the linux-noob.com server so i'm wary of making any mistakes,

 

[root@linux-noob ~]# cat /etc/redhat-release

CentOS release 5.4 (Final)

 

any advise as to the best way of resolving the problem above ?

Share this post


Link to post
Share on other sites

how odd, tried the same command some hours later and it went through no problem

must have been a glitch

 

Transaction Summary

===========================================================================================================================

Install 4 Package(s)

Update 125 Package(s)

Remove 2 Package(s)

 

Total download size: 131 M

Downloading Packages:

(1/129): avahi-glib-0.6.16-7.el5.i386.rpm | 15 kB 00:00

(2/129): libXrandr-1.1.1-3.3.i386.rpm | 15 kB 00:00

(3/129): libacl-2.2.39-6.el5.i386.rpm | 19 kB 00:00

(4/129): centos-release-5-5.el5.centos.i386.rpm | 19 kB 00:00

(5/129): libaio-0.3.106-5.i386.rpm | 19 kB 00:00

(6/129): device-mapper-event-1.02.39-1.el5.i386.rpm | 20 kB 00:00

(7/129): hmaccalc-0.9.6-3.el5.i386.rpm | 21 kB 00:00

(8/129): avahi-compat-libdns_sd-0.6.16-7.el5.i386.rpm | 23 kB 00:00

(9/129): pcsc-lite-libs-1.4.4-1.el5.i386.rpm | 23 kB 00:00

(10/129): dmraid-events-1.0.0.rc13-63.el5.i386.rpm | 24 kB 00:00

(11/129): ntsysv-1.3.30.2-2.el5.i386.rpm | 24 kB 00:00

(12/129): iptstate-1.4-2.el5.i386.rpm | 27 kB 00:00

(13/129): cpuspeed-1.2.1-9.el5.i386.rpm | 32 kB 00:00

(14/129): paps-0.6.6-19.el5.i386.rpm | 33 kB 00:00

(15/129): centos-release-notes-5.5-0.i386.rpm | 40 kB 00:00

(16/129): libhugetlbfs-1.3-7.el5.i386.rpm | 42 kB 00:00

(17/129): numactl-0.9.8-11.el5.i386.rpm | 45 kB 00:00

(18/129): readahead-1.3-8.el5.i386.rpm | 47 kB 00:00

(19/129): vconfig-1.9-3.i386.rpm | 55 kB 00:00

(20/129): at-3.1.8-84.el5.i386.rpm | 56 kB 00:00

(21/129): pax-3.4-2.el5_4.i386.rpm | 63 kB 00:00

(22/129): ethtool-6-4.el5.i386.rpm | 63 kB 00:00

(23/129): php-pdo-5.1.6-27.el5.i386.rpm | 65 kB 00:00

(24/129): acl-2.2.39-6.el5.i386.rpm | 68 kB 00:00

(25/129): yp-tools-2.9-1.el5.i386.rpm | 71 kB 00:00

(26/129): dosfstools-2.11-9.el5.i386.rpm | 72 kB 00:00

(27/129): poppler-utils-0.5.4-4.4.el5_4.11.i386.rpm | 72 kB 00:00

(28/129): dmidecode-2.10-3.el5.i386.rpm | 74 kB 00:00

(29/129): sysklogd-1.4.1-46.el5.i386.rpm | 74 kB 00:00

(30/129): audit-libs-1.7.17-3.el5.i386.rpm | 78 kB 00:00

(31/129): audit-libs-python-1.7.17-3.el5.i386.rpm | 79 kB 00:00

(32/129): apr-util-1.2.7-11.el5.i386.rpm | 80 kB 00:00

(33/129): NetworkManager-glib-0.7.0-10.el5.i386.rpm | 82 kB 00:00

(34/129): pciutils-2.2.3-8.el5_4.i386.rpm | 83 kB 00:00

(35/129): php-mysql-5.1.6-27.el5.i386.rpm | 86 kB 00:00

(36/129): coolkey-1.1.0-14.el5.i386.rpm | 91 kB 00:00

(37/129): libgcc-4.1.2-48.el5.i386.rpm | 95 kB 00:00

(38/129): php-xml-5.1.6-27.el5.i386.rpm | 96 kB 00:00

(39/129): less-436-2.el5.i386.rpm | 105 kB 00:00

(40/129): libpcap-0.9.4-15.el5.i386.rpm | 108 kB 00:00

(41/129): newt-0.52.2-15.el5.i386.rpm | 111 kB 00:00

(42/129): libevent-1.4.13-1.i386.rpm | 112 kB 00:00

(43/129): php-gd-5.1.6-27.el5.i386.rpm | 117 kB 00:00

(44/129): pcsc-lite-1.4.4-1.el5.i386.rpm | 123 kB 00:00

(45/129): dhcpv6-client-1.0.10-18.el5.i386.rpm | 123 kB 00:00

(46/129): dbus-libs-1.1.2-14.el5.i386.rpm | 123 kB 00:00

(47/129): libsepol-1.15.2-3.el5.i386.rpm | 128 kB 00:00

(48/129): pam_krb5-2.2.14-15.i386.rpm | 136 kB 00:00

(49/129): sos-1.7-9.49.el5.noarch.rpm | 147 kB 00:00

(50/129): php-common-5.1.6-27.el5.i386.rpm | 152 kB 00:00

(51/129): chkconfig-1.3.30.2-2.el5.i386.rpm | 157 kB 00:00

(52/129): nscd-2.5-49.i386.rpm | 163 kB 00:00

(53/129): libXt-1.0.2-3.2.el5.i386.rpm | 173 kB 00:00

(54/129): libsepol-devel-1.15.2-3.el5.i386.rpm | 187 kB 00:00

(55/129): firstboot-tui-1.4.27.8-1.el5.centos.i386.rpm | 189 kB 00:00

(56/129): cups-libs-1.3.7-18.el5.i386.rpm | 197 kB 00:00

(57/129): procps-3.2.7-16.el5.i386.rpm | 211 kB 00:00

(58/129): kudzu-1.2.57.1.24-1.el5.centos.i386.rpm | 223 kB 00:00

(59/129): sudo-1.7.2p1-6.el5_5.i386.rpm | 230 kB 00:00

(60/129): curl-7.15.5-9.el5.i386.rpm | 233 kB 00:00

(61/129): dbus-1.1.2-14.el5.i386.rpm | 235 kB 00:00

(62/129): logwatch-7.3-8.el5.noarch.rpm | 243 kB 00:00

(63/129): avahi-0.6.16-7.el5.i386.rpm | 250 kB 00:00

(64/129): checkpolicy-1.33.1-6.el5.i386.rpm | 251 kB 00:00

(65/129): system-config-securitylevel-tui-1.6.29.1-5.el5.i386.rpm | 253 kB 00:00

(66/129): wpa_supplicant-0.5.10-9.el5.i386.rpm | 258 kB 00:00

(67/129): openssh-server-4.3p2-41.el5.i386.rpm | 269 kB 00:00

(68/129): dhclient-3.0.5-23.el5.i386.rpm | 276 kB 00:00

(69/129): openssh-4.3p2-41.el5.i386.rpm | 287 kB 00:00

(70/129): openldap-2.3.43-12.el5.i386.rpm | 294 kB 00:00

(71/129): net-tools-1.60-81.el5.i386.rpm | 360 kB 00:00

(72/129): audit-1.7.17-3.el5.i386.rpm | 361 kB 00:00

(73/129): libstdc++-4.1.2-48.el5.i386.rpm | 362 kB 00:00

(74/129): hwdata-0.213.18-1.el5.1.noarch.rpm | 380 kB 00:00

(75/129): nfs-utils-1.0.9-44.el5.i386.rpm | 381 kB 00:00

(76/129): hal-0.5.8.1-59.el5.i386.rpm | 389 kB 00:00

(77/129): selinux-policy-2.4.6-279.el5.noarch.rpm | 405 kB 00:00

(78/129): kpartx-0.4.7-34.el5.i386.rpm | 406 kB 00:00

(79/129): module-init-tools-3.3-0.pre3.1.60.el5.i386.rpm | 420 kB 00:00

(80/129): tcpdump-3.9.4-15.el5.i386.rpm | 447 kB 00:00

(81/129): openssh-clients-4.3p2-41.el5.i386.rpm | 448 kB 00:00

(82/129): mesa-libGL-devel-6.5.1-7.8.el5.i386.rpm | 461 kB 00:00

(83/129): tcsh-6.14-17.el5.i386.rpm | 464 kB 00:00

(84/129): mkinitrd-5.1.19.6-61.el5_5.1.i386.rpm | 467 kB 00:00

(85/129): automake-1.9.6-2.3.el5.noarch.rpm | 476 kB 00:00

(86/129): parted-1.8.1-27.el5.i386.rpm | 541 kB 00:00

(87/129): microcode_ctl-1.17-1.50.el5.i386.rpm | 558 kB 00:00

(88/129): glibc-headers-2.5-49.i386.rpm | 601 kB 00:00

(89/129): policycoreutils-1.33.12-14.8.el5.i386.rpm | 619 kB 00:00

(90/129): sendmail-8.13.8-8.el5.i386.rpm | 623 kB 00:00

(91/129): device-mapper-1.02.39-1.el5.i386.rpm | 719 kB 00:00

(92/129): dmraid-1.0.0.rc13-63.el5.i386.rpm | 725 kB 00:00

(93/129): tar-1.15.1-30.el5.i386.rpm | 747 kB 00:00

(94/129): nss_db-2.2-35.4.el5_5.i386.rpm | 763 kB 00:00

(95/129): tzdata-2010i-1.el5.i386.rpm | 793 kB 00:00

(96/129): iproute-2.6.18-11.el5.i386.rpm | 812 kB 00:00

(97/129): mdadm-2.6.9-3.el5.i386.rpm | 827 kB 00:00

(98/129): autofs-5.0.1-0.rc2.143.el5.i386.rpm | 887 kB 00:00

(99/129): php-mbstring-5.1.6-27.el5.i386.rpm | 995 kB 00:00

(100/129): yum-3.2.22-26.el5.centos.noarch.rpm | 1.0 MB 00:00

(101/129): filesystem-2.4.0-3.el5.i386.rpm | 1.0 MB 00:00

(102/129): shadow-utils-4.0.17-15.el5.i386.rpm | 1.0 MB 00:00

(103/129): kernel-headers-2.6.18-194.3.1.el5.i386.rpm | 1.0 MB 00:00

(104/129): NetworkManager-0.7.0-10.el5.i386.rpm | 1.0 MB 00:00

(105/129): nash-5.1.19.6-61.el5_5.1.i386.rpm | 1.1 MB 00:00

(106/129): selinux-policy-targeted-2.4.6-279.el5.noarch.rpm | 1.2 MB 00:00

(107/129): ksh-20100202-1.el5.i386.rpm | 1.2 MB 00:00

(108/129): httpd-2.2.3-43.el5.centos.i386.rpm | 1.2 MB 00:00

(109/129): gnome-vfs2-2.16.2-6.el5.i386.rpm | 1.2 MB 00:00

(110/129): nss_ldap-253-25.el5.i386.rpm | 1.4 MB 00:00

(111/129): crash-4.1.2-4.el5.centos.i386.rpm | 1.5 MB 00:00

(112/129): glibc-devel-2.5-49.i386.rpm | 2.0 MB 00:00

(113/129): php-cli-5.1.6-27.el5.i386.rpm | 2.1 MB 00:00

(114/129): php-5.1.6-27.el5.i386.rpm | 2.3 MB 00:00

(115/129): lvm2-2.02.56-8.el5_5.1.i386.rpm | 2.5 MB 00:00

(116/129): cpp-4.1.2-48.el5.i386.rpm | 2.6 MB 00:00

(117/129): device-mapper-multipath-0.4.7-34.el5.i386.rpm | 2.8 MB 00:00

(118/129): libstdc++-devel-4.1.2-48.el5.i386.rpm | 2.8 MB 00:00

(119/129): binutils-2.17.50.0.6-14.el5.i386.rpm | 3.0 MB 00:00

(120/129): poppler-0.5.4-4.4.el5_4.11.i386.rpm | 3.0 MB 00:00

(121/129): cups-1.3.7-18.el5.i386.rpm | 3.1 MB 00:00

(122/129): gcc-c++-4.1.2-48.el5.i386.rpm | 3.4 MB 00:00

(123/129): man-pages-2.39-15.el5_4.noarch.rpm | 4.2 MB 00:00

(124/129): gcc-4.1.2-48.el5.i386.rpm | 5.2 MB 00:00

(125/129): glibc-2.5-49.i686.rpm | 5.2 MB 00:00

(126/129): kernel-devel-2.6.18-194.3.1.el5.i686.rpm | 5.4 MB 00:00

(127/129): mesa-libGL-6.5.1-7.8.el5.i386.rpm | 9.6 MB 00:01

(128/129): glibc-common-2.5-49.i386.rpm | 16 MB 00:01

(129/129): kernel-2.6.18-194.3.1.el5.i686.rpm | 17 MB 00:01

---------------------------------------------------------------------------------------------------------------------------

Total 6.7 MB/s | 131 MB 00:19

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

Updating : kernel-headers 1/256

Updating : tzdata 2/256

Updating : glibc-common 3/256

Updating : filesystem 4/256

Updating : centos-release-notes 5/256

Updating : automake 6/256

Updating : nash 7/256

Updating : centos-release 8/256

Updating : logwatch 9/256

Updating : yum 10/256

Updating : man-pages 11/256

Installing : kernel-devel 12/256

Updating : libgcc 13/256

Updating : glibc 14/256

Updating : chkconfig 15/256

Updating : audit-libs 16/256

Updating : libsepol 17/256

Updating : device-mapper 18/256

Updating : openldap 19/256

Updating : shadow-utils 20/256

Updating : libstdc++ 21/256

Updating : libacl 22/256

Updating : php-common 23/256

warning: /etc/php.ini created as /etc/php.ini.rpmnew

Updating : kpartx 24/256

Updating : binutils 25/256

Updating : cups-libs 26/256

Updating : curl 27/256

Updating : newt 28/256

Updating : procps 29/256

Updating : tar 30/256

Updating : apr-util 31/256

Updating : pcsc-lite-libs 32/256

Updating : mesa-libGL 33/256

Updating : httpd 34/256

Updating : system-config-securitylevel-tui 35/256

Updating : ntsysv 36/256

Updating : paps 37/256

Updating : device-mapper-multipath 38/256

Updating : php-pdo 39/256

Updating : sendmail 40/256

Updating : nscd 41/256

Updating : device-mapper-event 42/256

Updating : lvm2 43/256

Updating : openssh 44/256

Updating : audit-libs-python 45/256

Updating : policycoreutils 46/256

Updating : pcsc-lite 47/256

Updating : libevent 48/256

Updating : dmidecode 49/256

Updating : dhclient 50/256

Updating : iproute 51/256

Updating : hmaccalc 52/256

Updating : coolkey 53/256

Updating : nss_ldap 54/256

Updating : php-cli 55/256

Installing : poppler 56/256

Installing : poppler-utils 57/256

Updating : parted 58/256

Updating : libpcap 59/256

Updating : pam_krb5 60/256

Updating : numactl 61/256

Updating : libXt 62/256

Updating : cpp 63/256

Updating : nss_db 64/256

Updating : libaio 65/256

Updating : libXrandr 66/256

Updating : php 67/256

Updating : openssh-clients 68/256

Updating : openssh-server 69/256

Updating : mdadm 70/256

Updating : php-mysql 71/256

Updating : readahead 72/256

Updating : autofs 73/256

Updating : crash 74/256

Updating : php-gd 75/256

Updating : php-xml 76/256

Updating : php-mbstring 77/256

Updating : acl 78/256

Updating : iptstate 79/256

Updating : tcpdump 80/256

Updating : sudo 81/256

Updating : audit 82/256

Updating : at 83/256

Updating : cpuspeed 84/256

Updating : microcode_ctl 85/256

Updating : net-tools 86/256

Updating : sysklogd 87/256

Updating : ksh 88/256

Updating : tcsh 89/256

Updating : ethtool 90/256

Updating : vconfig 91/256

Updating : libhugetlbfs 92/256

Updating : yp-tools 93/256

Updating : less 94/256

Updating : checkpolicy 95/256

Updating : dhcpv6-client 96/256

Updating : pax 97/256

Updating : dosfstools 98/256

Updating : glibc-headers 99/256

Updating : glibc-devel 100/256

Updating : selinux-policy 101/256

Updating : libstdc++-devel 102/256

Updating : selinux-policy-targeted 103/256

Updating : firstboot-tui 104/256

Updating : mesa-libGL-devel 105/256

Updating : sos 106/256

Updating : libsepol-devel 107/256

Updating : gcc 108/256

Updating : gcc-c++ 109/256

Updating : dbus-libs 110/256

Updating : dbus 111/256

Updating : hal 112/256

Updating : avahi 113/256

Updating : dmraid 114/256

Updating : mkinitrd 115/256

Updating : module-init-tools 116/256

Updating : avahi-compat-libdns_sd 117/256

Updating : avahi-glib 118/256

Updating : wpa_supplicant 119/256

Updating : dmraid-events 120/256

Updating : gnome-vfs2 121/256

Updating : cups 122/256

Updating : nfs-utils 123/256

Updating : hwdata 124/256

Installing : kernel 125/256

Updating : kudzu 126/256

Updating : pciutils 127/256

Updating : NetworkManager 128/256

Updating : NetworkManager-glib 129/256

Cleanup : pcsc-lite 130/256

Cleanup : iptstate 131/256

Cleanup : kudzu 132/256

Cleanup : policycoreutils 133/256

Cleanup : tcsh 134/256

Cleanup : ethtool 135/256

Cleanup : kernel 136/256

Cleanup : hwdata 137/256

Cleanup : at 138/256

Cleanup : mesa-libGL-devel 139/256

Cleanup : php-pdo 140/256

Cleanup : libevent 141/256

Cleanup : libsepol-devel 142/256

Cleanup : cpuspeed 143/256

Cleanup : readahead 144/256

Cleanup : dbus 145/256

Cleanup : glibc-devel 146/256

Cleanup : nfs-utils 147/256

Cleanup : NetworkManager-glib 148/256

Cleanup : php 149/256

Cleanup : tcpdump 150/256

Cleanup : binutils 151/256

Cleanup : php-gd 152/256

Cleanup : libpcap 153/256

Cleanup : pam_krb5 154/256

Cleanup : libacl 155/256

Cleanup : openssh-clients 156/256

Cleanup : vconfig 157/256

Cleanup : kpartx 158/256

Cleanup : libhugetlbfs 159/256

Cleanup : numactl 160/256

Cleanup : hal 161/256

Cleanup : yp-tools 162/256

Cleanup : mkinitrd 163/256

Cleanup : less 164/256

Cleanup : autofs 165/256

Cleanup : coolkey 166/256

Cleanup : avahi 167/256

Cleanup : checkpolicy 168/256

Cleanup : libXt 169/256

Cleanup : firstboot-tui 170/256

Cleanup : lvm2 171/256

Cleanup : pcsc-lite-libs 172/256

Cleanup : man-pages 173/256

Cleanup : cups 174/256

Cleanup : yum 175/256

Cleanup : kernel-devel 176/256

Cleanup : microcode_ctl 177/256

Cleanup : openssh 178/256

Cleanup : cups-libs 179/256

Cleanup : gcc-c++ 180/256

Cleanup : tar 181/256

Cleanup : net-tools 182/256

Cleanup : php-xml 183/256

Cleanup : openssh-server 184/256

Cleanup : dbus-libs 185/256

Cleanup : centos-release-notes 186/256

Cleanup : centos-release 187/256

Cleanup : crash 188/256

Cleanup : openldap 189/256

Cleanup : filesystem 190/256

Cleanup : sos 191/256

Cleanup : php-mysql 192/256

Cleanup : tzdata 193/256

Cleanup : logwatch 194/256

Cleanup : audit 195/256

Cleanup : libstdc++-devel 196/256

Cleanup : dmidecode 197/256

Cleanup : acl 198/256

Cleanup : glibc-headers 199/256

Cleanup : dmraid-events 200/256

Cleanup : curl 201/256

Cleanup : gnome-vfs2 202/256

Cleanup : php-cli 203/256

Cleanup : nash 204/256

Cleanup : sendmail 205/256

Cleanup : system-config-securitylevel-tui 206/256

Cleanup : audit-libs 207/256

Cleanup : shadow-utils 208/256

Cleanup : dmraid 209/256

Cleanup : cpp 210/256

Cleanup : httpd 211/256

Cleanup : mdadm 212/256

Cleanup : wpa_supplicant 213/256

Cleanup : dhclient 214/256

Cleanup : php-mbstring 215/256

Cleanup : nss_db 216/256

Cleanup : libaio 217/256

Cleanup : mesa-libGL 218/256

Cleanup : NetworkManager 219/256

Cleanup : nss_ldap 220/256

Cleanup : apr-util 221/256

Cleanup : sysklogd 222/256

Cleanup : module-init-tools 223/256

Cleanup : newt 224/256

Cleanup : dhcpv6-client 225/256

Cleanup : nscd 226/256

Cleanup : paps 227/256

Cleanup : ntsysv 228/256

Cleanup : ksh 229/256

Cleanup : procps 230/256

Cleanup : chkconfig 231/256

Cleanup : pax 232/256

Cleanup : libstdc++ 233/256

Cleanup : automake 234/256

Cleanup : glibc-common 235/256

Cleanup : dosfstools 236/256

Cleanup : kernel-headers 237/256

Cleanup : pciutils 238/256

Cleanup : sudo 239/256

Cleanup : avahi-compat-libdns_sd 240/256

Cleanup : libsepol 241/256

Cleanup : libgcc 242/256

Cleanup : libXrandr 243/256

Cleanup : iproute 244/256

Cleanup : glibc 245/256

Cleanup : gcc 246/256

Cleanup : device-mapper 247/256

Cleanup : selinux-policy-targeted 248/256

Cleanup : audit-libs-python 249/256

Cleanup : avahi-glib 250/256

Cleanup : device-mapper-event 251/256

Cleanup : hmaccalc 252/256

Cleanup : php-common 253/256

Cleanup : selinux-policy 254/256

Cleanup : parted 255/256

Cleanup : device-mapper-multipath 256/256

 

Removed:

kernel.i686 0:2.6.18-164.9.1.el5 kernel-devel.i686 0:2.6.18-164.9.1.el5

 

Installed:

kernel.i686 0:2.6.18-194.3.1.el5 kernel-devel.i686 0:2.6.18-194.3.1.el5

 

Dependency Installed:

poppler.i386 0:0.5.4-4.4.el5_4.11 poppler-utils.i386 0:0.5.4-4.4.el5_4.11

 

Updated:

NetworkManager.i386 1:0.7.0-10.el5 NetworkManager-glib.i386 1:0.7.0-10.el5

acl.i386 0:2.2.39-6.el5 apr-util.i386 0:1.2.7-11.el5

at.i386 0:3.1.8-84.el5 audit.i386 0:1.7.17-3.el5

audit-libs.i386 0:1.7.17-3.el5 audit-libs-python.i386 0:1.7.17-3.el5

autofs.i386 1:5.0.1-0.rc2.143.el5 automake.noarch 0:1.9.6-2.3.el5

avahi.i386 0:0.6.16-7.el5 avahi-compat-libdns_sd.i386 0:0.6.16-7.el5

avahi-glib.i386 0:0.6.16-7.el5 binutils.i386 0:2.17.50.0.6-14.el5

centos-release.i386 10:5-5.el5.centos centos-release-notes.i386 0:5.5-0

checkpolicy.i386 0:1.33.1-6.el5 chkconfig.i386 0:1.3.30.2-2.el5

coolkey.i386 0:1.1.0-14.el5 cpp.i386 0:4.1.2-48.el5

cpuspeed.i386 1:1.2.1-9.el5 crash.i386 0:4.1.2-4.el5.centos

cups.i386 1:1.3.7-18.el5 cups-libs.i386 1:1.3.7-18.el5

curl.i386 0:7.15.5-9.el5 dbus.i386 0:1.1.2-14.el5

dbus-libs.i386 0:1.1.2-14.el5 device-mapper.i386 0:1.02.39-1.el5

device-mapper-event.i386 0:1.02.39-1.el5 device-mapper-multipath.i386 0:0.4.7-34.el5

dhclient.i386 12:3.0.5-23.el5 dhcpv6-client.i386 0:1.0.10-18.el5

dmidecode.i386 1:2.10-3.el5 dmraid.i386 0:1.0.0.rc13-63.el5

dmraid-events.i386 0:1.0.0.rc13-63.el5 dosfstools.i386 0:2.11-9.el5

ethtool.i386 0:6-4.el5 filesystem.i386 0:2.4.0-3.el5

firstboot-tui.i386 0:1.4.27.8-1.el5.centos gcc.i386 0:4.1.2-48.el5

gcc-c++.i386 0:4.1.2-48.el5 glibc.i686 0:2.5-49

glibc-common.i386 0:2.5-49 glibc-devel.i386 0:2.5-49

glibc-headers.i386 0:2.5-49 gnome-vfs2.i386 0:2.16.2-6.el5

hal.i386 0:0.5.8.1-59.el5 hmaccalc.i386 0:0.9.6-3.el5

httpd.i386 0:2.2.3-43.el5.centos hwdata.noarch 0:0.213.18-1.el5.1

iproute.i386 0:2.6.18-11.el5 iptstate.i386 0:1.4-2.el5

kernel-headers.i386 0:2.6.18-194.3.1.el5 kpartx.i386 0:0.4.7-34.el5

ksh.i386 0:20100202-1.el5 kudzu.i386 0:1.2.57.1.24-1.el5.centos

less.i386 0:436-2.el5 libXrandr.i386 0:1.1.1-3.3

libXt.i386 0:1.0.2-3.2.el5 libacl.i386 0:2.2.39-6.el5

libaio.i386 0:0.3.106-5 libevent.i386 0:1.4.13-1

libgcc.i386 0:4.1.2-48.el5 libhugetlbfs.i386 0:1.3-7.el5

libpcap.i386 14:0.9.4-15.el5 libsepol.i386 0:1.15.2-3.el5

libsepol-devel.i386 0:1.15.2-3.el5 libstdc++.i386 0:4.1.2-48.el5

libstdc++-devel.i386 0:4.1.2-48.el5 logwatch.noarch 0:7.3-8.el5

lvm2.i386 0:2.02.56-8.el5_5.1 man-pages.noarch 0:2.39-15.el5_4

mdadm.i386 0:2.6.9-3.el5 mesa-libGL.i386 0:6.5.1-7.8.el5

mesa-libGL-devel.i386 0:6.5.1-7.8.el5 microcode_ctl.i386 1:1.17-1.50.el5

mkinitrd.i386 0:5.1.19.6-61.el5_5.1 module-init-tools.i386 0:3.3-0.pre3.1.60.el5

nash.i386 0:5.1.19.6-61.el5_5.1 net-tools.i386 0:1.60-81.el5

newt.i386 0:0.52.2-15.el5 nfs-utils.i386 1:1.0.9-44.el5

nscd.i386 0:2.5-49 nss_db.i386 0:2.2-35.4.el5_5

nss_ldap.i386 0:253-25.el5 ntsysv.i386 0:1.3.30.2-2.el5

numactl.i386 0:0.9.8-11.el5 openldap.i386 0:2.3.43-12.el5

openssh.i386 0:4.3p2-41.el5 openssh-clients.i386 0:4.3p2-41.el5

openssh-server.i386 0:4.3p2-41.el5 pam_krb5.i386 0:2.2.14-15

paps.i386 0:0.6.6-19.el5 parted.i386 0:1.8.1-27.el5

pax.i386 0:3.4-2.el5_4 pciutils.i386 0:2.2.3-8.el5_4

pcsc-lite.i386 0:1.4.4-1.el5 pcsc-lite-libs.i386 0:1.4.4-1.el5

php.i386 0:5.1.6-27.el5 php-cli.i386 0:5.1.6-27.el5

php-common.i386 0:5.1.6-27.el5 php-gd.i386 0:5.1.6-27.el5

php-mbstring.i386 0:5.1.6-27.el5 php-mysql.i386 0:5.1.6-27.el5

php-pdo.i386 0:5.1.6-27.el5 php-xml.i386 0:5.1.6-27.el5

policycoreutils.i386 0:1.33.12-14.8.el5 procps.i386 0:3.2.7-16.el5

readahead.i386 1:1.3-8.el5 selinux-policy.noarch 0:2.4.6-279.el5

selinux-policy-targeted.noarch 0:2.4.6-279.el5 sendmail.i386 0:8.13.8-8.el5

shadow-utils.i386 2:4.0.17-15.el5 sos.noarch 0:1.7-9.49.el5

sudo.i386 0:1.7.2p1-6.el5_5 sysklogd.i386 0:1.4.1-46.el5

system-config-securitylevel-tui.i386 0:1.6.29.1-5.el5 tar.i386 2:1.15.1-30.el5

tcpdump.i386 14:3.9.4-15.el5 tcsh.i386 0:6.14-17.el5

tzdata.i386 0:2010i-1.el5 vconfig.i386 0:1.9-3

wpa_supplicant.i386 1:0.5.10-9.el5 yp-tools.i386 0:2.9-1.el5

yum.noarch 0:3.2.22-26.el5.centos

 

Complete!

[root@linux-noob ~]# yum -y update

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

* addons: ftp.nluug.nl

* base: ftp.nluug.nl

* extras: ftp.nluug.nl

* updates: mirror.liteserver.nl

Setting up Update Process

No Packages marked for Update

[root@linux-noob ~]#

Share this post


Link to post
Share on other sites

Yeah, CentOS 5.5 was just released -- when I upgraded a couple of machines, not all of the mirrors were in perfect sync with each other and it had to retry a few packages. Things should be better now.

 

If you get problems with yum, it's often helpful to:

 

yum clean all
yum makecache

 

and then try again. At the very least, you'll often get directed to a different mirror which doesn't have the same problem.

Share this post


Link to post
Share on other sites

How did the 5.4->5.5 upgrade go, Pete?

 

Also: do you know if chroot has found its way into the openssh-server RPM yet? We've had to frig around with rebuilding an RPM which has forked dependencies outside of normal CentOS repos - we're now using rpmforge and jasonlitka.com (utterramblings) in order to get courier-imap on the server. I'm wary of heading down the Fedora route with this custom-building.

Share this post


Link to post
Share on other sites

How did the 5.4->5.5 upgrade go, Pete?

 

Also: do you know if chroot has found its way into the openssh-server RPM yet? We've had to frig around with rebuilding an RPM which has forked dependencies outside of normal CentOS repos - we're now using rpmforge and jasonlitka.com (utterramblings) in order to get courier-imap on the server. I'm wary of heading down the Fedora route with this custom-building.

 

The upgrade went very smoothly for me. I did have to run yum update twice, first to get the major batch of new upgrades and I ran it again after the reboot and it found an additional few (including an even newer kernel). I wasn't expecting that, perhaps the mirrors weren't still in perfect sync or something, but another reboot later and everything looks happy.

 

I'm not aware of chroot support for the OpenSSH server. I don't personally need it (I'm not in the same situation with courier-imap as I outsource all that email business to Google Apps ;) ). I feel your pain with having to install other repos to get stuff working. My focus with this machine is to keep things as simple and as 'stock' as possible, so I'm not loading anything on there that I'm not directly using! Sorry I can't be more help. :P

Share this post


Link to post
Share on other sites

okay, ta for that info. TBH I don't *really* need courier-imap, but I want to run squirrelmail on one of my servers as a fallback and want some IMAP server. Dovecot broke on me twice under Fedora, and I couldn't get cyrus to work properly, but courier seemed find under Fed. Just missing under CentOS! Gahhh!

Share this post


Link to post
Share on other sites

guys is their any compelling reason for me to ugprade this server to the newests centos ? i really couldn't handle any hassle right now

Share this post


Link to post
Share on other sites

guys is their any compelling reason for me to ugprade this server to the newests centos ? i really couldn't handle any hassle right now

 

Sorry, I thought you had managed to get the upgrade to complete the second time? If you're running CentOS 5.5 (cat /etc/*-release if you're not sure) and you don't get any updates showing up when you yum update, then everything should be fine to leave alone.

Share this post


Link to post
Share on other sites
[root@linux-noob ~]# cat /etc/redhat-release

CentOS release 5.5 (Final)

 

silly me, i missed that ! what an easy update :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...