Jump to content
Sign in to follow this  
Oroshi

UserDir - kept getting 403 Forbidden

Recommended Posts

hello,

 

My apache works fine for /var/www/html. so i want to make UserDir, /home/*/public_html

 

userdir mod.

 

<IfModule mod_userdir.c>
   #
   # UserDir is disabled by default since it can confirm the presence
   # of a username on the system (depending on home directory
   # permissions).
   #
   UserDir "enabled *"
   UserDir "disabled root"

   #
   # To enable requests to /~user/ to serve the user's public_html
   # directory, use this directive instead of "UserDir disable":
   # 
   UserDir public_html

</IfModule>

 

Directory

 

<Directory "/home/*/public_html">
       Options Indexes Includes FollowSymLinks
       
       AllowOverride None
       Allow from all
       Order deny,allow
</Directory>

<Directory "/home/*/public_html/cgi-bin">
       Options ExecCGI
       SetHandler cgi-script
</Directory>

 

public_html's chmod are: 775

 

it still Forbidden 403. is there is anything i must've missed out? or it need to change something?

 

it would be appreciate if you could help me out.

Share this post


Link to post
Share on other sites

chmod 711 /home/user

 

by default RH has the home dir's chmod to 700 and the apache user needs at least --x access to get into and dirs about the public_html dir

Share this post


Link to post
Share on other sites

ahh of course, i'm idiot! lol. i chmod the public_html as 755. but it had to chmod on home dir...

 

thanks mate! :)

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...