Jump to content
linux_nub

a noobish problem with Kubuntus terminal thing

Recommended Posts

Hi everyone. Its very nice to meet you. I have recently installed Kubuntu (my first time on Linux) and have struck a problem which hopefully you can help me with .. I am trying to install the Opera browser and I was told to open the terminal Konsole and type sudo apt-get install opera. Then it asked me for my password which is fine.

Now it reads ... package lists:Done .....building dependency tree ...reading state info:Done ...Package opera is not availabe but is referred to by another package ....may mean package is missing obsoleted etc

 

E:Package opera has no installation candidate

 

Thats it ^^ Do I have to have gdebi installed ( i dont know what that is ). On the Opera download page it had Debian package as the default so maybe if I just go ahead and download it I can save myself all this hassle ? I havent tried that yet because I dont want to mess up my newly formatted computer with half installed programs that I dont have the skills to uninstall.

 

I think ive bitten off more than i can chew with this Linux thing XD

But your help would really be appreciated

thank you.

 

*******

 

Also if you could tell me what browser is the best for linux and other basic hints that would be great :D

Share this post


Link to post
Share on other sites

Welcome to the forum smile.png

 

You can try doing the following:

 

download the .deb packages from here: http://www.opera.com/download/ to a location

go to terminal

sudo dpkg -i /path/to/package/opera.deb

 

or you can do

run in terminal: wget -O - http://deb.opera.com/archive.key | sudo apt-key add -

 

(forgot to add this) you still need to add to repository: like this

nano /etc/sources.list

add this line to the file: --> deb http://deb.opera.com/opera-beta/ stable non-free

ctrl+o to save

 

sudo apt-get update

sudo apt-get install opera

 

Hope that helps?

Share this post


Link to post
Share on other sites

"apt-get" is the way in which most stuff is installed under Kbuntu, so you're on the right track.

 

As Feedmebits mentioned up there, the first thing to do is an "apt-get update" to refresh your local databases with lists of software, i.e.:

sudo apt-get update
sudo apt-get install opera

(the "sudo" bit is just because normal users can't run those commands)

 

Another option is to look for "Software Management" under your "applications" menu. Usually you can find the package listed there, tick it and let it download and install. Again, if it's not listed, either you'll need to update your databases (command above) *or* you'll need to add another repository in, one that contains the packages you want.

 

If the former doesn't work, post back here and we'll take you though the latter.

Share this post


Link to post
Share on other sites

Welcome to the forum smile.png

 

You can try doing the following:

 

download the .deb packages from here: http://www.opera.com/download/ to a location

go to terminal

sudo dpkg -i opera.deb

 

or you can do

run in terminal: wget -O - http://deb.opera.com/archive.key | sudo apt-key add -

sudo apt-get update

sudo apt-get install opera

 

Hope that helps?

It does. I downloaded using the first method and the browser files are in home>downloads. But after entering that code ^ it replies: dpkg error processing opera.deb (--install--) Cannot process archive, no such file or directory ..

Am i right in thinking im in the wrong directory and it cant find it ? How do I get the konsole into the downloads directory?

Thanks alotbiggrin.pngbiggrin.png

Share this post


Link to post
Share on other sites

Welcome to the forum smile.png

 

You can try doing the following:

 

download the .deb packages from here: http://www.opera.com/download/ to a location

go to terminal

sudo dpkg -i opera.deb

 

or you can do

run in terminal: wget -O - http://deb.opera.com/archive.key | sudo apt-key add -

sudo apt-get update

sudo apt-get install opera

 

Hope that helps?

It does. I downloaded using the first method and the browser files are in home>downloads. But after entering that code ^ it replies: dpkg error processing opera.deb (--install--) Cannot process archive, no such file or directory ..

Am i right in thinking im in the wrong directory and it cant find it ? How do I get the konsole into the downloads directory?

Thanks alotbiggrin.pngbiggrin.png

 

try using this if you downloaded to downloads.

go to terminal:

 

sudo dpkg -i /home/username/Downloads/opera.deb

Share this post


Link to post
Share on other sites
"apt-get" is the way in which most stuff is installed under Kbuntu, so you're on the right track. As Feedmebits mentioned up there, the first thing to do is an "apt-get update" to refresh your local databases with lists of software, i.e.:
 sudo apt-get update sudo apt-get install opera 

(the "sudo" bit is just because normal users can't run those commands) Another option is to look for "Software Management" under your "applications" menu. Usually you can find the package listed there, tick it and let it download and install. Again, if it's not listed, either you'll need to update your databases (command above) *or* you'll need to add another repository in, one that contains the packages you want. If the former doesn't work, post back here and we'll take you though the latter.

Thanks Dave. "apt-get update"didnt change the response i was getting from the konsole. But in software management I can see what you mean about the packages that are availabe ( it has firefox etc but not opera and updating the database command didnt bring it up either, I suppose i'll have to search online for the Opera package ?

Share this post


Link to post
Share on other sites

Welcome to the forum smile.png

 

You can try doing the following:

 

download the .deb packages from here: http://www.opera.com/download/ to a location

go to terminal

sudo dpkg -i opera.deb

 

or you can do

run in terminal: wget -O - http://deb.opera.com/archive.key | sudo apt-key add -

sudo apt-get update

sudo apt-get install opera

 

Hope that helps?

It does. I downloaded using the first method and the browser files are in home>downloads. But after entering that code ^ it replies: dpkg error processing opera.deb (--install--) Cannot process archive, no such file or directory ..

Am i right in thinking im in the wrong directory and it cant find it ? How do I get the konsole into the downloads directory?

Thanks alotbiggrin.pngbiggrin.png

 

try using this if you downloaded to downloads.

go to terminal:

 

sudo dpkg -i /home/username/Downloads/opera.deb

dpkg error: unknown option-/

 

Thanks for the help guys, i'm gonna sleep on this one :D

Share this post


Link to post
Share on other sites

You'll get it smile.png let me show you, I got it to work.

1. goto http://www.opera.com/download/ and download the .deb package

2a. you can then use the Kubuntu software installer to install it and you'll need to give your password to install it

2b. or you can go to terminal and type: dpkg -i /path/to/package example: dpkg -i /home/feedmebits/Downloads/opera_11.51.1087_i386.deb

3. Voila it works biggrin.png

 

snapshot1.png

Share this post


Link to post
Share on other sites

I suppose i'll have to search online for the Opera package ?

That's kinda what APT does for you, but it searches specific servers (the APT repos).

 

If you've got your software management tool, there should be a button to add a new one. If so, click on it and add in:

http://deb.opera.com/opera/

Once that's done, a quick "apt-get update" will refresh your databases with the contents of Opera's repo. Then a "apt-get install opera" should pull down and install Opera directly from their servers.

 

The other alternative is Firefox, as suggested, but if you're more comfortable/familiar with Opera then one of those methods ought to do it.

 

- just as a final note: many "common" packages (think Firefox, Thunderbird, VLC, etc) find their way onto the Distro's official servers so a quick "apt-get install" pulls them down. In some cases, third-party packages (like Opera) aren't part of Kbuntu's distros by default, so you just need to "educate" apt into looking at additional locations is all. It's quite commonplace; don't feel that this is necessarily a noob thing, nor that this is the only time you'll have to do it!

 

Good luck!

Share this post


Link to post
Share on other sites

Done it guys, I searched in my start menu and there was Opera sleep.pngsleep.png hiding from me. This has been a successful 1st experinence for me on Linux and now i will try to learn more about the tools youve mentioned and get some real things done in Linux,

Cheers.

 

2qn2n94.jpg

Share this post


Link to post
Share on other sites

Glad you got it to work :) If you run across anything feel free to post and ask your questions here on the forums.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...